Wacom Control Panel
System Software
Score 82%
Description:

UPDATE New version is currently underway. I so far have better tablet detection, the new features of xsetwacom implemented, Intuos4 OLEDs working with both images, text and animations and application profiles that automatically switch the button configuration. Please hang in there everyone, I know the current version up here sucks and this overhaul is long overdue. Check back in a month or two.



THIS DOES NOT WORK WITH UBUNTU 11.04
I will fix the compatibility issues when I have the time to do so.

You can now easily configure a wacom tablet on linux!
This utility allows you to:
- Automatically detect and configure a wide range of wacom products
- Set custom key commands or mouse buttons to a tablet's shortcut buttons
- Set custom pressure curve on each of the tablet's input devices
- Automatically remembers and reapplies settings on startup
- At present, serial and bluetooth tablets are not yet supported. If it doesn't work for you, submit a comment on here so I can fix it.
- More features coming!

HOW TO INSTALL:
======================
Add the PPA to get the latest updates automatically!

sudo add-apt-repository ppa:hughescih/ppa && sudo apt-get update && sudo apt-get install wacom-utility


HOW TO USE PRESSURE SUPPORT IN GIMP:
====================================
1. Open GIMP
2. In the Edit menu, click on preferences
3. Click on Input Devices
4. Click on Configure Extended Input Devices
5. For the devices; stylus, eraser and cursor, set the Mode to 'Screen'
6. Click Save, then Ok and you're done!
Last changelog:

8 years ago

Update:
Version 1.20-1: Updated for Maverick. Now works on Ubuntu 10.10

Version 1.19-2: Added button mapping for CTE_440 tablets. (thanks to ABelliqueux for the contribution)

Version 1.18-2: Repackaged and being built on launchpad servers.

Version 1.17-1: Adds button-mapping support for DTZ-12wx, DTZ-20wsx, DTZ-21ux.

Version 1.16-1: Adds support for CTH-660 (Bamboo Pen and Touch)
Fixes support for all Cintiq models (report back any bugs people!)

Version 1.15-1: Adds support for CTH-460 (Bamboo Pen and Touch) tablets.

Version 1.14-1: Adds support for CTL-460 (Bamboo Pen) tablets.

Version 1.13-1: Fixes issue with button mapping on PTZ-431W tablets

Version 1.12-1: Adds support for Intuos 4. Let me know if you have any bugs with your intuos 4!

Version 1.11-1: Fixed some bugs that appeared due to 10.04.

Version 1.10-1: Fixed dependency that prevented install on Ubuntu 10.04.

Version 1.9-1: Removed xorg.conf configuration. Now works with HAL and the new hotplugging support.

Version 1.8-1: Fixed button map getting cropped by window border.

Version 1.7-1: Fixed button mapping for all Intuos 3 series tablets.

Version 1.6-1: Fixed bug where gtk button events were left unmapped, leading to changes going in the wrong place when modifying your pad settings.

Version 1.5-1: Fixed model info for CTF_430-U (Bamboo1)

Version 1.4-1: Fixes launcher to use any installed version of python, not just 2.5

Version 1.3-1: Further bugfixes

Version 1.2-1: Bugfix - Software now creates serverlayout section of xorg.conf if it doesn't exist.

eleefece

5 years ago

Hi.

Is there a way to tweak the mapping of the tablet like in the kcm-tablet?

http://kde-apps.org/content/show.php?content=114856

Report

gamamoto

5 years ago

It's ben almost a year since your last update and I'm sure many people are waiting for some news. Could you please tell us how is the project going ? Do you still work on it ? Do you need help ?

Best regards.

Report

C

qb89dragon

5 years ago

I'm sorry for the delay. I would love for someone to take over my work on this. I am no longer using Ubuntu any more as my career forced a switch over to Mac OS to develop iPhone apps. I will (time permitting) revisit this at some point in future if noone wants to take over the source. I can provide a github account if there is any interest.

Report

gpsvn

5 years ago

Knowing that you are working on a new version, I'd like to report some errors message when installing this software on Ubuntu 11.10


W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG D0D833F9AC15E7DE Launchpad latest Hugin builds
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG DFB844B8BB91632D Launchpad PPA for Weather Indicator Team
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package wacom-utility

Report

KozaG

6 years ago

After editing buttons the program does not save it. So basically I can't modify any pad keys.

Using Intuos4 L.

Also in case something not nice happens, how do I uninstall this program?

Report

C

qb89dragon

6 years ago

I'm currently working on a new version of this app. The current one is broken on most newer distros, as it says in the comments section above. If you are using Ubuntu, you can uninstall it through the software center, or leave it in there and it will update automatically when I have done the new version (that also supports intuos4 LEDs!)

Report

KozaG

6 years ago

If with your program you will be able to make my wacom work as it should be I would be VERY grateful! I've been struggling to get it work for many days now.

Can you give any schedule for up-coming up-date, a week, a month?

Report

C

qb89dragon

6 years ago

Going on a couple months now that I haven't had any time to work on it unfortunately. You can check out the xsetwacom to configure your tablet. This program currently is a frontend for that program, you can check the manual page for how to use it by typing man xsetwacom in the terminal. Good luck!

Report

pixelforce

6 years ago

Hi together,
got same problem on 10.10.
It seems like it's caused due to sythax changes in xsetwacom:
see:
----------------------------------------
xsetwacom --set "Wacom Intuos3 6x11 pad" "Button3" "Button3"
Paramater 'Button3' is no longer in use. It was replaced with 'Button'
----------------------------------------

CheerS
Roy

Report

orbitgray

6 years ago

Is there any way to get sources to try it with other Linux distributions? (particularly with Gentoo)

Report

orbitgray

6 years ago

Oh, I've found that there should be tar.bz2 in deb.

Report

C

qb89dragon

6 years ago

New version is on its way. I've got the intuos 4 OLED panels and application profiles going. Hang on for that in the upcoming month or so and I'll be sure to package it more carefully and include source.

Report

Deevad

6 years ago

That's a good news !

Report

Krzychu

6 years ago

I've just recently bought Wacom Bamboo Fun tablet, but it is't recognized by your control panel.
It is CTH-661 model.
I've compiled your software from AUR (on Archlinux), but changing compiling commands, so I don't know, if it's just me or Control Panel is't supporting my device yet :P
And btw... sorry for my English :D

Report

inky

6 years ago

Hi, can you please help me ?

I'm on Ubuntu 10.04 x32, have installed input-wacom-0.11.0 , Xf86-input-wacom 0.10.11 and wacom-utility 1.21-1 but I don't get any configuration options in your tool, although it recognizes the tablet.

Report

C

qb89dragon

6 years ago

It must be another new model, can you send me the output of lsusb | grep wacom ?

Report

inky

6 years ago

Actually I bought it back in 2009 when they first came out. lsusb returns:
Bus 003 Device 002: ID 056a:00b9 Wacom Co., Ltd

Report

Deevad

6 years ago

Hi,
I very like this GUI for wacom tablets. For future features is it planed to bring a tab for configuring the 2 buttons of the stylus ? and about Cintiq and TabletPC , a calibration tool too ?
Thanks again for the cool soft.

Report

smroose73

6 years ago

Just curious, is there an approx timeline that you have for the release of this tool for 11.04? I understand that most publishers here are doing it in what little spare time they have. Thank you for your dedication.

Report

xonaag

6 years ago

Hi, I just installed Ubuntu 11.04 on my laptop and the program doesn't detects my wacom special edition tablet, Ubuntu does (I can move the pointer with the pen and with my fingers) but it doesn't appears on the control panel.What can i do?

Thanks

Report

Ukarimu

6 years ago

Hi !
I have the same problem with a wacom Bamboo fun (Type CTE-650).
This comment is present when i click on pad button :
"Cannot find device 'Wacom BambooFun 6x8 pad id: 13 type:'."

with http://sourceforge.net/apps/mediawiki/linuxwacom/index.php?title=Xsetwacom
i change the parameter but without effect when i use the tablett.
Sorry for my english

Report

marlboroman

6 years ago

Hi:

I never got the application to "see" my Bamboo Pen (CTL-460) under Ubuntu 9.10, even if I could get the device to work.

Recently I just installed Ubuntu 11.04 and the device works out of the box. The application sees the device as a Bamboo Fun 2FG 4x5 (same model, I guess, right picture anyway). It will let me use the "Test drawing area" but for each input device the "device mode", "device tilt" and "device pressure" optiones are disabled (except for the finger pad, of course).

If I remember correctly this device has "pressure" (I got it to work in Gimp but I found it not to be sensitive enogh)...

Is this the intended behaviour?. Should I be able to modify the pressure curve?.

I can post as much information as you need.

Thanks for your time making this application.

Report

C

qb89dragon

6 years ago

I'm working on compatibility issues for ubuntu 11.04. The backend program xsetwacom has changed significantly, and while the changes are for the better, it breaks this app until I can find time to fix it.

Report

marlboroman

6 years ago

Thanks for the quick reply. Ok, no problems, it's great to know that something isn't wrong with my machine at all.

Count on me to keep an eye on the project and try it as soon as it gets updated.

Again, thanks for your time and patience.

Report

grenzfrequence

6 years ago

I just installed wacom utility by using your ppa.

The input devices are displayed:

Wacom Intuos4 4x6 stylus
Wacom Intuos4 4x6 eraser
Wacom Intuos4 4x6 cursor
Wacom Intuos4 4x6 pad

In section "Wacom Intuos4 4x6 pad" the buttons display an error message as follows:

Cannot find device 'Wacom Intuos4 4x6 pad'

It is not possible to assign new keys.
Would be nice to solve the problem because i want to use it in blender for 3D graphic. It works, but i have to assign the keys to the pad as well.

In blender you use the numpad numbers very often to chance the perspectives. It is elementary important. Therefore this question: How can i assign numpad numbers (etc. numpad-1, numpad-2 etc.) to the pad buttons of intuos4?

Many thanks in advanced, i like your gui.

Greatings...

Report

8 years ago

Update:
Version 1.20-1: Updated for Maverick. Now works on Ubuntu 10.10

Version 1.19-2: Added button mapping for CTE_440 tablets. (thanks to ABelliqueux for the contribution)

Version 1.18-2: Repackaged and being built on launchpad servers.

Version 1.17-1: Adds button-mapping support for DTZ-12wx, DTZ-20wsx, DTZ-21ux.

Version 1.16-1: Adds support for CTH-660 (Bamboo Pen and Touch)
Fixes support for all Cintiq models (report back any bugs people!)

Version 1.15-1: Adds support for CTH-460 (Bamboo Pen and Touch) tablets.

Version 1.14-1: Adds support for CTL-460 (Bamboo Pen) tablets.

Version 1.13-1: Fixes issue with button mapping on PTZ-431W tablets

Version 1.12-1: Adds support for Intuos 4. Let me know if you have any bugs with your intuos 4!

Version 1.11-1: Fixed some bugs that appeared due to 10.04.

Version 1.10-1: Fixed dependency that prevented install on Ubuntu 10.04.

Version 1.9-1: Removed xorg.conf configuration. Now works with HAL and the new hotplugging support.

Version 1.8-1: Fixed button map getting cropped by window border.

Version 1.7-1: Fixed button mapping for all Intuos 3 series tablets.

Version 1.6-1: Fixed bug where gtk button events were left unmapped, leading to changes going in the wrong place when modifying your pad settings.

Version 1.5-1: Fixed model info for CTF_430-U (Bamboo1)

Version 1.4-1: Fixes launcher to use any installed version of python, not just 2.5

Version 1.3-1: Further bugfixes

Version 1.2-1: Bugfix - Software now creates serverlayout section of xorg.conf if it doesn't exist.

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
1.20
updated Jun 02 2011
added May 07 2009
downloads today
0
page views today 27