Apollon
Network
Score 78%
Description:

Apollon - the greek god of music, mp3s, and videos! Apollon is a KDE-based client for the p2p-protocol giFT (OpenFT, FastTrack(Kazaa!), Gnutella, OpenNap) It is very userfriendly, intuitively, offers an inline Mediaplayer for previews of downloaded files, etc etc


For further questions and support please contact us either on
apollon-devel@lists.sourceforge.net
or irc.freenode.net#apollon.
That little forum below is not a help/support/bug-forum, imho.
Last changelog:

13 years ago

8 May 2005
- added icons for Ares.
- improvements of the search page
- all in one installer contains Ares plugin as well
- fixed some translation filenames.

14.12.04:
Updated the all-in-one installer.
Contains now the latest versions of:
giFT: 0.11.8.1
OpenFT: 0.2.1.5
Gnutella: 0.0.10rc1
FastTrack: 0.8.8

13.10.04:
fixed several QT 3.2/3.3 issues.
updated french and serbian translation.
significantly improved first run wizard. Installs now all available plugins automatically (and not only OpenFT).

01.10.04:
Again a bugfix-release of the installer. Lots of important bugfixes!

29.09.04:
Bugfix-release of the all-in-one installer. Fixes compile-errors with mising QT libraries.

26.09.04
Apollon 1.0
===========

- Apollon connects to the chat only when desired.

- "search for more sources" changes the icon to express the action

- fixed some untranslatable strings.

- ctrl-w and Esc go to the right tab-page in the search-page.

- Apollon should be compatible to KDE versions installed after apollon now.

- added helenic, norwegian, danish, russian translations.

- NEW FEATURE: added chat-support for apollon-users
* nick colouring and highlighting
* tab-nick-completion
* popup-notification if your nick is mentioned

- added the choice for "apollon-progressbars" and "KDE-progressbars"

- replaced the progressbars with real ones.


May 15 2004:
Apollon 0.9.4
=============

- added brazil translation

- some changes to prepare apollon for autopackage.

- apollon is ready for the use with unsermake

- files already in progress appear in your searchresults as selected for downloading

- improved tooltip in the search page.

- enable/disable docking. docking ready for GNOME-uses who have the kdesystrayproxy installed

- toolbar added for transfer page

jetpeach

9 years ago

obviously apollon is pretty much dead, hasn't been updated in forever and won't even work without tweaking after install. but what is the replacement? apollon is _still_ the most downloaded file sharing app on apps.kde.org and something like it would still seem great. i guess frostwire / limewire are the replacement, but i would much rather have something Qt-based...especially Qt4 based

Report

zymno

11 years ago

hello, when I install apollon at 50% it give me this error : checking for rpath... yes * configure: error: * in the prefix, you've chosen, are no KDE headers installed. This will fail. * So, check this please and use another prefix! ***** Return value 1 Someone can explain me how to solve this problem, thank ;)

Report

andu

11 years ago

Hello,
I think you need to check:
1.Is kde_devel package installed?
IF 1 == true THEN
2.Locate your kde home
directory - the prefix
(a.k.a /usr/local/kde3.5)
ELSE
install kde_devel packages

CONTINUE
3. type:
$./configure --help
This command tell us about the behaviour of the package and presents a list with a lot of options and resource path modifiers, ex: --with-kde-dir or --with-kde-prefix or something similar
try to run:
$ ./configure --with-kde-prefix=/usr/local/kde3.5
and see what happens

IF CONFIGURE==FAIL THEN
try to run:
$./configure --prefix=/usr/local/kde3.5
If you choose as installation prefix for an application exactly the prefix of the kde then this should work

IF CONFIGURE CONTINUES TO FAIL THEN
Ask an expert

Report

bugmenot

10 years ago

Who the fuck do you think you are? You're fucking crazy, man!

To everybody: look in desc: this forum is not a support area! PLus, last release date from 2005.

Report

bugmenot

10 years ago

forget about this. Im sorry

Report

bugmenot

10 years ago

"Happiness comes at a price : the price of suffering!"

Actually, i don't think happiness comes at a price, if not the price of living, being. I think people have lost sight of what's happiness. Really, look around: people are always looking for something better, somewhat a constant unsatisfaction. People have lost the ability to look at a glass of wine and see it half full, and not half empty; they have lost the ability to look at the present, look how the fuck they are powerfull, that's it, how well made.

Now, to that point, i agree; but i don't see why you want to suffer to reach happiness.
I may just say "ok, go on, cut you a hand
if it can makes you feel so happy why would I contest?",
"and by the way, would you say okay if i asked you to do it with my toothbrush just bought last day?
"The better you suffer, the better you are,
"i know a guy in Niger, it was forty-five,
"he took more than a whole year to die from a cancer
"he caught those ones on a river, at home in Niger
"he thought this shit gonna lead him to glory
"but he died in the lost of a all possible dignity

Amen

Report

emc2

12 years ago

simply the best..!!!

Report

mononoke

12 years ago

by the way.. how to uninstall these files that are only half installed with arkollon (apollon-installer) ???

Report

mononoke

12 years ago

can someone help ? compiling works for all but ares, i get an compile error while using arkollon:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/local/include -I../lib -I/usr/include -Wall -g -O2 -MT as_ares.lo -MD -MP -MF .deps/as_ares.Tpo -c as_ares.c -fPIC -DPIC -o .libs/as_ares.o
* as_ares.c:64: warning: initialization makes integer from pointer without a cast
* as_ares.c:64: error: initializer element is not computable at load time
* as_ares.c:64: error: (near initialization for `default_conf[1].data.i')
* as_ares.c:64: error: initializer element is not constant
* as_ares.c:64: error: (near initialization for `default_conf[1].data')
* as_ares.c:65: error: initializer element is not constant
* as_ares.c:65: error: (near initialization for `default_conf[1]')
* as_ares.c:66: error: initializer element is not constant
* as_ares.c:66: error: (near initialization for `default_conf[2].data')
* as_ares.c:67: error: initializer element is not constant
* as_ares.c:67: error: (near initialization for `default_conf[2]')
* as_ares.c:68: error: initializer element is not constant
* as_ares.c:68: error: (near initialization for `default_conf[3].data')
* as_ares.c:69: error: initializer element is not constant
* as_ares.c:69: error: (near initialization for `default_conf[3]')
* as_ares.c:70: error: initializer element is not constant
* as_ares.c:70: error: (near initialization for `default_conf[4].data')
* as_ares.c:71: error: initializer element is not constant
* as_ares.c:71: error: (near initialization for `default_conf[4]')
* as_ares.c:72: error: initializer element is not constant
* as_ares.c:72: error: (near initialization for `default_conf[5].data')
* as_ares.c:73: error: initializer element is not constant
* as_ares.c:73: error: (near initialization for `default_conf[5]')
* make[2]: *** [as_ares.lo] Fehler 1
make[2]: Leaving directory `/tmp/selfgz9789/gift-ares-0.2.2/lib'
* make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/tmp/selfgz9789/gift-ares-0.2.2'
* make: *** [all] Fehler 2
***** Return value 2

----------------------
My System is SuSE 9.3Pro, AMD-64bit

Report

maarizwan

12 years ago

Thanks apollon developers, the installer is compiling now :). the installer is just amazing.

I hope arkollon could be of much help to Linux Newbies to create and install packages on their linux systems.

Report

liranbar

12 years ago

I keep getting this error while running "sh apollon-installer-0.8.1.run":
checking for unlink... yes
checking for lt_dlopen in -lltdl... no
* configure: error:
* *** Couldn't find ltdl library. If it is installed in a non-standard
* *** location, please supply --with-ltdl=DIR on the configure command line,
* *** where `DIR' is the prefix where ltdl is installed (such as /usr,
* *** /usr/local, or /usr/pkg). If that doesn't work, check config.log.
*
***** Return value 1

why is that?

Thanks

Report

beaner1111

12 years ago

Just install libtools from source.

Fedora doesn't include all of it, that's why the installer stops.

Report

bored2k

12 years ago

the installer didnt work :(.

Report

mkoebele

12 years ago

why not?

sh apollon-installer-0.8.1.run

works.

Martin

Report

alross

12 years ago

Worked for me "almost"

comes up at the end wanting zlib 1.1.4 but I have zlib 1.2.something

HELP

al.ross2005@gmail.com

Report

genjix

12 years ago

Hi, in your all in one installer script, I have a suggestion... It would help, if you could give it a prefix (for when kde is installed in a non standard place - such as on my system SUSE 9.2). also after it exits with the errors, if the script wasnt run as root, it gets permission errors from trying to remove installation files (from when you was as root). Keep it up!

Report

naim89

12 years ago

Hi,

I tried the all-in-one package, however I keep getting this error:

* configure: error:
* *** Couldn't find ltdl library. If it is installed in a non-standard
* *** location, please supply --with-ltdl=DIR on the configure command line,
* *** where `DIR' is the prefix where ltdl is installed (such as /usr,
* *** /usr/local, or /usr/pkg). If that doesn't work, check config.log.
*
***** Return value 1

Any solutions?

Report

pgk3734

12 years ago

Your all-in-one installer is a work of art. Absolutely no problem with the install. I only wish that all program installs were so thorough. I only have one minor problem that gnutella doesn't want to connect. I'll probably figure that one out. I am using Fedora 3.
Good job, again.
pgk

Report

effco

12 years ago

I had the same problem, in fact after install of the gnutella plugin you HAVE to run the gift-setup command from a konsole.
Accept all the default values, it will finish the config and gnutella will connect

Report

majoritywhip

12 years ago

Error when doing sanity check on this file. Running MDK 10.1

Any ideas?

Report

inescapableus

12 years ago

I use apollon as my primary source of getting music that I need. I find that the network speeds tend to flux quite abit, but I can live with it. I have to say that the program is easy to install (by source) and that the addition of the ares network makes me use the application even more so.

Report

myformerself

12 years ago

Works fine for me . The all in one installer is easiest .

I am running suse 9.1 .I am pretty much a newbe .

The only thing that was missing was the kde multimedia part but i figured out how to fix that by using the ftp and just getting it .

Ares plugin doesnt work for me but thats not the program and someone else made it . if anyone has that working / post here and lemme know how . thank you

gnutella doesnt connect but i think the program needs something to update the nodes etc.

kceasy has something that updates the nodes and plugin . apollon needs that .

so far so good . very promising program . i cant wait for ares and soulseek to work in this .

Great work !!

Report

csanchisb

12 years ago

Neither the chat nor the player work for me. Does that happen to you? What can I do?

Report

oicdn

12 years ago

This is what happenned to me after I DLd the installer and tried to run it:

oicdn@linux:~> su
Password:
linux:/home/oicdn # cd Documents
linux:/home/oicdn/Documents # sh ./apollon-installer-0.6.run
Verifying archive integrity... All good.
Uncompressing Apollon............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................


Please wait while the Arkollon installer is compiled

This may take a few moments


linux:/home/oicdn/Documents #

Nothing happened after the "It may take a few moments......help???

Report

malegria

12 years ago

I´ve just installed Apollon with the exec file...and every time I start a search, it crashes.

Anybody have this problem? Found a way to fix it? Anybody?

Thanks

Report

13 years ago

8 May 2005
- added icons for Ares.
- improvements of the search page
- all in one installer contains Ares plugin as well
- fixed some translation filenames.

14.12.04:
Updated the all-in-one installer.
Contains now the latest versions of:
giFT: 0.11.8.1
OpenFT: 0.2.1.5
Gnutella: 0.0.10rc1
FastTrack: 0.8.8

13.10.04:
fixed several QT 3.2/3.3 issues.
updated french and serbian translation.
significantly improved first run wizard. Installs now all available plugins automatically (and not only OpenFT).

01.10.04:
Again a bugfix-release of the installer. Lots of important bugfixes!

29.09.04:
Bugfix-release of the all-in-one installer. Fixes compile-errors with mising QT libraries.

26.09.04
Apollon 1.0
===========

- Apollon connects to the chat only when desired.

- "search for more sources" changes the icon to express the action

- fixed some untranslatable strings.

- ctrl-w and Esc go to the right tab-page in the search-page.

- Apollon should be compatible to KDE versions installed after apollon now.

- added helenic, norwegian, danish, russian translations.

- NEW FEATURE: added chat-support for apollon-users
* nick colouring and highlighting
* tab-nick-completion
* popup-notification if your nick is mentioned

- added the choice for "apollon-progressbars" and "KDE-progressbars"

- replaced the progressbars with real ones.


May 15 2004:
Apollon 0.9.4
=============

- added brazil translation

- some changes to prepare apollon for autopackage.

- apollon is ready for the use with unsermake

- files already in progress appear in your searchresults as selected for downloading

- improved tooltip in the search page.

- enable/disable docking. docking ready for GNOME-uses who have the kdesystrayproxy installed

- toolbar added for transfer page

product-maker 59 230

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
1.0.2.1
updated May 08 2005
added Jan 05 2004
downloads today
0
page views today 0