Description:

Apper is the KDE interface for PackageKit (aka KPackageKit)

Apper is able to manage packages, applications and updates in a cross-distribution way thanks to the PackageKit project. Providing Linux users a single application that they can learn and use in whatever distribution they are.

Hope you enjoy Apper, and please report bugs, make wishes so we can improve this application.

BUGS goes to bugs.kde.org

-----------------------------------------------------
IMPORTANT:
Apper itself can do nothing without PackageKit.
So have it installed before.
-----------------------------------------------------

INSTALLATION

Well now that you decide to install it. Be careful :D no warranty is given..

Requirements:
AFTER INSTALLING LOGOUT AND LOGIN SO KDED CAN LOAD THE Apper PLUGIN.
(also, make uninstall #from your old build dir)

PackageKit >= 0.8.5
KDELibs headers of Kde4
KDEWorskpace
KDE >= 4.3

Compiling:
- $ cd Apper # where you extracted it
- $ mkdir build && cd build
- $ cmake .. -DCMAKE_INSTALL_PREFIX=/usr/ # you must install in /usr otherwise KDE won't find it
- $ make
- $ su
- # make install

Enjoy :)

Orbmiser

3 years ago

Wonder if you stop bug fixing or improving?

Report

revelation128

3 years ago

Hey, I really like this program! :-)
I'm using it as a frontend for pacman the package manager of Archlinux and it works great!

However, when Apper shows me the packages with updates in the repository, only the new version on the server is shown. Is it possible to also show the version that is currently installed on my computer? Maybe as an additional column in the list?

Cheers
Johannes

Report

dantti

3 years ago

Yes, just right click the updates list and select the column you want.

Report

dorg

3 years ago

why detail in install & update not shown
size of package & downloaded
count of pacage & done
& a log of install / download
thank's

Report

dantti

3 years ago

All that information depends on which distribution are you using.

Report

Antik

3 years ago

I'm trying to install it from ports in freebsd 9.2

cd /usr/ports/ports-mgmt/kpackagekit/ && make install clean

and resolve an error while building dependance port
usr/ports/ports-mgmt/packagekit-qt4/

===>>> This port is marked IGNORE
===>>> does not build with Qt 4.8

What can I do to resolve this issue ?

Report

dantti

3 years ago

Sorry I don't know how to use ports or what does that error mean, but kpackagekit means that you are trying to use an old version since it was renamed to Apper long ago...

Report

jamjam

4 years ago

Would be cool if I could do like:

apper --search mplayer

..and apper opens up and does a package search.

Report

dantti

4 years ago

You can do that using pkcon :D

Report

jamjam

4 years ago

Well as an openSUSE user I'd directly use zypper for that..

Having results come up in apper would be nice though, because you can click, browse, get detailed info, and install using nice GUI. :)

Report

mambasoft

4 years ago

With Apper 0.7.2 I can't install package files, from the browser or e.g. from command line:

apper ./google-earth-stable_current_i386.rpm

This doesn't work, but this works:

pkcon install-local ./google-earth-stable_current_i386.rpm

By investigating on the backend (smart) it seems to me that it is not its fault, because it is not getting the package(s) file name as install-files option. pkcon works, so I tried to investigate on Apper but I realized that the problem might as well be in libpackagekit-qt2. Thanks for any help.

Report

SG2Tiger

4 years ago

Hey, I thought I'd make you guys aware that there's a slight visual bug with the description box when using QTCurve (or possibly, when not using the Oxygen widget style; I haven't tested any other styles to know if it does this outside QTCurve). You can see the difference here:

http://imgur.com/a/S3Iwn

I've confirmed this to happen on both Kororaa 17 and OpenSuSE 12.1 so it most likely isn't distro-specific. If I switch the widget style back to Oxygen, Apper returns to its normal functionality, but then swapping to QTCurve again causes it to reoccur. A fix for this would be great :D

Report

dantti

4 years ago

It's a known bug, because other widgets don't repaing the background, it's a bug in the theme engine which should repaint after an animation, which doesn't happen.

Report

netean

5 years ago

Have to say that I really like Apper, first came across it in Fedora 16 but now have it on both my fedora laptop and both my Ubuntu laptops (now sad am I having 4 laptops) Much prefer it over Muon etc.

Thank you for making it

Report

dantti

5 years ago

You're welcome!

Report

shura

5 years ago

There is impossible to update package if it has not certificate. Appers asks if I sure that want install those packeges, I press "Yes" and it asks again and again, so update never starts.

Report

dantti

5 years ago

Fixed in this release sorry for the delay

Report

shura

5 years ago

thank you!
Do you have any ppa for installing on Ubuntu without compilation?

Report

dantti

5 years ago

Ximion has packaged it again :D
https://launchpad.net/~ximion/+archive/packagekit/+packages

Report

Dana912

5 years ago

Hi
I used the last release of apper, and it still says
"License agreement Required"

The problem are not resolved as you promised:-(

Report

Dana912

5 years ago

Hi
I used the last release of apper, and it still says
"License agreement Required"

The problem are not resolved as you promised:-(

Report

dantti

5 years ago

Can you please elaborate a test case?
Distro/package etc?
did you make install on /usr?
I tested this several times and it actually worked...

Report

shura

5 years ago

Ubuntu 12.04. I confirm, issue is fixed!

Report

dantti

5 years ago

no, the issue he's talking about should openSUSE specific our license handling is quite different from theirs...

Report

pejakm

5 years ago

Hi Daniel. Can you please add option "check for updates every X hours", where we can define number of hours to check for updates?

Report

Filename Version Description Filetype Packagetype License Downloads Date Filesize Install
Score 84%
84.00 Likes
16 Dislikes
Details
version
0.8.0
updated Jan 08 2013
added Jul 06 2008
downloads
page views 7978