Kopete OTR Plugin
Various KDE Extensions
Score 82%
Description:

This plugin enables Off-The-Record encryption for the KDE instant messenger Kopete. Using this plugin you can encrypt chatsessions to other users with IM-Cients supporting the OTR encryption method.
What you need
KDE-3.5.x for version 0.7
KDE-4 for version 0.8
Kopete
libotr-3.1.0

enjoy!
Last changelog:

9 years ago

0.8:
- KDE-4 Port. 0.8 is only for KDE-4.
- GUI redesign due to the port
- small fixes
0.7:
- Added support for the Socialists Millionaires Protocol. This requires libotr-3.1.0.
- Fixed a bug where the creation of new fingerprints would overwrite the wrong key
- Allow copy-paste the own fingerprint
- Polished the verify fingerprint dialog
- Added italian translation.
- Fixed a crash when verifying fingerprint with no fingerprint selected
0.6:
- Fixed some licensing issues
- Fixed a newline bug
- minor fixes
0.5:
- Fixed a crash when joining Jabber-MUCS
- Added a popup when receiving a new (unknown) fingerprint
- Removed duplicate shown messages on automatic resend
- rewrote messagehandling (output is more userfriendly now)
- corrected permissions on keyfiles
- fixed a crash when reading the fingerprint file
- minor fixes
0.4:
- You can now set a different policy for every contact
- Protocol names are now shown in preferences
- You can now have enabled both plugins: GPG and OTR
- fixed some bugs
0.3:
- Generation of Private keys is now userfriendly
- Translation to german
- You can now verify fingerprints in the chatwindow
- bugfixes

annaeus

9 years ago

Is there already a port for KDE 4?

Thank you.

Report

dreadhead

9 years ago

The KDE 4 port is work in progress. It is basically working but all the icons etc are missing.

It isn't ready for end user use yet. I will update this section as soon I release the first kde4 version.

Report

thsnielsen

9 years ago

If you would benefit from a beta tester, do not hesitate - contact me at the above username @gmail.com
Normally I am on the latest kde4 packets, and I am using kopete all day on multiple protocols, and I have colleagues that prefer talking of the record :-)
And I am used to reporting bugs in a qualified way.

Report

illuminatus23

9 years ago

really nice ;-)

Report

texDiggs

9 years ago

I've compiled the OTR plugin for Debian testing/lenny and packaged it up. You can get it at http://blog.gauner.org/2007/12/05/kopete-otr-for-debian-lenny/.

Report

sektion31

9 years ago

i was still using kopete-otr 0.2, somehow my gentoo didnt update...
anyways it crashed my kopete and _maybe_ this is not an old bug so here we go:

gdb says:
ibkopete: WARNING: [Kopete::Plugin* Kopete::PluginManager::loadPluginInternal(const Q String&)] Unable to find a plugin named 'kopete_statistics'!
KCrash: Application 'kopete' crashing...
---Type <return> to continue, or q <return> to quit---
Program exited normally.


kcrash says:
#6 0xb60a7a25 in strstr () from /lib/libc.so.6
#7 0x0000e8ac in ?? ()
#8 0xb603b2b0 in ?? () from /lib/libc.so.6
#9 0xb5e22778 in ?? () from /usr/lib/libotr.so.2
#10 0x00000000 in ?? ()


I hope this is any help. i dont have debug compiled in

Report

dreadhead

9 years ago

Is this crash still coming from 0.2?
What were you doing when it crashed?
Please add debug output to the build as the stack trace isn't telling anything about the crash.

Report

sektion31

9 years ago

yes this was comming from 0.2
the crash did come at every kopete startup, since one day. i didnt do any unusuall things during the last kopete session, before the crashes appeared.
i upgraded then to 0.7 and it works now again.

is there a way to add more debug info without having debug compiled in?
in other words should i not even bother about filling out bugreports (not only kopete/otr but in general), because all my packages are compiled without debug support.

Report

dreadhead

9 years ago

This is a big problem with user reports... The stack trace doesn't tell anything if they haven't enabled debug. But if you find a reproducible bug and you can explain exactly what you are doing to reproduce it, this will halp the developers.

But for sure you shouldn't report bugs if you are 5 versions behind because this bugs will most likely been fixed already.

Report

sektion31

9 years ago

> But for sure you shouldn't report
> bugs if you are 5 versions behind
> because this bugs will most likely
> been fixed already.

hehe, yeah i know
usually my packages are all up to date =)

Report

elfchief

9 years ago

Ok, so got and installed the plugin, generated a key, set myself to 'manual'

Brought up a chat window for a friend, tools->otr->start session

Try to send a message:

OTR Error: You transmitted an unreadable encrypted message.


... any ideas?

Report

liquidat

9 years ago

This is a really helpful plugin. Why don't you try to push it upstream?

Report

dreadhead

9 years ago

Work in progress...

Report

ZdadrDeM

9 years ago

I think you uploaded the wrong package (it's 0.5 and should be 0.6).

Report

dreadhead

9 years ago

Sorry... The link was still pointing to the older version.
Now it is corrected.

Report

sektion31

9 years ago

... wont work.

My fingerprints are imported from pidgin 2.0.2. As described here in the comments.

Btw: The private key can not just be coppied from pidgin. They seem to use a string for "protocol" while kopete needs an integer value.
I changed the line
(protocol prpl-icq)
to
(protocol "myicqno") <- with Quotations

and it worked.

Ok back to the opportunistic issue.
Well kopete justed does not send encrypted messenages to people i have an verified fingerprints of.

What to do here?

Report

sektion31

9 years ago

Hm. To prevend missunderstandings.
The encryption itself works nice, when an otr session is started manualy or by an incomming message.

Kopete justs does not start an otr session automatically, when I start a conversion with others.

Report

dreadhead

9 years ago

The opportunistic mode tags outgoing messages with whitespaces. If the other client receives this tags it should start a private conversation. For this reason it depends also on the other side whether opportunistic will work or not. If the other side has set the policy for example to manual or never it won't encrypt automatically.

Report

francov

10 years ago

Kopete crashes at start:

kopete: symbol lookup error: /usr/lib/kde3/kopete_otr.so: undefined
symbol: _ZN17OtrlChatInterface20checkFilePermissionsE7QString

Report

dreadhead

9 years ago

It seems that you have mixed two different versions of the plugin. Make sure to uninstall the old version before installing the new one.

Report

gfdsa

10 years ago

Hi,

Any idea of how to deal with the newlines problem anyone?

Thanks!

Report

dreadhead

10 years ago

What newline problem do you mean?

Report

brand80

10 years ago

I have created a debian packages for kopete-otr.

download:
http://www5.autistici.org/debian-xgl/

Report

sts

10 years ago

Kopete crashes here when clicking on "OTR" in the "configure plugins" dialog.

Backtrace is here: http://sts.synflood.de/kopetecrash.txt

Report

sts

10 years ago

the crashes disapperead after ressetting the fingerprints file. nevertheless there must be some problem here.

Report

9 years ago

0.8:
- KDE-4 Port. 0.8 is only for KDE-4.
- GUI redesign due to the port
- small fixes
0.7:
- Added support for the Socialists Millionaires Protocol. This requires libotr-3.1.0.
- Fixed a bug where the creation of new fingerprints would overwrite the wrong key
- Allow copy-paste the own fingerprint
- Polished the verify fingerprint dialog
- Added italian translation.
- Fixed a crash when verifying fingerprint with no fingerprint selected
0.6:
- Fixed some licensing issues
- Fixed a newline bug
- minor fixes
0.5:
- Fixed a crash when joining Jabber-MUCS
- Added a popup when receiving a new (unknown) fingerprint
- Removed duplicate shown messages on automatic resend
- rewrote messagehandling (output is more userfriendly now)
- corrected permissions on keyfiles
- fixed a crash when reading the fingerprint file
- minor fixes
0.4:
- You can now set a different policy for every contact
- Protocol names are now shown in preferences
- You can now have enabled both plugins: GPG and OTR
- fixed some bugs
0.3:
- Generation of Private keys is now userfriendly
- Translation to german
- You can now verify fingerprints in the chatwindow
- bugfixes

product-maker 31 157

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.8
updated Mar 03 2008
added Mar 21 2007
downloads today
0
page views today 3