SoftRAID Monitor
KDE Plasma 4 Extensions
Score 66%
Description:

A software RAID monitor plasmoid
Supported RAID levels: 1, 4, 5, 6, 10
Last changelog:

5 years ago

0.5
- fixed configuration UI bug

rollerson

2 years ago

My /proc/mdstat:
Personalities : [raid1]
md1 : active raid1 sdb1[0] sdc1[2]
2930263928 blocks super 1.2 [2/2] [UU]

unused devices: <none>

I see a double disk symbol (device md1 is configured). But shouldn't there be no green lights?

Going with cursor over symbol shows:
md1: raid1
sdb1: active
sdc1: active

(active written in green colour)

Best Regards
Roland Langner

Report

vienna

2 years ago

The Package pykde4 is needed when running within gentoo:

https://forum.kde.org/viewtopic.php?f=67&t=111628

BR

Report

mbulik

3 years ago

Your plasmoid has stopped working on Debian testing
(amd64). If I understand correctly the versions of the following packages may be important :
python-kde4 4:4.10.5-1+b1
python-qt4 4.10.3+dfsg-1
python-sip 4.15.3-1

Any hint ?
Thanks, Michal

Report

rbos

4 years ago

Since I upgraded to kde-4.9.2 I get the following message in the widget area:
cannot create python script engine.
Does anybody know what can be cause of this message?
(openSUSE_12.2)

Report

doomsdaydev

4 years ago

The problem was that python-sip and python-qt were updated to the API version 9.0 while python-kde was still using version 8.1. A downgrade of python-sip and python-qt works as a temporary fix, but the problem is solved by now by an update of python-kde anyway.

Report

rbos

4 years ago

Ah, yes. After a package update (kde4-python) the problem was solved.

Report

doomsdaydev

5 years ago

The new version (0.5 - sm_config.ui was renamed to config.ui) is working fine (openSUSE 12.2 + KDE 4.9). Thank you very much!

Report

fakbill

5 years ago

It's a GUI bug.
The output of /proc/mdstat is parsed correctly by parse_mdstat.

"for dev in sorted(status['devices']): self.configUi.deviceComboBox.addItem(dev)"
what's wrong with that??
I also get nothing in the device list in the GUI...

Report

archangelks

5 years ago

not show any devices

Report

C

alz83

5 years ago

post `cat /proc/mdstat`, please

Report

archangelks

5 years ago

Thanks for the quick reply, my mdstat file look like this:


Personalities : [raid6] [raid5] [raid4] [raid0] [raid1] [raid10]
md0 : active raid1 sdc1[2] sda1[0] sdb1[1]
63476 blocks super 1.0 [3/3] [UUU]
bitmap: 0/1 pages [0KB], 65536KB chunk

md3 : active raid5 sdc4[3] sda4[0] sdb4[1]
953570816 blocks super 1.0 level 5, 128k chunk, algorithm 2 [3/3] [UUU]
bitmap: 3/4 pages [12KB], 65536KB chunk

md1 : active raid5 sdc2[3] sda2[0] sdb2[1]
2103040 blocks super 1.0 level 5, 128k chunk, algorithm 2 [3/3] [UUU]
bitmap: 0/1 pages [0KB], 65536KB chunk

md2 : active raid5 sdc3[3] sda3[0] sdb3[1]
20965120 blocks super 1.0 level 5, 128k chunk, algorithm 2 [3/3] [UUU]
bitmap: 1/1 pages [4KB], 65536KB chunk

unused devices: <none>


I use OpenSUSE 12.1 witch KDE 4.8.1.

Report

archangelks

5 years ago

Thanks for the quick reply, my mdstat file look like this:


Personalities : [raid6] [raid5] [raid4] [raid0] [raid1] [raid10]
md0 : active raid1 sdc1[2] sda1[0] sdb1[1]
63476 blocks super 1.0 [3/3] [UUU]
bitmap: 0/1 pages [0KB], 65536KB chunk

md3 : active raid5 sdc4[3] sda4[0] sdb4[1]
953570816 blocks super 1.0 level 5, 128k chunk, algorithm 2 [3/3] [UUU]
bitmap: 3/4 pages [12KB], 65536KB chunk

md1 : active raid5 sdc2[3] sda2[0] sdb2[1]
2103040 blocks super 1.0 level 5, 128k chunk, algorithm 2 [3/3] [UUU]
bitmap: 0/1 pages [0KB], 65536KB chunk

md2 : active raid5 sdc3[3] sda3[0] sdb3[1]
20965120 blocks super 1.0 level 5, 128k chunk, algorithm 2 [3/3] [UUU]
bitmap: 1/1 pages [4KB], 65536KB chunk

unused devices: <none>


I use OpenSUSE 12.1 witch KDE 4.8.1.

Report

C

alz83

5 years ago

It seems like a KDE bug

Report

doomsdaydev

5 years ago

Same problem here on openSUSE 12.2 + KDE 4.8.4.

Personalities : [raid1]
md0 : active raid1 sdc1[0] sdd1[2]
1953511864 blocks super 1.0 [2/2] [UU]
bitmap: 0/466 pages [0KB], 2048KB chunk

unused devices: <none>

Report

Sho

5 years ago

Very useful, thanks.

Report

rbos

5 years ago

What are the differences, compared to the previous version?

Report

C

alz83

5 years ago

Added configuration of colors

Report

rbos

6 years ago

Looks interesting, but how to install? Where should the python scripts be stored and where should the meta file be placed?

Report

C

alz83

6 years ago

plasmapkg -i /path/to/file.plasmoid

Report

5 years ago

0.5
- fixed configuration UI bug

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.5
updated Sep 13 2012
added Aug 21 2011
downloads today
0
page views today 1