Description:

This is a plasma applet which displays kanji. it has a timer that make the kanji change every two minute, you can also forward to the next one with a simple click or go backward with a shift-click.

config dialog is still missing. it displays kanji up to grade 3 by default. that can be change in the code. until I add a config dialog.

it requires KDE 4.2 and Plasma. it is written in Ruby, so it requries QtRuby/Korundum.

Package is not distribution specific.

get dependencies
$ sudo apt-get install rubygems korundum4 plasma-scriptengine-ruby sqlite3 libsqlite3-ruby1.8 libsqlite3-ruby libsqlite3-dev
$ sudo gem install activerecord sqlite3

(note that korundum4 was called libkorundum4-ruby1.8 before 4.5)

then simply install with
$ plasmapkg -i 99711-kikkanji.zip

see second screenshot for a full look under KDE 4.5

if the plasmoid does not load, you might need to add an underscore on the
require 'activerecord'
it depends on your rubygems version.

vim $HOME/.kde/share/apps/plasma/plasmoids/kikkanji/contents/code/kikkanji.rb
change line 12 to... (simply adding the underscore)
require 'active_record'

Last changelog:

5 years ago

# 2006.05.16 - Project started in QtRuby for KDE 3. I wanted a kicker applet for displaying kanji, so I called it kikkanji. but QtRuby could not create kikker applet at the time so I made a main window.
# 2009-02-* - Project ported to KDE4/Plasma
# 2010.05.31 - update missing requirements for installation.
# 2010.08.11 - tested under ubuntu 10.04 with freshly installed KDE 4.5
# 2012.06.08 - tested under ubuntu 12.04 with KDE 4.8.3 and ruby 1.8.7 p352

Be the first to comment

5 years ago

# 2006.05.16 - Project started in QtRuby for KDE 3. I wanted a kicker applet for displaying kanji, so I called it kikkanji. but QtRuby could not create kikker applet at the time so I made a main window.
# 2009-02-* - Project ported to KDE4/Plasma
# 2010.05.31 - update missing requirements for installation.
# 2010.08.11 - tested under ubuntu 10.04 with freshly installed KDE 4.5
# 2012.06.08 - tested under ubuntu 12.04 with KDE 4.8.3 and ruby 1.8.7 p352

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
1.0
updated Jun 08 2012
added Feb 20 2009
downloads today
0
page views today 0