audiokonverter (also for KDE4)
Dolphin Service Menus
Score 85%
Description:

audiokonverter is a service menu (and also a commandline utility) to easily convert from MP3, OGG, AMR, AAC, M4A, FLAC, WMA, RealAudio, Musepack, Wavpack, WAV and movies to MP3, OGG, M4A, WAV and FLAC in Konqueror by right-clicking on them. It needs ffmpeg/avconv, oggenc, oggdec, faac, faad, flac, mplayer and lame to work. id3lib is optional for full functionality. Also optional are vorbis-tools and metaflac for handling other metadata. See README how/where to get that software.
Be sure about needed software when installing prebuilt packages!

Please vote for "good" if you like the program. There are many downloads with each release, but only a few votes.
Last changelog:

Fix 2 months ago

fixed paths for KDE4

jano

2 months ago

Does not work at all... I installed all the stuff the installer said was "necessary", but it doesn't even show up in dolphin's settings.

Report

C

labrum

2 months ago

Thanks for reporting it!
Please try the 5.9.5 version with installKDE4.sh

Report

morine01

1 year ago

Apply for valid international English Language Test eg.IELTS,TOEFL,ESOL,CELTA,DELTA.


We deal and specialize in the production of registered TOEFL, IELTS, ESOL, CELTA/DELTA & other English Language Certificates. Please note that Our IELTS & TOEFL,Certificates are Original and registered in the data base and Can be verified.After your order is placed it takes just few days for us to get your details in the system

Once your details are imputed in the system it will be in the IELTS or TOEFL web sites/system once for ever and will appear real, legit and verifiable for ever. WE can also help you to get valid Work permits,Driver’s license ,second p***port and Visas to European ,USA,Canada and Australia . below are additional documents that we offer Adoption Certificates Baptism Certificates Birth Certificates Death Certificates Divorce Certificates Marriage Certificates Custom Certificates prostitution certificate High
School Diplomas G.E.D. Diplomas Home School Diplomas College Degrees University Degrees Trade Skill Certificates Social Security Validate SSN Number Driver License Travel documents(passports, visas etc)for more information

General Support ( realdocumentationservices@gmail.com )

call us on +237697737461(whatsapp)

Skype: newdreams.documentation1

Once you place your order with us,you just need to stay back because you will not be required to take the test in person as we have veterans who are specialised in taking the test and will take the test for you accompanied with our invigilators and the collaborations we have with the British Council .

https://vimeo.com/185729397

Report

houston4444

3 years ago

hello.
ffmpeg has been removed from ubuntu 14.04. Have you planed to change the code of the script to be compatible with avconv ?

Report

C

labrum

3 years ago

how inconvenient!
Can you try
"sudo ln -s /usr/bin/avconv /usr/bin/ffmpeg"?
I have to think about a solution of this annoying problem. ubuntu could have kept this symlink and everybody would be happy!

Report

C

labrum

3 years ago

Please try the latest ubuntu package.

Report

Chip88

4 years ago

Hi there!

I'd like to use this great service menu, but there seems to be some difficulties with VLC Player.

If vlc is installed, it will be deleted due to install of this menu.

Installing VLC back via Muon doesn't work at all and results in an error.

So there is just the option to install VLC again via terminal.

But, when installing VLC, some packages are goingt to be removed:
audiokonverter:i386 dvgrab ffmpeg:i386 libav-tools:i386 libavcodec53 libavcodec53:i386
libavdevice53:i386 libavformat53 libavformat53:i386 libavutil51 libavutil51:i386
libcdio-cdda1:i386 libcdio-paranoia1:i386 libcdio13:i386 libdca0:i386 libdvdnav4:i386
libdvdread4:i386 libenca0:i386 liblircclient0:i386 libquicktime2 mplayer:i386
nepomuk-core-ffmpegextractor

All needed for this service menu...

How can I fix this and get both things (your service menu and VLC) to work together?

Thanks in advance!

Regards,
Chipy

Report

Chip88

4 years ago

Sorry, I forgot to add the information of the system I'm using:
KDE 4.10.5
Ubuntu 13.04
Kernel: 3.8.0-29-generic

Hope this helps to resolve the issue.

Report

C

labrum

4 years ago

Please try installing it with the installer from the tarball. This does not affect your package management, then.

Report

manxmaus

7 years ago

Hi,

Thanks for the nice tool. There is one little bug, though: in line 743 the script calls itself with the name "audioconvert" which should be changed to the new "audioconvert4" otherwise it will not be found.

The same change should be applied to the usage text. And it would be nice to mention that wildcards may be used, or maybe even add some example like this:

"audioconvert4 -dontask *" will convert all audio files in the current directory into MP3 and place them in the default $encdir directory.

Report

kmaglione

7 years ago

It's a shame that this uses faac rather than neroAacEnc. The latter still performs significantly better on listening tests.

Report

C

labrum

7 years ago

Is it free software?

Report

tukozaki

7 years ago

audiokonverter for KDE-3x and KDE-4x is an excellent add-on.
On Mandriva 2009.1 x86_64 with KDE-3, 'install.sh' (from the tarball provided) even looks for $KDEDIR and let me graphically choose where it is (/opt/kde3) :-)
install script eventualy let me know which programs or libs it needs to provides full functionalities: id3 id3v2 id3lib in this location.

Whish there are a 'convert Ogg to mp3' for mp3-only player.

Report

C

labrum

7 years ago

Thanks for the praise.
What exactly do you mean? It can convert ogg to mp3.

Report

testerus

7 years ago

Please support Ape (monkey audio) files.

Report

C

labrum

7 years ago

Monkey is inofficially supported.
For ape to flac (lossy format to lossfree format) you must edit your "audioconvert" file. Find it with "which audioconvert".

There is a
function apetoflac()
{
echo -e "# Monkey to FLAC only increases filesize. I won't do this.\n"
kdialog --passivepopup "Monkey to FLAC only increases filesize. I won't do this." 3
# flacname="${encdir}/${EXTRA}/${shortname}.flac"
# nice -10 mac "$1" "${tempfile}" -d
# nice -10 flac ${FLACOPTS} --output-name="${flacname}" "${tempfile}"
# rm -f "${tempfile}"
}

Delete all "#" there, make one before "kdialog" and save the file.

Then you can do "audioconvert -t f filename.ape".
I want to keep audiokonverter simple and sensible. It is not easy to add ape files to the servicemenu, because the mimetype is different in every distro. Probably it is not even existing in most distros, because the software to use it is not free.

Report

cowb0y

7 years ago

Works great on Kubuntu (Karmic and previously). Thanks for your contribution to making the free desktop more usable.

Report

apileocole

8 years ago

Hello, because I switched from kubuntu I couldn't get the error message mentioned in my previous post but it was probably a packaging problem.

Anyway I'm using SuSE with KDE 4.3x at this time and missed your very handy utility. Because the SuSE rpm is old and you note only *8.2 should be used with KDE 4x, I tried to install it from the .gz package. install.sh doesn't work. Activating it in terminal as regular user "./install.sh" brings up a dialog asking install or uninstall options. I click install. A message box labeled "Sorry - KDE su" then appears at this point with this exact message:
"Command './install.sh --global' not found"

Do you know how to fix this or provide an up to date rpm for use w/KDE 4x?

Report

C

labrum

8 years ago

Please open a terminal in this directory and try "sudo ./installKDE4.sh"

Report

apileocole

8 years ago

Result in terminal:

"kdialog: cannot connect to X server
Installation cancelled."

Report

C

labrum

8 years ago

Then try "xhost +" before. This will allow anyone to connect to your Xserver. "xhost +<your ip>" will allow anyone on your computer.

Report

apileocole

8 years ago

Well I should probably look into xhost stuff before messing around with that, but I'd rather not. I did a bit of searching and may be mistaken but it's just that it should be kdesu not kdesudo. kdesu brings up the authorization box, then the dialog menu to install/uninstall. Selecting install globally yeilds the same error as reported before when doing the same as normal user: "A message box labeled "Sorry - KDE su" then appears at this point with this exact message:
"Command './install.sh --global' not found"" Or if it "should" be kdesudo, SuSE doesn't have kdesu/kdesudo set up the way the script expects?

Report

C

labrum

8 years ago

Please try sudo ./installKDE4.sh --suseinstall
It worked on my virtual box SUSE installation!

Report

mohareve

7 years ago

It has to be installed as normal user and it works, although it complains about mppdec, id3info,id3v2,id3cp and apetag. This is for Kubuntu 9.10

Report

C

labrum

7 years ago

I added a package for karmic koala. The programs it complains about add functionality, but it also works without them. My package will not resolve dependencies so far!

Report

Fix 2 months ago

fixed paths for KDE4

2 years ago

fix for ogg decoding

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
5.9.5
updated Aug 29 2017
added May 13 2004
downloads today
0
page views today 1