Kopete DeskList Plugin

Various KDE 1.-4. Improvements

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on git.opendesktop.org

0
Score 79%
Description:

This is a plugin for Kopete that displays all online (as in not offline) contacts right on the desktop, Karamba style.
It uses contact photos and transparency to give a unique new look to your contact list. You can close the regular contact list to system tray to reduce window clutter.

Many features of the real contact lst are accessible via this list: double click starts chat, groups can be collapsed, tool tips and (with some restrictions) context menus can be used.

The look is extremely configurable to adapt to as many users needs as possible.
The option to exclude single contacts as well as whole groups is now available.

Last changelog:

12 years ago

New in 0.3.0:

- improved rendering engine
(the window is now only completely redrawn if the number of displayed contacts changes, otherwise the existing window is modified, which doesn't cause the flicker)
- added an context option for contacts as well as groups to be excluded from the desklist (accessible via meta contact/group context menu)
- hopefully fixed some crashes caused by removal of meta contacts
- added a couple of configure checks

Thanks to Daniel Faust for the new Suse RPM!

bolleg

10 years ago

Hey,

since the download link for Suse seems to be broken I tried to compile from source. I am using suse 11.0. ./configure is working without problem, but make stops after undefined references to kopete. I installed kdenetworks-devel... is there any other thing to take care of?

Regards,

Bolleg

Report

gothicbob

10 years ago

I second the opinion for the desklist plugin to be added to the new kopete.

I'd also suggest trying to get in into the kopete svn, so that it is included as a default plugin. It is just the sort of quality plugin that kopete needs.

Report

stevenjoseph

10 years ago

Hi is there a kde4 version of this plugin ...

Report

dglent

11 years ago

i have a problem with the mouse over. when i work in a application and i have to click in the position that desklist is behind , the mouse does not work. i have to open kopete → configure plugins → un select desklist and after reselect, but i have to do it many times. Can i fix that ?
thank you

is a great plugin, indispensable in my desktop environment

mandriva 2008.0
kde 3.5.7

Report

MADevil

11 years ago

Work great here , except perhaps transparency (it's not real transparency ???)

I've make an ebuild for Gentoo users, so i post it here !

kopete-desklist-0.3.0.ebuild
Quote:# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header:

inherit kde

S="/var/tmp/portage/kde-misc/kopete-desklist-${PV}/work/desklist"
DESCRIPTION="This is a plugin for Kopete that displays all online (as in not offline) contacts right on the desktop, Karamba style. It uses contact photos and transparency to give a unique new look to your contact list."
HOMEPAGE="http://conrausch.elise.no-ip.com/index.php?p=kopete_desklist"
SRC_URI="http://conrausch.elise.no-ip.com/kopete/desklist/desklist-${PV}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""

#FIXME Fix deps before KDE-4
DEPEND="( >=kde-base/kopete-3.5.5-r2 )"

need-kde 3.5.5

src_unpack() {
kde_src_unpack
}

Report

MADevil

11 years ago

replace

S="/var/tmp/portage/kde-misc/kopete-desklist-${PV}/work/desklist"
by
S="${WORKDIR}/desklist"

Report

bauerfichtner

11 years ago

I am using openSUSE 10.2 with KDE 3.5.7 and I can't compile this plugin. I compiled kopete from svn.
Trying to configure the desklist plugin with

./configure --prefix=/opt/kde3/ --with-qt-includes=/usr/lib64/qt3/include/ --with-qt-libraries=/usr/lib64/qt3/lib64/

is the only way to make the configure script find the libqt-mt library. However, it does never find KDE libraries (and they are installed in /opt/kde3).

Has anyone managed to compile this plugin on openSUSE10.2 with latest KDE 3.5? Any help is appreciated.

Report

nickajordan

11 years ago

I'm experiencing exactly the same problem on openSUSE 10.3. If anyone knows how to get it to compile I, too, would be extremely grateful.

Report

whome123

11 years ago

This looks like a great plug-in for Kopete but when I try to configure I get an error using Mepis 6.5.

Could not find Kopete header files!


Report

majewsky

11 years ago

This is a nice plugin, but many of my buddies have no icons. I have checked the settings dialogs, but there seems to be no option to turn the buddy icons off. Could one add this, please?

Report

shneeble

12 years ago

If the list of contacts gets too big for the screen is ist possible to continue the list in a new column?

Report

Hantilles

12 years ago

Hi,

I hope you're still working on this plugin, cause I have come to like it very much over the last two weeks since I began using it.

With an upgrade to a new xserver and a new i810 driver on my laptop I got finally my 3D desktop working with beryl fine as where I had many problems before.

The only usability problem I have with DeskList now is, that it doesn't work really well with beryl activated, as it doesn't show anymore on every workspace and pops up above my current window when it's view is updated. I would be great, it there's a possibility to make DeskList ready for the use with 3D desktops.

Report

trafikselskabet

11 years ago

I have the very same problem using Compiz running on openSUSE 10.2. And that is indeed very sad, beacause its a lovely plugin. I really hope I could be compatible with the 3d-desktops

Report

WMPhP

12 years ago

there isn't even any /usr/kde under /usr :x

Report

shneeble

12 years ago

I'm pretty sure it was the /usr or /usr/kde3 directory to use as prefix in kubuntu edgy

Report

i666an

12 years ago

Qt is installed in different locations depending on which linux you use. I am not sure about Fedora, but try :

./configure --prefix=/usr/kde/3.5

If this doesn't work, then search the internet for the Qt install path in fedora 6, and use that in the ./configure.

hope this helps

Report

WMPhP

12 years ago

the comments are full of newbie questions, I'm sorry for adding another :P
I'm using Fedora 6, and KDE 3.5.5.
When I run './configure --prefix=/usr' ('which kopete' prints '/usr/bin/kopete') it prints a lot of lines starting with 'checking ...' and then it prints this error and exit:

checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

and the last 6 lines of config.log are:

#define ksize_t socklen_t
#endif
#ifdef __cplusplus
extern "C" void std::exit (int) throw (); using std::exit;

configure: exit 1

The error says 'checking for Qt... configure: error: Qt (>= Qt 3.2)', but I have a Karamba theme that says "Qt: 3.3.7"
I also tried to run ./configure --prefix=/usr as a superuser, and the error was the same.
What can I do?

PS: I'd be pleased if someone explained me wth is "Qt" :P

Report

gecko

12 years ago

Maby you havn't installed the QT-dev packages. Check this out.
And for the path variable you have to search for the KDE-directory maby it is /usr/share/kde

Report

gecko

12 years ago

or maby you try the SuSE rpm-File.

Report

dkarlmt

12 years ago

I am really new to linux and need some help with the install of this plugin for kopete. I am using Xandros HP and still learning how to install programs outside of XN.

I downloaded the source file, and it shows up in file manager, and I know I'm supposed to extract the files, but I'm not sure where to extract to, and then what executable I should run.

Also, after that I'm not sure if Kopete will automatically recognize the new plugin, or if I have to show it where to look, and if so, how to do that.

Can someone help me with this?

Report

Coffeebot

12 years ago

For anyone else struggling like I did, you want to use --prefix=/usr

Kubuntu has KDE installed in /usr/lib and /usr/bin

Conrausch was quick and very willing to respond to my query. Great plugin, great author!

Report

scummos

12 years ago

if i try to install, xen says that libexpat.so.0 is missing... where can i get it??

i already searched whole google...

Report

Anaryin

12 years ago

Hey, sorry to bother with such a newbie question but I'm new to linux. I'm running Kubuntu Edgy Eft, the latest, and I dloaded and installed your improvement. All went well, I had to install a couple of libs to make it work but other than that, the config-make-mkinstall thing went well.

I have superkaramba Installed and I was wondering... how do I put the improvement to work? I can't find it anywhere... =/

Thanks!

Report

Anaryin

12 years ago

Forget it, forgot to add the --prefix.. =(

Great improve btw, congrts!

Report

lordcrow

12 years ago

What about an option to "Exclude All"(not groups, just all) except the people i really want(even if they're offline) in my desktop?

thanks!

cheers

Report

12 years ago

New in 0.3.0:

- improved rendering engine
(the window is now only completely redrawn if the number of displayed contacts changes, otherwise the existing window is modified, which doesn't cause the flicker)
- added an context option for contacts as well as groups to be excluded from the desklist (accessible via meta contact/group context menu)
- hopefully fixed some crashes caused by removal of meta contacts
- added a couple of configure checks

Thanks to Daniel Faust for the new Suse RPM!

product-maker 46 191

File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
Details
license
version
0.3.0
updated May 05 2006
added Dec 01 2005
downloads today
0
page views today 3