Konqueror Userscript
Various KDE Extensions
Score 68%
Description:

No update just uploading the 0.1.1 (kde3) to new file sharing provider (box.net)

So far, the only feature available is autoexecuting every file under ~/.kde/share/apps/konqueror/userscripts as js, within current document context.

TODO:
- enable disable userscript.
- include default script to emulate GMxx function or make it builtin

Screenshot #1
Shows an effect of the following code:
var elms = document.getElementsByTagName("a");
//alert(elms.length);

for(var i=0;i<elms.length;i++) {
elms.style.color="red";
elms.style.border="1px solid";
}

Screenshot #2
Shows textarea_drag_resize.js which originally a greasemonkey script (http://userscripts.org/scripts/show/5073). With a lil bit of modification, it's working in Konqueror (by defining some GMxxx function). The resize icon doesn't show up though. I don't know how to translate res://xx/xxx into a working konqueror format.

Konqueror version of textarea_drag_resize.js can be found here:
http://gudangupload.com/filelink.php?filecode=1dd91f4aa704ccfaaeb7db3b30fcc4af86c06efbb13ea873b8bf3cd23a51a9d1

Screenshot #3
Shows Greasemonkey Userscript metadata support
Last changelog:

10 years ago

v0.1.1
- Supports userscript metadata (//== UserScript== tag). include/exclude works (I assume greasemonkey using wildcard matching)

v0.1
- initial PoC version

soulrebel

9 years ago

Hi!
Is there still being work done on this project?

How can I download it? The Link wont work for me...

Thanks!

Report

kerenskyy

5 years ago

I guess it is not worked on anymore.

Report

Kiblet

9 years ago

This project is a WONDERFUL idea. I am having too many problems with Opera 9 and Firefox 2, and I would love to be able to use Konqueror with some extended functionality.

Konqueror immediately crashes after I install this, and try to open Konqueror, though. Please help me if you can--I really need another browser that works! I wish I could know whether it is Konqueror, QT or something else. If a backtrace would help, here it is:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1230854448 (LWP 27901)]
[KCrash handler]
#9 0xb78500b5 in QGListIterator::QGListIterator ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0xb5b0c97a in Pluginkonqtest::slotAction ()
from /opt/kde3/lib/kde3/libkonqtestplugin.so
#11 0xb5b0ce82 in Pluginkonqtest::qt_invoke ()
from /opt/kde3/lib/kde3/libkonqtestplugin.so
#12 0xb7596b11 in QObject::activate_signal ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb75977ed in QObject::activate_signal ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb7fae58c in KParts::ReadOnlyPart::completed ()
from /opt/kde3/lib/libkparts.so.2
#15 0xb5f2b3ab in KHTMLView::timerEvent () from /opt/kde3/lib/libkhtml.so.4
#16 0xb7596562 in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb75cf19c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb7537657 in QApplication::internalNotify ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb7538449 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb7b9db92 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#21 0xb752c863 in QEventLoop::activateTimers ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb74e64f0 in QEventLoop::processEvents ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb754e480 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb754e316 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb753720f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb67a4665 in kdemain () from /opt/kde3/lib/libkdeinit_konqueror.so
#27 0xb730e524 in kdeinitmain () from /opt/kde3/lib/kde3/konqueror.so
#28 0x0804e2ff in launch ()
#29 0x0804eb8a in handle_launcher_request ()
#30 0x0804ef0f in handle_requests ()
#31 0x08050103 in main ()

Report

Kiblet

9 years ago

Nevermind, in my confusion, I missed the part about adding a userscripts directory.

Most of my .js scripts give "Darn" errors, though.

Report

gentakojima

10 years ago

I've tried to use it, and after changing automake version to 1.7 (kubuntu feisty doesn't have automake 1.6) it compiled ok.

Then, it installed under following locations:

/usr/local/kde/lib/kde3/
/usr/local/kde/share/apps/khtml/kpartplugins/

I had to copy the .rc and .la files to other locations so konqueror recognised them:

/usr/lib/kde3/
/usr/share/apps/khtml/kpartplugins/

I suppose these would be fine too:

/usr/local/lib/kde3/
/usr/local/share/apps/khtml/kpartplugins/

But when I start konqueror it inmediately crashes, without an useful output.

Perhaps something relating to paths?

Btw, great work. Most konqueror users would love such an extension.

Report

milianw

10 years ago

i can confirm this.

crash log here: http://attachr.com/7552

Report

neofreko

10 years ago

Try mkdir the ~/.kde/share/apps/konqueror/userscripts/

I slightly remember the first PoC kinda have a bug related to that directory

Report

egonw

10 years ago

Neofreko, per Thiago's comment [1], I added a KDE Google Summer of Code project idea at [2]. Are you going to apply?

1.http://kemistry-desktop.blogspot.com/2007/03/chemical-kde-gsoc-projec-ideas.html
2.http://techbase.kde.org/Projects/Summer_of_Code/2007/Ideas#Konqueror_-_userscripts

Report

elijahlofgren

10 years ago

I was considering applying for that project, but it seems someone is already well on their way: http://namshub-kde.blogspot.com/2007/01/more-work-on-konquerors-user-scripts.html :)

Report

neofreko

10 years ago

It's almost a year, and I've just read the message. Guh.

Is there any some notification message somewhere for "my kde-apps comments"?

Report

neofreko

10 years ago

Oops, wrong calculation. Should have gone to bed before many things go wrong :D

Report

dtlin

10 years ago

Use this instead:
src="data:image/gif;base64,R0lGODlhDAAMAPcAAAAAAHNzc4yMjK2trf///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////ywAAAAADAAMAAAIPwAJCBxIsKDAAAEMDhQAAIAAhQIHDFD4kIBEgRUJBAAgEaFEAAk1chzgcQDIhREnEshI8CJEhg4hagwp02BAAAA7"

Report

jackiebrown

10 years ago

/usr/bin/m4:configure.in:61: bad regular expression: `AS_ESCAPE([$as_me:$LINENO: error: cannot run _AC_LANG compiled programs.
If you meant to cross compile, use `--host'.], [`""])': Invalid range end
/usr/bin/m4:configure.in:61: bad regular expression: `AS_ESCAPE([$as_me: error: cannot run _AC_LANG compiled programs.
If you meant to cross compile, use `--host'.], [`""])': Invalid range end
configure.in:39: error: possibly undefined macro: AM_INIT_AUTOMAKE

Report

jackiebrown

10 years ago

I can get past that but get stuck at
./configure: line 1271: syntax error near unexpected token `konqtest,'
./configure: line 1271: `AM_INIT_AUTOMAKE(konqtest, 0.1)

Report

mirshafie

10 years ago

this is a great idea. i hope you and others keep developing it. it's a shame that konqueror hasn't had userscripts until now.

Report

neofreko

10 years ago

Looking at the quality of my code, it's obvious that my C++/Qt/KDE skill is .. questionable :D. Thus, help from other would be definitely warmly accepted :)

Report

Kwilliam

10 years ago

What's the computer-info applet/widget running in the background of the first pic? And what window deco is that? I really like it.

(Greasemonkey scripts for Konqueror is a sweet idea.)

Report

neofreko

10 years ago

Running on the background is conky. This little app is configurable (what thing to display, display format, etc)

Win deco? It's actually fluxbox desktop (I forgot what theme it was) :D

Report

DanaKil

10 years ago

I had to downgrade to automake 1.6.3 and then, it seems to compile and install well but it don't works (tested with the Konqueror version of textarea_drag_resize.js and the script to put a border around links, in the right directory [~/.kde/share/apps/konqueror/userscripts])

Well, the problem comes maybe from me... but anyway, it seems to be a GREAT plugins :)

Thanks

Report

DanaKil

10 years ago

hm... actually it works, I had installed it in the false location (use "./configure --prefix=`kde-config --prefix`" !)

Thank you very much :)

Report

bobuse

10 years ago

A great demonstration of the possibilities that Konqueror offers :-)

Thanks

Report

10 years ago

v0.1.1
- Supports userscript metadata (//== UserScript== tag). include/exclude works (I assume greasemonkey using wildcard matching)

v0.1
- initial PoC version

product-maker kerenskyy Jun 26 2012

product-maker 14 36

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.1.1
updated Jan 13 2007
added Jan 12 2007
downloads today
0
page views today 0