wacom tablet
System Software
Description:

KDE 4 KCModule

This module implements a GUI for the Wacom Linux Drivers and extends it
with profile support to handle different button / pen layouts per profile.

For hardware support have a look at http://www.linuxwacom.sourceforge.net

Project Repository:
https://projects.kde.org/projects/extragear/base/wacomtablet

get the source with
git clone git://anongit.kde.org/wacomtablet

(K)Ubuntu 12.x & 13.04:
https://launchpad.net/~maret/+archive/wacom

OpenSUSE 12.2, 12.3 & Factory:
http://software.opensuse.org/download.html?project=home:Temar:wacom&package=kcm_tablet
Last changelog:

1 year ago

+++++++++++++++++++++++++++
# v3.0.0~beta1
First kde frameworks 5 release
* port kded to kf5
* port plasma widget to qml widget
* ported KCM to kf5
* support xcb and x11_input

Thanks a lot to Michael Abrahams, Juan Palacios, Weng Xuetian, Stephan Frank

There are still some known issue with the tablet screen mapping and hotplugging with xcb.

+++++++++++++++++++++++++++
# v2.1.0
* Add support for Cintiq 22HD 18 buttons
* Add image for the Cintiq 13HD layout
* Update Wacom Intuos PT S Finger touch device db entry
* Update Intuous button layout
* Update Wacom INTUOS Pen Small CTH-480 db entry (030E)
* Add Wacom Intuos Pro L PTH-851 to db (0316)
* Allow to setup Stylus/Eraser Tip Mosue button (Left-Handed Mode)
* Update database. Add HUION, add Waltop again, install missing vendors

Note:
you must install a wacom-driver 0.20 or higher
See:
http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=summary

leneve

6 years ago

Quote:
CMake Error at applet/CMakeLists.txt:13 (kde4_add_plugin):
Unknown CMake command "kde4_add_plugin".


is unknown with kde5libs -- dummy workaround (changing all refs to KDE4 in the src/CMakeLists.txt's to KDE5) didn't work. any ideas?

Report

Etric

6 years ago

The cmake file is correct (with kde4)
it is just a matter of the build system and the missing cmake macros.

Sadly, can't remember what i did once to fix this. Google might help here if you search for kde4_add_plugin"

Report

turquoiserabbit

6 years ago

Hey guys, I've got an intuos 3 and it works fine until I start this settings app. After loading it and applying settings the pen tip will only make a single click and will not allow you to click and drag. Which is a bummer, any ideas why this is happening?

The problem goes away with a system reboot, but then the settings aren't saved at all.

Report

Etric

6 years ago

This might be solved now.

Report

naught101

6 years ago

Hi, I have two screens set up, a Viewsonic VA2026 20" LCD and my laptop screen (12").

The bigger monitor is set up as monitor 1, at 1680x1050
the laptop screen is #2, "rightof" screen one, at 1024x768

I want to limit the wacom to only the right screen. This works, however the viewport of the wacom seems to set itself to 1352x1050, on the left (bigger) screen. When I limit it to the second screen, it also goes into the bigger screen a little, and far below the bottom, off the screen.

I think what's happening is that the wacom viewport is being set to:
x=(screen1x + screen2x)/2
y=max(screen1y,screen2y)

I have correctly set the resolutions in the "Screen Setup" tab.

It's usable as is, but it'd be nice to have the full screen to work with.

----
Two other things: every time I go to the "screen setup" tab, it resets the "twinview" field to vertical, which I don't use.
Also, would it be possible to just grab the resolutions from the Hardware>Display and Monitor>Multiple Monitors control panel?

It's great to see this. I only wish it was in more distro repos!

Cheers
ned

Report

Etric

6 years ago

Haven't set up my Wacom tablet in multiview setup in a while. I'll have to check that

It did work a while ago, but since the change to the new wacom-driver in xorg a few things changed

Will change the second thing
and i ddn't fetch them from it, because I had weired results with my nvidia card and the twinview option regarding the settings there (I have just 1 screen according to it, but the wacom driver still expects 2 screen to be set)

I did want to add this into the normal KDE repo (it is in KDE review since a while)

sadly the new xorg driver has changed and reduced in functionality, but added some bugs ;)

Some gus reported they couldn't use their tablet at all. Thats why it will have to wait a while before this will be available on a large scale

Report

kjetilk

6 years ago

I am using openSUSE 11.3 with KDE 4.5 and this doesn't "just work". The problem is the kded daemon. I am not sure if the problem is lacking entries in /etc/init.d or if there are other problems. At least I am not able to start the daemon from YaST's system services tool.

Report

Etric

6 years ago

Is the wacomtablet kded at least available in the service system settings menu?

If so, could it be that kded4 is crashing (happens with the 1.2.3 release, should be fixed in 1.2.3b)

As for kubuntu, somehow pure cmake .. which installs everything in /usr/local prevents the kded part from showing up in the system settings menu
only cmake .. -DCMake_INSTALL_PREFIX='kde4config --prefix' which installs as usual into /usr works on my end.

did you use the packages from the suse build service above? could you maybe check if the same happens when you build the package on your own?

Report

kjetilk

6 years ago

> Is the wacomtablet kded at least available in the service system settings menu?

I am not 100% sure I know where you mean when you write "service system settings menu". My installation is in Norwegian. I've translated the entries as best I can, but user interface translations are not always intuitive.

The place I would expect to find it is in YaSTs "Systemtjenester (kjørenivå)" (System services (runtime level)).

It is not there.

I also looked in Systeminnstillinger - System Settings where the entry "Inndataenheter" (Input Units). There's an entry there for the tablet, but that's the entry that complains that kded isn't running.


However.... I re-installed (1.2.3b-2.1) and now I found KDED in "Systeminnstillinger" -> "Systemadministrasjon" -> "Oppstart og avslutning" -> "Tjenestebehandler" (System Settings -> System Administration -> Startup and Shutdown -> Service Manager).
It is not running, but it could be started - and voila, the Wacom Tablet Settings module in Input Units is now running!

I tested some setting changes (button click assignments) and it worked nicely. Brilliant!

Report

naught101

6 years ago

in systemsettings>System administration>Startup and Shutdown>Service Manager
in the second pane, there should be a "wacom tablet" service. Select that and press "start", and then try.

Report

kjetilk

6 years ago

I am using openSUSE 11.3 with KDE 4.5 and this doesn't "just work". The problem is the kded daemon. I am not sure if the problem is lacking entries in /etc/init.d or if there are other problems. At least I am not able to start the daemon from YaST's system services tool.

Report

JanMalte

6 years ago

The svn repository is not available

Report

Etric

6 years ago

*whups* changed the svn path to the current one in kdereview

Report

azagoth

6 years ago

1.2.3

Crashed KDED4

Application: KDE (kded4), signal: Segmentation fault
[KCrash Handler]
#5 0x00007fa6aec055f2 in Wacom::DeviceHandler::findXInputDevice() () from /usr/lib/kde4/kded_wacomtablet.so
#6 0x00007fa6aec062e3 in Wacom::DeviceHandler::detectTablet() () from /usr/lib/kde4/kded_wacomtablet.so
#7 0x00007fa6aec08e00 in Wacom::TabletDaemon::deviceAdded(int) () from /usr/lib/kde4/kded_wacomtablet.so
#8 0x00007fa6aec09993 in Wacom::TabletDaemon::TabletDaemon(QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kded_wacomtablet.so
#9 0x00007fa6aec0a357 in QObject* KPluginFactory::createInstance<Wacom::TabletDaemon, QObject>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kded_wacomtablet.so


Kubuntu 10.04.1 amd64

Report

Etric

6 years ago

wonder why this things never happen on my system.

Nevertheless, I've hopefully fixed it.

Report

azagoth

6 years ago

First time after install its work fine, but after reboot its crashed.

KDE 4.4.2

Report

azagoth

6 years ago

Work fine after reconfigure by
http://ubuntuforums.org/showthread.php?t=1515562

Thank you!

Report

azagoth

6 years ago

I got it!
First - start KDED4
Second - modprobe wacom

If wacom.ko it is already loaded, then KDED4 crash.

Report

Etric

6 years ago

could you install the debug packages for kde as well and tell me the line in which the kded4 crashes (so the proper output from the KCrashHandler)

It is somewhere in findXInputDevice but i can't find where and on my end the kded will not crash no matter what I try.

Report

azagoth

6 years ago

apt-get install kdelibs5-dbg libqt4-dbg

http://kde.pastebin.com/Naf9PLBn

Report

azagoth

6 years ago

1.2.3b work fine with kded4

But it is nothing setup.
Screen setup won't work.
(i have TwinView)
Pad Buttons won't changes.

Bamboo CTH-460

Report

nowardev

6 years ago

doesn't work anyway

xsetwacom list dev

Wacom Graphire4 4x5 eraser ERASER
Wacom Graphire4 4x5 cursor CURSOR
Wacom Graphire4 4x5 pad PAD
Wacom Graphire4 4x5 STYLUS

xsetwacom get "Wacom Graphire4 4x5" tabletid
21

sudo nano /usr/share/kde4/apps/wacomtablet/data/wacom_devicelist

added but....noway doens't work


[0015]
model=CTE_440
layout=unknown
name=Wacom Graphire4 4x5
padbuttons=2
wheel=yes
touchring=yes
touchstripl=yes

Report

Etric

6 years ago

is the kded started? in the system settings you can start/stop the kded services on its own.

usually when my program is installed the service is not started right away (but will start every time the system is restarted afterwards)

in case the kded is running, could you start the kded with debug output please.

to enable debug output, run:
kdebugdialog
and enable the output for the kded (or just everything)

in the konsole run:
kquitapp kded
then
kded4

plugin / out you tablet and the wacomtablet should complain why your tablet is not found

Report

nowardev

6 years ago

kded4 was crashing everytime
and yea was your software :D
downloaded the B version
and it's working
ty so much
wheel still doesn't work on my graphire buyt i know it's a xsetwacom problem with my tablet.

Report

nowardev

6 years ago

libxi-dev to compile on kubuntu..
but doesn't work :D

xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech USB Mouse id=9 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=11 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=12 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 eraser id=13 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 cursor id=14 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 pad id=15 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=10 [slave keybo

Report

1 year ago

+++++++++++++++++++++++++++
# v3.0.0~beta1
First kde frameworks 5 release
* port kded to kf5
* port plasma widget to qml widget
* ported KCM to kf5
* support xcb and x11_input

Thanks a lot to Michael Abrahams, Juan Palacios, Weng Xuetian, Stephan Frank

There are still some known issue with the tablet screen mapping and hotplugging with xcb.

+++++++++++++++++++++++++++
# v2.1.0
* Add support for Cintiq 22HD 18 buttons
* Add image for the Cintiq 13HD layout
* Update Wacom Intuos PT S Finger touch device db entry
* Update Intuous button layout
* Update Wacom INTUOS Pen Small CTH-480 db entry (030E)
* Add Wacom Intuos Pro L PTH-851 to db (0316)
* Allow to setup Stylus/Eraser Tip Mosue button (Left-Handed Mode)
* Update database. Add HUION, add Waltop again, install missing vendors

Note:
you must install a wacom-driver 0.20 or higher
See:
http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=summary

Filename Version Description Filetype Packagetype License Downloads Date Filesize Install
Score 81%
81.00 Likes
19 Dislikes
Details
version
3.0.0~beta1
updated Oct 28 2015
added Nov 04 2009
downloads
page views 19321