Description:

WARNING: Ksquirrel needs maintainer and someone who will port it to KDE4.

KSquirrel is an image viewer for KDE implementing OpenGL.

Features:
* dynamic format support (~ 50 image formats)
* customizable filters
* external tools
* file tree
* thumbnails, extended thumbnails
* KIPI support
* KEXIF support
* list view, icon view, detailed view, thumbnail view
* archive support
* view of currently mounted partitions
* flexible options
* slidedshow
* preview window
* opera-like tabs
* Konqueror integration

KSquirrel is the first viewer for KDE widely supporting such a quantity of formats, including Photoshop PSD, X cursors, animated GIF, WMF, SVG, DXF, JPEG2000 and APNG.

The detailed information, format of libraries with examples, screenshots you can find visiting web page http:// ksquirrel.sourceforge.net/

** Important: You should have video drivers installed (means hardware-accelerated OpenGL support).

At this time KSquirrel supports 57 image formats.
Last changelog:

6 years ago

ksquirrel-0.8.0 and ksquirrel-libs-0.8.0
****************************************
* new runtime options:
--nodirectorybasket
--noimagebasket
--nocategories
--nomountview
* added Konqueror intergation module
* added printing feature in image window
* added codec manager, which will allow to
enable/disable image codecs (requires root password)
* fixed licensing issues in source code
* fixed MIME types in .desktop files
* time counting in image window is more fair

ksquirrel-libs:
* added EPS, PSP
* bugfix in PNM decoder on P3 PNMs
* bugfix in CAMERA codec, when KSquirrel couldn't open raw fotos

zyghom

9 years ago

this is extremely good and fast software
this is what I was missing here on Linux !

Report

drcux

9 years ago


thx for the patch ;)

Report

nbecker

9 years ago

diff -r d16c4f4c26a2 kernel/kls_psp/fmt_codec_psp.cpp
--- a/kernel/kls_psp/fmt_codec_psp.cpp Fri Dec 07 20:05:10 2007 -0500
+++ b/kernel/kls_psp/fmt_codec_psp.cpp Fri Dec 07 20:09:41 2007 -0500
@@ -118,7 +118,7 @@ bool fmt_codec::ReadGenAttributes()
if (Header.MajorVersion != 3)
ChunkLen -= 4;

- if (!frs.readK(&AttChunk, std::min(sizeof(AttChunk), ChunkLen)))
+ if (!frs.readK(&AttChunk, std::min(sizeof(AttChunk), size_t(ChunkLen))))
return false;

// Can have new entries in newer versions of the spec (4.0).
@@ -220,7 +220,7 @@ bool fmt_codec::ReadLayerBlock()

ChunkSize -= (2 + 4 + NumChars);

- if (!frs.readK(&LayerInfo, std::min(sizeof(LayerInfo), ChunkSize)))
+ if (!frs.readK(&LayerInfo, std::min(sizeof(LayerInfo), size_t(ChunkSize))))
return false;

// Can have new entries in newer versions of the spec (5.0).

Report

CKulT

9 years ago

Thanks for the patch. I'll update -libs tommorrow.

Report

nbecker

9 years ago

fmt_codec_psp.cpp: In member function 'bool fmt_codec::ReadGenAttributes()':
fmt_codec_psp.cpp:121: error: no matching function for call to 'min(long unsigned int, ILuint&)'
fmt_codec_psp.cpp: In member function 'bool fmt_codec::ReadLayerBlock()':
fmt_codec_psp.cpp:223: error: no matching function for call to 'min(long unsigned int, ILuint&)'
make[2]: *** [fmt_codec_psp.lo] Error 1

Report

donpedro69

9 years ago

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu

...
configure: error: "Header file konq_operations.h is missing. Please install kdebase-devel package."

thoug kdebase-dev installed

krzysztof@Athlon64X2:~/install/ksquirrel-0.7.5$ sudo apt-get install kdebase-dev
[sudo] password for krzysztof:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Reading state information... Gotowe
kdebase-dev jest już w najnowszej wersji. [eng: kdebase-dev already installed in latest version]

Report

CKulT

9 years ago

Try to install kde-devel, or libkonq4-dev

Report

CKulT

9 years ago

JPEG2000 stuff
------------------

Since version 0.7.3, binary package of ksquirrel-libs for Debian/Ubuntu depends on libjasper-1.701 OR libjasper1. It will allow to install ksquirrel-libs_0.7.3-1etch_i386.deb both in Debian Etch and in Kubuntu Gutsy with libjasper-1.900. But in order to use JPEG2000 codec with libjasper1 (e.g. 1.900) without problems you should do one simple trick (as root):

# ln -s /usr/lib/libjasper.so.1.0.0 /usr/lib/libjasper-1.701.so.1

If you don't need JPEG2000 at all, you can simply remove this codec:

# rm -f /usr/lib/ksquirrel-libs/libkls_jpeg2000.so.0.7.3

Report

srog

9 years ago

Good work !


JPEG2000 decoder is much faster now - Hooray ! (It really is).

Report

drcux

9 years ago

Hi,

could you please raise your release if you have an update in sourcecode?

For example: 0.7.2.1

Detlef

Report

civtwo

9 years ago

Is there a way to start a slideshow without a given delay between the slides, so that you have to press a key/mouse button to get the next picture?

Report

CKulT

9 years ago

In this case slideshow will act as image window. Use image window instead.

Report

civtwo

9 years ago

That did it, thx for this great program :-).

Report

pressh

9 years ago

Just wondering, do you plan on porting ksquirrel to kde4/qt4 ?

Report

CKulT

9 years ago

not earlier than KDE4 based Debian/KUbuntu will be released :)

Report

joelswartz

9 years ago

I've successfully compiled and installed all files without errors, but get these errors when trying to run ksquirrel 0.7.2. on my Debian box. Can anyone point me towards a resolution please?
***************************
joels@debian3:~/Documents/ksquirrel-0.7.2$ ksquirrel
ksquirrel: +KSquirrel
ksquirrel: +SQ_LibraryHandler
/usr/lib/ksquirrel-libs/libkls_jbig.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_jbig.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_jbig.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_mng.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_mng.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_mng.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_png.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_png.la: invalid ELF header
/usr/lib/ksquirrel-libs/libkls_png.la: invalid ELF header
KCrash: Application 'ksquirrel' crashing...

Report

CKulT

9 years ago

Try to install .debs from http://ksquirrel.sourceforge.net/download.php

Report

joelswartz

9 years ago

I actually had tried that approach first. I have since found problem-I apparently had some files installed from a previous version, so I cleaned all the old stuff, tried make install again and now all is working.

Thanks for your help.

Report

srog

9 years ago

Kubuntu Gutsy can use Debian Etch package (ksquirrel-0.7.2.deb) but it can't use ksquirrel-libs-0.7.2.deb. It will tell:

Package: ksquirrel-libs
Status: Error:Dependency is not satisfiable: libjasper-1.701-1

Gutsy has:
libjasper1
The JasPer JPEG-2000 runtime library
Available versions: 1.900.1-3 (gutsy)

Here is ksquirrel-libs_0.7.2-1_i386.deb:
http://www.badongo.com/file/4586264
Compiled in Kubuntu Gutsy.

You also need:
Gamin
Package: gamin (0.1.8-2ubuntu1)
File and directory monitoring system
Package: libgamin0 (0.1.8-2ubuntu1)
Client library for the gamin file and directory monitoring system.

If you don't have those:
ksquirrel: error while loading shared libraries: libfam.so.0: cannot open shared object file: No such file or directory

After these. KSquirrel is working fine. Good work!

Report

CKulT

9 years ago

If JPEG2000 is the only problem with dependencies, you try one simple trick with libraries:

1) install libjasper1_1.900
2) create symlink (as root):

# ln -s /usr/lib/libjasper.so.1 /usr/lib/libjasper-1.701.so.1

3) use dpkg with "--force" to install ksquirrel-libs:

# dpkg -i --force all ksquirrel-libs_0.7.2-1etch_i386.deb

This should work :)

Report

gassauer

9 years ago

ksquirrel: ...G/2007/20070817_Heu/IMG_3091.JPG" => JPEG compressed
kio (KIOJob): stat
ksquirrel: ERR_MALFORMED_URL
QGDict::hashKeyString: Invalid null key
ksquirrel: ERROR: : couldn't create slave : Unable to create io-slave:
klauncher said: Unknown protocol ''.

Report

CKulT

9 years ago

How did you try to open IMG_3091.JPG ? Give me more info. From command line or from KSquirrel itself ? Also give me full URL of IMG_3091.JPG image.

Report

gassauer

9 years ago

today it works, may be after restart of the desktop

Report

zabivator

9 years ago

http://diceron.livejournal.com/34654.html
Please, release some feature.
It's russian layer, he is migrate her oficce from M$ to OpemSource.
KSquirrel is gut, but some small problem...
Thank you.

Report

CKulT

9 years ago

Hi. As I understood, Riven has problems with printing. Unfortunately this is doesn't depend on me. Since version 0.7.0-pre1 KSquirrel supports KIPI plugins, so you should send a feature request to Todd Shoemaker - the author of KIPI Print wizard.

Thanks :)

Say, 0.7.1 with KEXIF and kio-slaves support is coming soon :)

Report

6 years ago

ksquirrel-0.8.0 and ksquirrel-libs-0.8.0
****************************************
* new runtime options:
--nodirectorybasket
--noimagebasket
--nocategories
--nomountview
* added Konqueror intergation module
* added printing feature in image window
* added codec manager, which will allow to
enable/disable image codecs (requires root password)
* fixed licensing issues in source code
* fixed MIME types in .desktop files
* time counting in image window is more fair

ksquirrel-libs:
* added EPS, PSP
* bugfix in PNM decoder on P3 PNMs
* bugfix in CAMERA codec, when KSquirrel couldn't open raw fotos

Filename Version Description Filetype Packagetype License Downloads Date Filesize Install
Score 82%
82.00 Likes
18 Dislikes
Details
version
0.8.0
updated Jun 24 2010
added Apr 29 2004
downloads
page views 1808