Description:

QComicBook is a viewer for PDF files and comic book archives containing jpeg/png images, which aims at convenience and simplicity. Features include:

* automatic handling of archives
* full-screen mode
* two-pages mode
* continuous scrolling mode
* frame view mode (frame-by-frame reading, comic frame detection)
* japanese mode
* thumbnails
* page scaling (fit to window width/height, whole page) and rotating
* mouse or keyboard navigation, whatever you prefer
* bookmarks

QComicBook requires Qt4 library, poppler library, zip, rar/unrar, tar, p7zip and unace programs to handle archives.

ATTENTION: I need translators! Please read README-translations and contact me if you'd like to translate QComicBook.
Last changelog:

5 years ago

* removed thin border around scroll area widget.
* fixed compilation errors on some systems (such as Ubuntu) caused by conflict with Page.h from libpoppler.

yogin

11 years ago

This is could be a nice feature. For now however I want to focus on viewing abilities and stability, so that qcomicbook would be an ultimate comicbook viewer for linux ;). I'll consider this feature in the future. Thanks for your idea.

Report

blurymind

11 years ago

Hi,I am sorry to bother you again.I noticed that i am not the only one with this problem in Ubuntu.I hav upgraded ubuntu installation to Hoary ,but have tried it on warty too and this is what I get at dpkg or apt-get:
-------------------------
The following packages have unmet dependencies:
qcomicbook: Depends: libc6 (>= 2.3.2.ds1-21) but 2.3.2.ds1-20ubuntu13 is to be installed
Depends: libqt3c102-mt (>= 3:3.3.4) but 3:3.3.3-7ubuntu3 is to be installed
E: Broken packages
-------------------------
I tried with force version and installed it,but it didnt run....so as I really LOVE this app,I went googlind and found older versions on some polish(i believe) website,where i got v 0.2.0 and I again i met some dependancy problems,but i didnt have to force it,and when i executed the app it worked flawlessly,but then synaptic simply stated that the package is broken and each time i had to do apt-get,it removed it and i had to install it again.I tried to find older versions but never did.I went on searching a way to make apt ignore it as broken and found out that there are many people who want this in the next synaptic/apt release.I found a tutorial but it was for the rpm version of apt(for fc3).Please,is it possible to put a link on your website to a cvs tree with the older versions of qcomicbook.Ubuntu is like the n1 distro at the moment.Many people love this app alot.
:(

Report

raditzman

11 years ago

Hi, I use ubuntu, and I do this:

1 - put debian unstable repositories in /etc/apt/sources.list. I use this line:
'deb http://http.us.debian.org/debian unstable main contrib non-free'
2-update apt (sudo apt-get update)
3-install the failed dependencies (sudo apt-get install whatever)
4-install the package (dpkg -i qcomicbook-version.deb)
5-remove debian repositories again
6-update apt back to normal (same as 2):)

works fine for me :)



works great!!!!

Report

blurymind

11 years ago

Thanks a bunch!
Its funny how I coudnt find this at ubuntu forums.There are few other packages who had problems with versions.
At first it said that I dont have a public key,but it downloaded the needed packages and updated them effortless.

This takes care of the problem.
==================================
I would like to report a minor bug-the last version,ubuntu/debian
here it is:
http://img101.echo.cx/img101/3796/screenshot3hy.png

and it doesnt change if i stretch the window.I know that its a small one,but bleh

Report

raditzman

11 years ago

I don't get that bug. Send it to the author, I'm sure he'll appreciate it.

btw, I posted to ubuntu too the reply I gave you :)

Dan

Report

blurymind

11 years ago

Great!

I am very thankfull and i am sure this will help many other.

Report

Aikurn

11 years ago

Don't mess with libc6! You can have really big problems when updating the kernel and other important packages. Use Ubuntu's supported version of the library, and compile QComicBook yourself.
It's worth it :)

Report

blurymind

11 years ago

...thanks ,but the warning came to late.What I did kinda messed up my kernel few days later and i had to get things to normal again(which was a pain in the neck).
Can i make a deb package for ubuntu specially?Does anyone have a tutorial for this.I heard you can use alien,but things dont come out as perfect.
I know how to compile,but how do i extract the deb package?

Report

diaphanu

12 years ago

I'm a absolute newbie.
I've just instaled mandrake 10.1
Does QComicBook run on that distro?
If not, is there a chace that a Mandrake version will be available?
TIA

Report

yogin

12 years ago

As far as I remember binary package is available in Mandrake Cooker repository (search main Mandrake site for links). However, their version may not be up-to-date, so you may want to download & compile source package by yourself.

Report

diaphanu

12 years ago

Tks for your prompt reply.
I didn't find Mandrake Cooker repository and (mea culpa) I don't have a clue how to compile the source package.
So I will try to use one of the "compiled for other distros" file and, if it does not work, hope someone using Mandrake and QComicBook that knows how to compile put it available to download.

Report

yogin

12 years ago

You may search for mandrake package (and also for rpms for other distros) using this search engine: http://rpm.pbone.net. I see the latest version is already available.

Report

blurymind

12 years ago

here it is:
http://img112.echo.cx/img112/8554/snap21cd.png
----------------------
Ok,i have few ideas for a splash screen for your app.This is only the basics,i havent color it yet,so look at it just as a sketch of my idea.I need your opinion and what size exatcly do you want it to be.As you can see we have Tux with a straw in his mouth and a red cape on his back in a talk bubble,forming the letter Q.I think of either a bottle at the end of the straw,or maybe a comic book.I will add the words:comic and book in separate bubbles or something like that.If its a bottle,i think of putting a comic book(your choice for a title/png image)as a background,but i think of blurring the bg abit.
I will clean up the lines and color it.
I couldnt contact you,because you dont have a propa email...but here is mine:
blurymind@excite.com
-----------------------
I still have few bright ideas.I also made few icons.

Report

norguhtar

12 years ago

ebuild updated.

Report

blurymind

12 years ago

Well,the bookmarks option works pretty well now.I had some issues with it in the past.

One thing that i notised is that when i load a zip/rar archive,which contains only one folder and then in the folder-the pictures,QCBook doesnt load it,saying:
¨ërror opening comic archive.File/directory not found¨

Report

yogin

12 years ago

Hmmm, I can't reproduce your error... Can anyone else confirm such problem? Could you check if archive was decompressed correctly (check contents of /tmp/qcomic-*) and see if file permissions are ok there?; please report if problem was found. You may also try the current work-in-progress version of qcomicbook - http://linux.bydg.org/~yogin/qcomicbook-test.tar.gz and see if it helps.

Report

blurymind

12 years ago

Its kinda weird,because it does it only to some of the zip archives,that I created(just an ordinary ziped folder,that contains jpg files)...

Another thing that i do not like is that i cannot erase a bookmark,when i am not at the bookmarked comic.Is it possible to make something like a bookmarks window.I dont say that you have to.The program is perfect as is now.I am really loving it.
It will be really cool if you add ¨clear recenly opened list¨to that window.I noticed that you made a settings window.You can add those options there,if its not too much of a pain in the ass,hehe.

I really love your app,its one of my favourite under linux.:)

Report

blurymind

12 years ago

oh,i forgot to say,that i am also thinking of making a logo for qcomicbook.I have some skills with the Gimp and few ideas.That is if you are thinking of a logo,that is...

I wonder how do i send it to you.I can put the links to it here,when i am done.:P

Report

sobit

12 years ago

The ebuild linked on your site seems to have disapeared. I had some improvements for it.

Great veiwer by the way.

Report

norguhtar

12 years ago

Check links now.

Report

CARTMAN

12 years ago

Will you make an optional KDE port?

Report

yogin

12 years ago

Yes, I'll probably add support at least for KDE file dialog; this and any other KDE features will be optional at compile-time, so Qt will be enough for compiliation. KDE will be supported as soon as I discover how to extend my current autoconf script for it ;)

Report

CARTMAN

12 years ago

I can help you write autoconf crap. Just drop me a mail in case.

Report

devriesz

12 years ago

The preview is pure genius :-).

One comment: make it 'autohide' in fullscreen mode (F11).

Report

Sputhnic

12 years ago

First of all the program is excellent for on screen reading of comic books. It leaves little area of improvement except that there should be the possibility to change the reading direction from left -> right to right -> left, as this is common in japanese manga. But not only there, also for arabic content (I don't know if they have comics, but I guess so) it makes sense, as this is also a letter system read in this direction.

Bernhard

Report

5 years ago

* removed thin border around scroll area widget.
* fixed compilation errors on some systems (such as Ubuntu) caused by conflict with Page.h from libpoppler.

Filename Version Description Filetype Packagetype License Downloads Date Filesize Install
Score 83%
83.00 Likes
17 Dislikes
Details
version
0.8.1
updated Jul 08 2011
added Jan 07 2005
downloads
page views 1990