profile-image

dplentini

David Lentini North Berwick, ME, United States of America
Qalculate

Plasma 4 Widgets 88 comments

Score 86%
86 Likes
14 Dislikes
Oct 22 2009
Can't you define the RPN mode to work like an HP calculator: number <Enter> number <operation> ... ? - Oct 08 2009
Thanks! I added the library, and the applet compiled like a charm. :-)

Now if I can only figure out how RPN works on Qalculate. :-| - Oct 07 2009
Hi! I love this applet, but when I tried to compile 0.6.4 to upgrade from 0.4, I get the following:

david@DD:~/qalculate_applet-0.6.4/build$ cmake .. -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
CMake Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:84 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/david/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:6 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
david@DD:~/qalculate_applet-0.6.4/build$ make
make: *** No targets specified and no makefile found. Stop.
- Oct 07 2009
Score 72%
72 Likes
28 Dislikes
Oct 13 2010
Thanks for the tip. I removed the "qt3" files as you described, and I confirmed the "qt4" were installed, but I still can't compile the program. Here's the current output:

david@DD:~/ktikz-0.9$ qmake
Project MESSAGE: *** KTikZ v0.9 ***
Project MESSAGE: The program will be installed in
Project MESSAGE: /usr/bin
Project MESSAGE: The translation files will be installed in
Project MESSAGE: /usr/share/ktikz
Project MESSAGE: The desktop file will be installed in
Project MESSAGE: /usr/share/applications
Project MESSAGE: KDE includes: /usr/lib/kde4/include/KDE /usr/lib/kde4/include
Project MESSAGE: KDE libs: /usr/lib/kde4/lib
Project MESSAGE:
Project MESSAGE: If you would like to change these paths,
Project MESSAGE: please adjust conf.pri to your needs and rerun qmake.
Project MESSAGE:
Project MESSAGE: In order to disable KDE file dialogs in this application,
Project MESSAGE: hide the line "CONFIG += usekde" in conf.pri.
david@DD:~/ktikz-0.9$ make
cd src/ && make -f Makefile
make[1]: Entering directory `/home/david/ktikz-0.9/src'
Makefile:369: warning: overriding commands for target `../build/obj/configappearancewidget.o'
Makefile:225: warning: ignoring old commands for target `../build/obj/configappearancewidget.o'
Makefile:373: warning: overriding commands for target `../build/obj/configeditorwidget.o'
Makefile:236: warning: ignoring old commands for target `../build/obj/configeditorwidget.o'
Makefile:378: warning: overriding commands for target `../build/obj/configgeneralwidget.o'
Makefile:241: warning: ignoring old commands for target `../build/obj/configgeneralwidget.o'
Makefile:382: warning: overriding commands for target `../build/obj/editgotolinewidget.o'
Makefile:245: warning: ignoring old commands for target `../build/obj/editgotolinewidget.o'
Makefile:386: warning: overriding commands for target `../build/obj/editindentdialog.o'
Makefile:249: warning: ignoring old commands for target `../build/obj/editindentdialog.o'
Makefile:391: warning: overriding commands for target `../build/obj/editreplacewidget.o'
Makefile:254: warning: ignoring old commands for target `../build/obj/editreplacewidget.o'
Makefile:397: warning: overriding commands for target `../build/obj/templatewidget.o'
Makefile:293: warning: ignoring old commands for target `../build/obj/templatewidget.o'
make[1]: *** No rule to make target `/usr/share/qt3/mkspecs/default/qmake.conf', needed by `Makefile'. Stop.
make[1]: Leaving directory `/home/david/ktikz-0.9/src'
make: *** [sub-src-make_default] Error 2
- Oct 07 2009
Thanks. I used the "make distclean" command, and that seemed to make some progress, but then I got a version error stating that my version of Qt (4.x) was too new (vs. 3.3.8b):

cd src/ && make -f Makefile
make[1]: Entering directory `/home/david/ktikz-0.9/src'
Makefile:369: warning: overriding commands for target `../build/obj/configappearancewidget.o'
Makefile:225: warning: ignoring old commands for target `../build/obj/configappearancewidget.o'
Makefile:373: warning: overriding commands for target `../build/obj/configeditorwidget.o'
Makefile:236: warning: ignoring old commands for target `../build/obj/configeditorwidget.o'
Makefile:378: warning: overriding commands for target `../build/obj/configgeneralwidget.o'
Makefile:241: warning: ignoring old commands for target `../build/obj/configgeneralwidget.o'
Makefile:382: warning: overriding commands for target `../build/obj/editgotolinewidget.o'
Makefile:245: warning: ignoring old commands for target `../build/obj/editgotolinewidget.o'
Makefile:386: warning: overriding commands for target `../build/obj/editindentdialog.o'
Makefile:249: warning: ignoring old commands for target `../build/obj/editindentdialog.o'
Makefile:391: warning: overriding commands for target `../build/obj/editreplacewidget.o'
Makefile:254: warning: ignoring old commands for target `../build/obj/editreplacewidget.o'
Makefile:397: warning: overriding commands for target `../build/obj/templatewidget.o'
Makefile:293: warning: ignoring old commands for target `../build/obj/templatewidget.o'
/usr/share/qt3/bin/uic editreplacewidget.ui -o ../build/ui/editreplacewidget.h
uic: File generated with too recent version of Qt Designer (4.0 vs. 3.3.8b)
make[1]: *** [../build/ui/editreplacewidget.h] Error 1
make[1]: Leaving directory `/home/david/ktikz-0.9/src'
make: *** [sub-src-make_default] Error 2 - Sep 25 2009
Hi! I love v. 0.8 of this program, so I couldn't wait to install the update; but I can't compile the code. I get the following output:

david@DD:~/Dropbox/Downloads/ktikz-0.9$ qmake
Project MESSAGE: *** KTikZ v0.9 ***
Project MESSAGE: The program will be installed in
Project MESSAGE: /usr/bin
Project MESSAGE: The translation files will be installed in
Project MESSAGE: /usr/share/ktikz
Project MESSAGE: The desktop file will be installed in
Project MESSAGE: /usr/share/applications
Project MESSAGE: (null)
Project MESSAGE: If you would like to change these paths,
Project MESSAGE: please adjust conf.pri to your needs and rerun qmake.
Project MESSAGE: (null)
Project MESSAGE: In order to enable KDE file dialogs in this application,
Project MESSAGE: unhide the line \"CONFIG += usekde\" in conf.pri.
david@DD:~/Dropbox/Downloads/ktikz-0.9$ make
cd src && make -f Makefile
make[1]: Entering directory `/home/david/Dropbox/Downloads/ktikz-0.9/src'
Makefile:369: warning: overriding commands for target `../build/obj/configappearancewidget.o'
Makefile:225: warning: ignoring old commands for target `../build/obj/configappearancewidget.o'
Makefile:373: warning: overriding commands for target `../build/obj/configeditorwidget.o'
Makefile:236: warning: ignoring old commands for target `../build/obj/configeditorwidget.o'
Makefile:378: warning: overriding commands for target `../build/obj/configgeneralwidget.o'
Makefile:241: warning: ignoring old commands for target `../build/obj/configgeneralwidget.o'
Makefile:382: warning: overriding commands for target `../build/obj/editgotolinewidget.o'
Makefile:245: warning: ignoring old commands for target `../build/obj/editgotolinewidget.o'
Makefile:386: warning: overriding commands for target `../build/obj/editindentdialog.o'
Makefile:249: warning: ignoring old commands for target `../build/obj/editindentdialog.o'
Makefile:391: warning: overriding commands for target `../build/obj/editreplacewidget.o'
Makefile:254: warning: ignoring old commands for target `../build/obj/editreplacewidget.o'
Makefile:397: warning: overriding commands for target `../build/obj/templatewidget.o'
Makefile:293: warning: ignoring old commands for target `../build/obj/templatewidget.o'
/usr/share/qt3/bin/uic editreplacewidget.ui -o ../build/ui/editreplacewidget.h
uic: Could not open output file '../build/ui/editreplacewidget.h'
make[1]: *** [../build/ui/editreplacewidget.h] Error 1
make[1]: Leaving directory `/home/david/Dropbox/Downloads/ktikz-0.9/src'
make: *** [sub-src] Error 2

This happens whether I run as su or not. What's going wrong?

Can someone make DEB for jaunty?

Thanks! - Sep 13 2009