profile-image

falkTX

FIlipe Coelho , Portugal

QtSixA

System Software Feb 22 2010
Score 61%
61 Likes
39 Dislikes
QtCurve (KDE4, KDE3, & Gtk2 Theme)

QtCurve 2889 comments

Score 78%
78 Likes
22 Dislikes
Jan 16 2013
Yet another request for GTK+ 3 support, thanks - Feb 02 2012
'Q' DVD-Author

Video 80 comments

Score 79%
79 Likes
21 Dislikes
Jan 09 2010
For those who want qt4 like, use qt3-qtcurve.

debs here:
https://launchpad.net/~falk-t-j/+archive/lucid/+files/kde3-style-qtcurve_0.69.1-0ubuntu0+ppa1_amd64.deb
https://launchpad.net/~falk-t-j/+archive/lucid/+files/kde3-style-qtcurve_0.69.1-0ubuntu0+ppa1_i386.deb
- Jan 18 2010
gtk-kde4

KDE 1.-4. Improvements 305 comments

Score 88%
88 Likes
12 Dislikes
Oct 22 2010
I compiled it on my 64bit laptop and after logout/login, nothing happens.
(Running Kubuntu 9.10; and I did remove the kcm-gtk thing).

I also manage to create a 64bit Deb, but since it doesn't to be working...


After a little searching, I found that manually running your app get this:
_______________________________________
*** glibc detected *** gtk-kde4: double free or corruption (out): 0x00007fffb064b6a0 ***
======= Backtrace: =========
/lib/libc.so.6[0x7fd191e95dd6]
/lib/libc.so.6(cfree+0x6c)[0x7fd191e9a70c]
/usr/lib/libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x44d)[0x7fd193b0b11d]
/usr/lib/libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x4f)[0x7fd192ff215f]
/usr/lib/libQtGui.so.4(_ZN11QMainWindow5eventEP6QEvent+0x7b)[0x7fd1933689db]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac)[0x7fd192fa3efc]
/usr/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x37e)[0x7fd192fab1ce]
/usr/lib/libkdeui.so.5(_ZN12KApplication6notifyEP7QObjectP6QEvent+0x36)[0x7fd194011e56]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x8c)[0x7fd193afbc2c]
/usr/lib/libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x2ba)[0x7fd193afc80a]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication4execEv+0xfc)[0x7fd193afcafc]
gtk-kde4[0x405bca]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7fd191e3eabd]
gtk-kde4[0x405719]
_______________________________________

then a big memory dump, which I think should not be needed.

I have practice compiling packages (for PPAs too if you want).
I see future on this, although I detected some errors on your Deb file.
PM me if you wanna help
- Nov 15 2009