skrooge

Financial

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on git.opendesktop.org

23
Score 89%
Description:

Skrooge is a personal finances manager powered by KF5, aiming at being simple and intuitive, yet powerful.

NEWS :
------
http://skrooge.org/news

AVAILABLE FEATURES:
-------------------
* KMyMoney, QIF, CSV, import/export
* OFX, QFX, Microsoft Money, MT940, Gnucash, Grisbi, homebank import
* Advanced Graphical Reports
* Several tabs to help you organize your work
* Infinite undo/redo (even after the file was closed !)
* Instant filtering on operations and reports
* Infinite categories levels
* Mass update of operations
* Scheduled operations
* Track refund of your expenses
* Automatically process operations based on search conditions
* Automatic budget computation based on your past expenses


INSTALLATION:
-------------

The recommended installation procedure is simply to install from your distro's package manager. However, if the latest Skrooge version is not in your distro's repository. You can install from sources :

More information at http://techbase.kde.org/Projects/Skrooge

C

willy9

9 years ago

I also think Arch has KDE4 in /usr.

Can you try
cmake . -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`

And see what it gives ?

Oh, and by the way, what happens if you start skrooge from a konsole ? Do you get any error from there ?

Report

righello

9 years ago

very little progress... now it show the splash screen and the "view" menu but the program is still unusable...
screenshot http://img18.picoodle.com/img/img18/3/1/21/f_skrooge1m_b18f883.png

started from konsole i get this
################################################
##STARTING SKROOGE
################################################
skrooge(32516)/kdecore (KSycoca) KSycocaPrivate::openDatabase: Trying to open ksycoca from "/var/tmp/kdecache-marco/ksycoca4"
skrooge(32516)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType "Skrooge/Plugin" not found
skrooge(32516): Attempt to use QAction "view_context" with KXMLGUIFactory!


hope this could help!

Report

miguipda

9 years ago

All the nine modules to change it to kde 4.1 is explained here :
http://www.slax.org/modules.php?action=detail&id=970

Thanks.

Have a nice day,

Miguipda ;-)

Report

C

willy9

9 years ago

Oh, OK, sorry I simply went to the "modules" page. Will definitely have a look.

Report

C

willy9

9 years ago

Oh, OK, sorry I simply went to the "modules" page. Will definitely have a look.

Report

C

willy9

9 years ago

Sorry for not getting back yet, my laptop is slowly dying, I can't build anything at the moment... Will keep you updated when I make some progress.

Report

miguipda

9 years ago

Hi,

oh, here is kde 4.1 ... yess please offer us your program for christmas ... yes...

SIncerely thanks and I wish you a merry christmas and an happy new year.

Thanks to create your program module for slax :
http://www.slax.org/modules.php?category=&search=&author=130&page=2

Have a nice day.

Miguipda ;-)

Report

C

willy9

9 years ago

OK, I'll have a look !!! Hope it will be on time for christmas...

Report

C

willy9

9 years ago

Hmm, I still don't see KDE4.1 for slax... Did I miss something ?

Also, it looks like the easiest way to create a slax module would be to convert it from a slackware .tgz... Is there anyone out there using slackware who would be willing to package skrooge for us ?

Report

C

willy9

10 years ago

Márcio Moraes translated skrooge in Brazilian Portugese. From the next version on (0.1.7), our brazilian users will enjoy skrooge in their native language !
Many thanks from the Skrooge Team to Márcio !!!

Report

C

willy9

10 years ago

Skrooge rpm is now available for OpenSUSE 11.0 & 11.1 ! Provided you activated and updated the "packman" repository, you should be able to install skrooge from yast or zypper.

Many thanks to Toni Graffy for packaging skrooge !

Report

C

willy9

10 years ago

Skrooge rpm is now available for OpenSUSE 11.0 & 11.1 ! Provided you activated and updated the "packman" repository, you should be able to install skrooge from yast or zypper.

Many thanks to Toni Graffy for packaging skrooge !

Report

C

willy9

10 years ago

Skrooge rpm is now available for Mandriva 2009.0 and Cooker ! Provided you activated and updated the "contrib backports" media, you should be able to install skrooge from the Mandriva Control Center.

Many thanks to Funda Wang from the skrooge team for packaging skrooge !

Report

C

willy9

10 years ago

If anyone is interested in packaging skrooge for a specific distro, please let me know !

Report

miguipda

10 years ago

Hi,

yes I am interrested to have it under slax distro.
For that have a look to developper guide : http://www.slax.org/documentation.php

Sincerely thanks and with pleasure to use it as quick as possible.

Report

C

willy9

10 years ago

I have a special fondness for slax, it is the first distro I regularly used (that was in 2004) before switching to a full blown installed distro. Memories...

However, as much as I like it, it seems it is still based on KDE 3.5, whereas skrooge requires KDE 4 libraries. I couldn't find any module for those, so it seems at first sight it is not yet possible to get a slax module running. Am I wrong ?

Report

File (click to download) Version Description Packagetype Architecture Downloads Date Filesize DL OCS-Install
Pling
Details
license
version
2.2.0
updated Dec 01 2015
added Nov 02 2008
downloads today
0
page views today 17
System Tags app software