LilyKDE

Audio Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

1
5.0
Description:

LilyKDE is a Free Software project to make working with the LilyPond music typesetter within KDE very easy. If you are a LilyPond user and you have KDE, then LilyKDE is for you.

The main part of LilyKDE is a plugin for Kate, with the following features:

[li]Run LilyPond on the current document with a keystroke.[/li][li]Show an embedded PDF preview. When you click on a note or another object, Kate jumps to the correct document and cursor position.[/li][li]A powerful Score Wizard to quickly set up a LilyPond document.[/li][li]Display LilyPond's messages in a log view. Error messages are also clickable.[/li][li]Direct MIDI input from a MIDI-keyboard or even your computer keyboard. This powerful function uses Rumor for the actual work, but it can automatically set the key and time signature according to the current document. You can adjust the metronome speed very easy by clicking on a "Tap" button. Many other settings are available.[/li][li]After LilyPond has run you can open, email or print PDF documents and play MIDI files with a mouseclick from within Kate.[/li][li]Automatic hyphenation of Lyric texts using dictionaries from e.g. OpenOffice.org or Scribus.[/li]

The other parts of LilyKDE are:

[li]MIME type information and an icon for LilyPond files[/li][li]A textedit:// service to make the clickable links work anywhere in KDE[/li][li]A Konqueror servicemenu and helper app to run LilyPond from within Konqueror on selected files[/li][li]Katepart syntax highlighting for LilyPond documents (also part of KDE)[/li]

LilyKDE is translated into Dutch, French, Turkish, Spanish, Russian, Italian and German.
Last changelog:

11 years ago

Changes in 0.6.6 (since 0.6.5):
- Translations update
- Minor improvements

Changes in 0.6.5 (since 0.6.4):
- Improve adding articulation etc. to selection. Now also recognizes chords and skips commands like \ff which were previously recognized as pitches.
- New Rhythm tab in Quick Insert panel with some powerful functions manipulating the rhythm of the selected music.
- Handling of non-ascii characters in filenames has been fixed.


Changes in 0.6.4 (since 0.6.3):
- New Quick Insert Panel, with already one convenient tool to insert articulations and ornaments, one by one or to a group of notes at once.

Changes in 0.6.3 (since 0.6.2):
- ScoreWizard: Choir: use \center-column if LilyPond >= 2.11.57
- config option to always empty log when a LilyPond job is started
- All vocal part types have now a checkbox Ambitus that adds the Ambitus_engraver to the correct staff or voice, showing the pitch range of that vocal part
- Example x-lilypond.conf file for Expand plugin added

olivierberten

10 years ago

Hi!

Great piece of software!

KDE4 is now coming to all the distros. Is there any release plan for a KDE4 port of LilyKDE?

Report

C

wbsoft

10 years ago

Thanks for your comment!

Regarding KDE4: Yes, sure!

As soon as Pate (the Kate Python plugin framework by Paul Giannaros) becomes available for KDE4, LilyKDE will be ported to KDE4. But if not, it could also be possible to turn LilyKDE into a standalone application for KDE4 (using the Katepart text editing component).

Report

C

wbsoft

10 years ago

... with some changes that should hopefully fix LilyKDE's behaviour when there are non-ascii characters in filenames.

Report

lucarossi

10 years ago

Hi,

i just installed Lilykde (thnks for developing this tool!)
All works except for the pdf preview: when pressing ctrl+alt+M the pdf tab appears in kate but without the pdf document in it.

What could it be?
I use lilykde 0.6.4 with kate 2.5.6 on kde 3.5.6

thanks
Luca

Report

lucarossi

10 years ago

in addition: this is the debug output of kate:

Traceback (most recent call last):
File "util.py", line 244, in _slotExit
File "runlily.py", line 185, in _finish
File "runlily.py", line 210, in completed
File "runlily.py", line 81, in previewPDF
File "pdf.py", line 54, in openFile
AttributeError: dcopClient

Report

C

wbsoft

10 years ago

Hmm. I call KApplication.kApplication().dcopClient() instead of KApplication.dcopClient(). It works on my system. If you want to try, change line 54 of $HOME/.kde/share/apps/lilykde/lilykde/pdf.py from:

c = KApplication.kApplication().dcopClient()

to:

c = KApplication.dcopClient()

this should work, next release (0.6.6) will contain this fix.

Thank you for your report!

Report

C

wbsoft

10 years ago

What exactly is the full pathname of the file you are editing?

Report

jakoblund

10 years ago

I just installed 0.6.4. It installs works nicely, once I got Pate in place, which was a major pain to do (the trick was uninstalling python2.4 from my system, as someone mentioned in an earlier post here.)

Thanks for your work with this - I'm a big fan of lilypond, and LilyKDE makes editing much easier.

One problem I found: The textedit: service seems to not work with non-ascii characters in filenames. I get this error

Traceback (most recent call last):
File "/home/jakob/.kde/share/apps/lilykde/ktexteditservice.py", line 30, in <module>
url = unicode(sys.argv[1])
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 21: ordinal not in range(128)

the file in question is called /home/jakob/øveren/gearampale_medley/medley10.ly -- you see that mean &oslash; in there :-) ?

Report

C

wbsoft

10 years ago

Could you please try opening /home/jakob/.kde/share/apps/lilykde/ktexteditservice.py and changing line 30 into:

url = sys.argv[1]

so just remove the call to unicode() ?

Next release will contain this fix, if it works.

Report

C

wbsoft

10 years ago

it seems this works:

ktexteditservice.py line 30:

url = sys.argv[1].decode(sys.getfilesystemencoding()).encode('latin1')

Please let me know if it works in your system as well.

Report

C

wbsoft

10 years ago

thanks for your feedback. I will try to investigate.

Report

Alfaro

11 years ago

Hi !

Thanks for LilyKDE, it is really a useful program.

I have some problems with LilyKDE configuration : I cannot access the "Configuration" Tab in "configure Python plugins" : I've got just a blank tab.

Thus, I cannot configure the paths in order to use the hyphenation function (Nothing occurs when I click on "Hyphen words").

I've tried with both v0.5.4 and 0.6.0beta.

(I'm running a kind of Debian distribution with a multimedia kernel (mix between 64Studio and Debian Lenny)).

Can you help me ?

Thanks.

Report

C

wbsoft

11 years ago

Well, I guess you have no KDEDIRS in your environment (the hyphen module just expected it to be set, so it bailed out when it is not set).

I made hyphen.py more robust in commit 484, so that it just uses some default search paths if KDEDIRS is not set.

0.6 will contain this improvement, that will hopefully fix hyphenation on your system!

Report

Alfaro

11 years ago

Hi !

Thank you for the quick answer.

I've got the following output in Konsole while accessing the configure tab :

Traceback (most recent call last):
File "/usr/share/apps/kate/pyplugins/configureplugins.py", line 144, in show
self.onConfigure()
File "/usr/share/apps/kate/pyplugins/configureplugins.py", line 224, in configurePlugin
self.pluginConfigure(self.configurationWidget)
File "/usr/share/apps/kate/pyplugins/lilypond.py", line 83, in configure
settings(parent)
File "settings.py", line 19, in settings
File "settings.py", line 52, in __init__
File "settings.py", line 58, in addModule
File "settings.py", line 147, in load
File "hyphen.py", line 81, in <module>
File "hyphen.py", line 40, in findDicts
File "/usr/lib/python2.5/UserDict.py", line 22, in __getitem__
raise KeyError(key)
KeyError: 'KDEDIRS'

Report

C

wbsoft

11 years ago

Thank you! So I guessed right, that referencing KDEDIRS while it is not set on your system was the problem. I fixed it already. You can get the svn version or just wait for 0.6.0 which will be released shortly.

Report

C

wbsoft

11 years ago

Thanks for your report. It seems there occurs an error on your system while building the config dialog.

Could you please run kate from the commandline (e.g. Konsole), and post the exact output here, after you open the config page?

The error message will point me in the right direction for a fix (I hope :-)

Thanks in advance!

Report

Alfaro

11 years ago

Hi !

Thanks for LilyKDE, it is really a useful program.

I have some problems with LilyKDE configuration : I cannot access the "Configuration" Tab in "configure Python plugins" : I've got just a blank tab.

Thus, I cannot configure the paths in order to use the hyphenation function (Nothing occurs when I click on "Hyphen words").

I've tried with both v0.5.4 and 0.6.0beta.

(I'm running a kind of Debian distribution with a multimedia kernel (mix between 64Studio and Debian Lenny)).

Can you help me ?

Thanks.

Report

sisko78

11 years ago

Hi,

have a little Problem with the preview.
In one line every note is notated a whole stop higher as it should be.

I think the fault was present in the last line until I reached line 4. It remained there, so after I finished the sheet, I have a faulty line 4 in preview.

The pdf output in acroread is fine.
I am confused ;)

Report

C

wbsoft

11 years ago

This is a rounding error in KPDF. Enlarge the preview (by middle-dragging) and the problem goes away.

Report

sisko78

11 years ago

Yes you are right, thanks.

The new wizzard is a really great feature. Keep up the good work.

Report

mapi

11 years ago


New LilyKDE version 0.5.2:

http://rpmlinux.org

Report

Superstoned

11 years ago

This is neath. Any chance it will have integration with KOffice and it's note editing feature as well?

Report

C

wbsoft

11 years ago

Possibly yes, but I think LilyKDE will remain LilyPond-centered, so may be it will more look like OOoLilyPond in that you could click on notes and then edit the LilyPond source for it.

Report

pilpilon

11 years ago

A lot of thanks for this application!
If only it could be installed more easily...
But all in all, I'm very impressed.
Dreams come true.

Report

sisko78

11 years ago

Thank you for your app, it's great and I will use it for my next sheets. I forgot to mention that in my previous posts ;)

I am interested in your plans for future versions.
Will there be a wizzard like the one the lilypond plugin for jedit has?

Report

11 years ago

Changes in 0.6.6 (since 0.6.5):
- Translations update
- Minor improvements

Changes in 0.6.5 (since 0.6.4):
- Improve adding articulation etc. to selection. Now also recognizes chords and skips commands like \ff which were previously recognized as pitches.
- New Rhythm tab in Quick Insert panel with some powerful functions manipulating the rhythm of the selected music.
- Handling of non-ascii characters in filenames has been fixed.


Changes in 0.6.4 (since 0.6.3):
- New Quick Insert Panel, with already one convenient tool to insert articulations and ornaments, one by one or to a group of notes at once.

Changes in 0.6.3 (since 0.6.2):
- ScoreWizard: Choir: use \center-column if LilyPond >= 2.11.57
- config option to always empty log when a LilyPond job is started
- All vocal part types have now a checkbox Ambitus that adds the Ambitus_engraver to the correct staff or voice, showing the pitch range of that vocal part
- Example x-lilypond.conf file for Expand plugin added

12345678910
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.6.6
updated Nov 21 2008
added Feb 13 2008
downloads today
0
page views today 3