Description:

KXStitch can be used to create cross stitch patterns, either from imported images or directly by the user.

The download link is to the official KDE download mirrors and contains a source tarball. OpenSuSE packages are maintained by myself on the OpenSuSE Build Service.
Last changelog:

KXStitch 2.0.0 released for KF5 12 years ago

The 2.0.0 version has been released for KF5 with a number of improvements and lots of new language translations thanks to the KDE translation teams.

kenaesthetic

2 years ago

Yea I'm having a tough time here trying to get this up and running. I've installed fink, brew, macports, etc and followed every bit of documentation I can find all with no luck. When I run the ./configure command from the root kxstitch folder I get the "configure: error: The important program kde-config was not found! Please check whether you installed KDE correctly." -> Running Mavericks...

Report

kenaesthetic

2 years ago

Yea I'm having a tough time here trying to get this up and running. I've installed fink, brew, macports, etc and followed every bit of documentation I can find all with no luck. When I run the ./configure command from the root kxstitch folder I get the "configure: error: The important program kde-config was not found! Please check whether you installed KDE correctly." -> Running Mavericks...

Report

Ralsa

2 years ago

I can't compile it. ¿Where are the instrucctions, with the required dependencies?

Report

MoonBlossom

5 years ago

Thank you for making this available for KDE4. It is great software!!

Report

brrtkr

7 years ago

checking for kde-config... not found
configure: error: The important program kde-config was not found!
Please check whether you installed KDE correctly.

I don't know what do I have to install to run this script correctly. I use Mandriva 2010.1 with KDE4.4.3 with all packages installed on.

Report

MoonBlossom

8 years ago

I was glad to see updates on this project. Thank you!!

Report

mkyral

8 years ago

Me too.

I have only one small problem, does not compile on my gentoo :-(

Fails to find Magick++.h, but I have it on my system.

[19:02:38 root@gool kxstitch-0.8.3]# locate Magick++.h
/usr/include/ImageMagick/Magick++.h

[19:06:43 root@gool kxstitch-0.8.3]# eix -c -I Magick
[I] media-gfx/imagemagick (6.4.8.3@6.1.2009): A collection of tools and libraries for many image formats

Report

C

sallewell

8 years ago

There have been a few people reporting that the magick++ configure check has failed on their systems, Gentoo was one of those mentioned.

The work around using --with-extra-includes doesn't seem to work either.

At the moment I don't know what is causing this, but myself and others are investigating and hopefully a fix will be available soon.

Regards

Report

mkyral

8 years ago

Thanks,
It is good to know. If you need any help, just ask.

Regards,
Marian

Report

C

sallewell

8 years ago

I have installed the gentoo.2008 live cd in vmare and emerged kde-meta. I have tried compiling kxstitch-0.8.3 and everything worked correctly. configure passed the imagemagick test properly and the compilation and installation was successful.

So no nearer a solution for those with a problem and being unable to replicate it doesn't really give me a chance to solve the issue.

Report

C

sallewell

8 years ago

I have updated the code in CVS with some better checks for ImageMagick which has some changes to the namespaces for different versions. I have tried this on a couple of distributions and all works correctly.

Please feel free to check for yourself if you can. I will release an updated version in a couple of days if there are no adverse reports.

Regards


Steve

Report

mkyral

8 years ago

Thanks,
Just tested and the ImageMagick test passed and KXStitch compiled and run without problems.

checking pkg-config is at least version 0.9.0... yes
checking for IMAGEMAGICK... yes
checking if admin should be compiled... no
checking if doc should be compiled... yes

Report

mkyral

8 years ago

Hm, I'm not able to build kxstitch on amd64 :-(

http://bugs.gentoo.org/show_bug.cgi?id=63847#c23

Report

mkyral

8 years ago

So there is some collision with KDE4. I have KDE3 installed in /usr/kde/3.5 and KDE4 installed in /usr.

When I put --prefix=/usr/kde/3.5 kxstitch build fine. But when I use --prefix=/usr, it found KDE3 includes and libraries, but uses KDE4 includes and libraries as well and fails to build.

See configure.cache diff I've made.
https://bugs.gentoo.org/show_bug.cgi?id=63847#c28

Report

jbus

10 years ago

KXStich is really great.

Any plans to develop embroidery software? Linux is sorely missing software for machine embroidery.

It would be great to have a Linux software equivalent of Thred digitizing software http://www.thredworks.com/dwnlod.htm

The source code is there, but I'm not sure what (if any) license it was released under.

Report

kism

12 years ago

Program exits when I try to import image files. I have tried with png, jpg, bmp, etc. All the same.

Report

C

sallewell

12 years ago

Which version of KXStitch are you using? Which distribution? Have you installed from RPM (which one?)or from source? If from source, then there is the possibility that installation has been to /usr/local instead of the KDE base directory. This will exhibit the same behaviour of crashing. Does it also crash when you right click on the editor window? Again this is because it would be installed in the wrong place.

Another possible reason could be that ImageMagick isn't installed.

Report

xis

12 years ago

My girlfriend will love it! :)
She had to use windoze because of PC Stitch (or something like this). And now this app comes.

Thank you very much!

Report

nigels

12 years ago

[nigels@zooropa Wares]$ rpm -Uvh --test kxstitch-0.6-1.i586.rpm
error: Failed dependencies:
libMagick++.so.5 is needed by kxstitch-0.6-1.i586
libMagick.so.5 is needed by kxstitch-0.6-1.i586
liblcms.so is needed by kxstitch-0.6-1.i586
[nigels@zooropa Wares]$ locate libMagick
/usr/lib/libMagick++.so
/usr/lib/libMagick++.so.6.0.7
/usr/lib/libMagick++.la
/usr/lib/libMagick.a
/usr/lib/libMagick.la
/usr/lib/libMagick.so
/usr/lib/libMagick++.so.6
/usr/lib/libMagick.so.6.0.7
/usr/lib/libMagick.so.6
/usr/lib/libMagick++.a
[nigels@zooropa Wares]$ rpm -qf /usr/lib/libMagick.a
ImageMagick-devel-6.0.7.1-5.fc3

Report

l1nux

12 years ago

ln -sf /usr/lib/libMagick++.so.6.0.7 /usr/lib/libMagick++.so.5

Report

C

sallewell

12 years ago

Don't do this, there is a binary incompatability between versions 5 and 6 of ImageMagick. Best to upgrade.

Report

l1nux

12 years ago

work perfect :)
Debian package here:
http://l1nux.free.fr/index.php?action=downloadfile&filename=kxstitch_0.6-1_i386.deb&directory=Debian/Graphics&
Thanks

Report

KXStitch 2.0.0 released for KF5 12 years ago

The 2.0.0 version has been released for KF5 with a number of improvements and lots of new language translations thanks to the KDE translation teams.

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
updated Dec 03 2016
added Mar 26 2005
downloads today
0
page views today 3