Kate Autobookmarker plugin

Text Editors

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
6.4
Description:

This is a separate package of the latest version of the autobookmarker plugin for the katepart editor. The plugin has been disabled in KDE 3.4, but since several people have asked for it, here is a package.

I hope we can activate the plugin in the next version of Kate, the requirement is a way to not enable plugins pr default, because the plugin is problematic for those not wanting it and not knowing about its existence.

Because of the size limitations of packages here, you need to do a extra step to build. see the README file.

If you create a rpm or ebuild or slackware or debian package, please mail it to me and I will add it here (anders at alweb dk).

If you have problems using this package or comments, please email me (anders at alweb dk) or track me down at the freenode irc network (nick sredna, channels #kde, #kate)
Last changelog:

14 years ago

I uploaded a new package, please retry.
... and again. if i keep on, i'll end up providing a working one.

chrismk

11 years ago

I had been bringing it along each KDE upgrade and actually put off newer DEs for awhile because of autobookmarker in KATE.

Eventually it'd been too long and now with a very new Kubuntu install I cannot get this to work:

desktop:~/autobookmarker$ WANT_AUTOCONF=2.5 make -f admin/Makefile.common
*** YOU'RE USING autoconf (GNU Autoconf) 2.61.
*** KDE requires autoconf 2.53 or newer
make: *** [cvs] Error 1

there's nothing to configure without that step, and I used autobookmarker so hard I don't understand at all why it's not one of the default plugins.

Report

jirityr

14 years ago

I love this plugin but something missing to be 100% satisfied. Can you make this plugin a litle user fiendly? It's mean do this plugin look like a "Python Browser". It will be cool see list of functions and local variables for Perl and others languages.

Report

Yaba

14 years ago

> WANT_AUTOCONF=2.5 make -f admin/Makefile.common
*** Creating acinclude.m4
*** Creating aclocal.m4
aclocal: `configure.ac' or `configure.in' is required
make: *** [cvs] Error 1

> autoconf --version
autoconf (GNU Autoconf) 2.59
Written by David J. MacKenzie and Akim Demaille.

Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

> automake --version
automake (GNU automake) 1.9.1
Written by Tom Tromey .

Copyright 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.



Does any body know, what I can do? The README does not help. However I found a dead link in ./admin pointing to /opt/kdecvs/share/apps/kapptemplate/admin.

Report

C

anderslund

14 years ago

Sorry, let me try to fix the package

Report

14 years ago

I uploaded a new package, please retry.
... and again. if i keep on, i'll end up providing a working one.

12345678910
product-maker Count:25 Rating: 6.36
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.2
updated Mar 23 2005
added Mar 22 2005
downloads today
0
page views today 1
System Tags app software