Kate PHP Browser Plugin

Developers Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
Score 50.0%
Description:

Kate PHP Browser is a kate plugin to display PHP source structure information. I'm still playing with ideas, so any feedback is welcome.
There are some issues yet (there is only one view - by source file, and icons need work) but overall, I think is good for a first release.

This plugin requires antlr (www.antlr.org) to compile.

HosipLan

10 years ago

Hi, I'm getting some error and I'm completely lost, can you please take a look at this?

hosiplan@hosiplan-laptop:/media/ntbdata/downloads/kate/katephpbrowser-0.1beta$ sudo ./configure --with-antlr=/usr/bin/runantlr --prefix=/usr
checking build system type... i686-pc-linux-gnu
...
not using lib directory suffix
...
./configure: line 31327: no-config: command not found
./configure: line 31328: no-config: command not found
...
config.status: executing depfiles commands

Good - your configure finished. Start make now

hosiplan@hosiplan-laptop:/media/ntbdata/downloads/kate/katephpbrowser-0.1beta$ sudo make
make all-recursive
make[1]: Entering directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta'
Making all in data
make[2]: Entering directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/data'
Making all in icons
make[3]: Entering directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/data/icons'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/data/icons'
make[3]: Entering directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/data'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/data'
make[2]: Leaving directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/data'
Making all in src
make[2]: Entering directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/src'
Making all in parser
make[3]: Entering directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/src/parser'
Makefile:690: warning: overriding commands for target `libphpparser_la.all_cpp.cpp'
Makefile:678: warning: ignoring old commands for target `libphpparser_la.all_cpp.cpp'
no ./lexer.g
/bin/bash: no: command not found
make[3]: *** [PHPLexer.cpp] Error 127
make[3]: Leaving directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/src/parser'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/media/ntbdata/downloads/kate/katephpbrowser-0.1beta'
make: *** [all] Error 2

Report

mariostg

11 years ago

Won't build :

/usr/include/antlr/CharScanner.hpp: In member function 'bool antlr::CharScannerL iteralsLess::operator()(const std::string&, const std::string&) const':
/usr/include/antlr/CharScanner.hpp:565: error: 'strcasecmp' was not declared in this scope
make[4]: *** [PHPLexer.lo] Error 1
make[4]: Leaving directory `/tmp/katephpbrowser-0.1beta/src/parser'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/katephpbrowser-0.1beta/src/parser'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/katephpbrowser-0.1beta/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/katephpbrowser-0.1beta'
make: *** [all] Error 2

Report

dayvee

12 years ago

hi, if you're running debian lenny, you'll probably face problem with antlr. first you've to install libantlr-dev, then softly link /usr/bin/runantlr (fucking special name for debian) to /usr/bin/antlr. even after that you may suppose it to compile it correctly.
and you better install it to /usr instand of /usr/local, use './configure --prefix=/usr' :-)

Report

dias2000md

12 years ago

what about phplexer problem ?

Report

Blizzz

12 years ago

I found nothing in google, nothing in forums, and no help in irc, so i think now i may ask...

...after successfully compiling and installing it...

...how to get this plugin into kate?

It is not listed in extensen of configurating kate.

Report

Blizzz

12 years ago

Solved by online help: in Kubuntu you have to call ./configure with --prefix=/usr

Thanks, tsilva, I hope this plugin will have a future :)

Report

kritikatur

12 years ago

I am curious about your plugin, but i get the following error processing MAKE:

antlr ./lexer.g
Exception in thread "main" java.lang.NoClassDefFoundError: antlr.Tool
at gnu.java.lang.MainThread.run(libgcj.so.70)
Caused by: java.lang.ClassNotFoundException: antlr.Tool not found in gnu.gcj.runtime.SystemClassLoader{urls=[], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass(libgcj.so.70)
at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.70)
at java.lang.ClassLoader.loadClass(libgcj.so.70)
at java.lang.ClassLoader.loadClass(libgcj.so.70)
at gnu.java.lang.MainThread.run(libgcj.so.70)
make[3]: *** [PHPLexer.cpp] Fehler 1

antlr is installed and 'antlr' is in the folder.

Greetings Gernod

Report

MrPaul

13 years ago

I have this error when I try to compile:
/bin/sh ../libtool --silent --tag=CXX --mode=link g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -fexceptions -o katephpbrowserplugin.la -rpath /usr/lib/kde3 -module -avoid-version -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -R /usr/lib -R /usr/lib/qt-3.3/lib -R /usr/lib -L/usr/lib -L/usr/lib/qt-3.3/lib plugin_katephpbrowser.lo browsertab.lo browserlistview.lo schemaconfigurationdlg.lo schemasettings.lo schema.lo browserloader.lo browserlistviewitem.lo ../src/parser/libphpparser.la ../src/nodeclasses/libnodes.la -lantlr -lkateinterfaces
/usr/bin/ld: cannot find -lantlr
collect2: ld returned 1 exit status
make[3]: *** [katephpbrowserplugin.la] Erreur 1
make[3]: quittant le répertoire « /home/paul/Internet/Build/katephpbrowser/katephpbrowser-0.1beta/src »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /home/paul/Internet/Build/katephpbrowser/katephpbrowser-0.1beta/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/paul/Internet/Build/katephpbrowser/katephpbrowser-0.1beta »
make: *** [all] Erreur 2

I have Fedora Core 6

Report

C

tsilva

13 years ago

"/usr/bin/ld: cannot find -lantlr"

You should have antlr (version 2.7.6 should work) properly installed, as informed in the INSTALL file.

www.antlr.org

Report

clockworks

13 years ago

Oh man, I've been waiting for a plugin like this for a long time. Two questions: can you put the pane on the right hand side of the window? ..and can you sort the items alphabetically?

Report

C

tsilva

13 years ago

Two questions: can you put the pane on the right hand side of the window?

Kate can do this for you. Just right click on the tab and choose the side :)

..and can you sort the items alphabetically?

I didn't get the time to work in this plugin for sometime. Sorting items in someway is definetly something it should have eventualy. Maybe I'll be able to work on this in the next couple of months.

Report

Diavolo

13 years ago

I was searching for a plugin like that. Thank you very very much!

Report

netcelli

13 years ago

very coooooooollll i'm waiting for it thx a lot

Report

12345678910
product-maker Base: 4 x 5.0 Ratings
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
01.beta
updated Sep 20 2006
added Sep 20 2006
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0
System Tags app software