KTranslator
Utilities
Score 85%
Description:

KTranslator is a program to translate words from one language to another.

Now, I create a program (dictconv) to convert a dictionary from one format do another, like a sdict to stardict. The program requires zlib and libxml2.

The program supports conversion from Babylon glossaries (.bgl) to stardict. I think this is the unique GPL program that handles Babylon glossaries at moment.

Thanks to Karl Grill (for the reverse engineering) and Ricardo Villalba (from Wordtrans) it is now possible.

More formats will come soon.
Last changelog:

12 years ago

Dictconv
---------

0.2
---
Fix several bug mainly in Babylon glossary reader
Add CMake support (you can build the package with GNU tools or CMake now)
Add support to convert to plain text dictionaries
Add support to convert to DICT dictionaries

0.1
----
Inicial version


KTranslator
-----------

0.4
----
Sdictionary plugin
Fix a bug in Babylon plugin
Fix a bug in StarDict plugin

atordo

9 years ago

I was a kwordtrans user time ago and was missing something like this since it ceased being updated.

Also the different format support is impressive!

Report

vicbrother

9 years ago

Hello, ktranslator is a nice idea (I use ksteak, but it doesn't seems there will be new version for kde4), but I don't know about the dictionarys on my system or where I can get them. This is very bad usability - what should I do now?

Report

linux3114a

10 years ago

ktranslator-0.4-1.lotus.i586.rpm
at
http://home.scarlet.be/raoul.linux/rpm/ktranslate.html

Report

arnobaudu

10 years ago

Hi,

Just to say another GPL program handles babylon dictionaries: wordtrans.

Ktranslator looks like a nice peace of software anyway :)

Report

C

rgfernandes

10 years ago

Actually, wordtrans does not support Babylon glossaries (.bgl), it only supports Babylon dictionaries (.dic). This is a old format for Babylon program (v3.x).

Ricardo Villalba (developer of Wordtrans) was the one that sent me the work from Karl Grill, the one that reverse engineered the bgl format.

Report

linux3114a

10 years ago

ktranslator-0.4-lotus.i586.rpm
at
http://home.scarlet.be/raoul.linux/

under DOWNLOAD section ( My SUSE RPM's )

Report

tusitala

11 years ago

I've a little question about this application: Where I can find some other dictionary to add in data folder?

Report

bico

11 years ago

This is great! I have been using kdict with the dictd server until now, but your app is amazing. It supports so many types of dictionaries (without the server) and it can even "read" text from pictures. I hope that it will be included in SUSE distributions.

Thank you very much!

Report

Enso

11 years ago

I can't see much difference from wordtrans/kwordtrans

Report

miguipda

11 years ago

Hi,

may be interresting to add some new 'babylon 6' like functionnalities :
"Il offre également l’accès à l’encyclopédie Wikipedia ainsi qu’au contenu des plus grands dictionnaires et encyclopédies.".

Bye

Report

C

rgfernandes

11 years ago

Sorry for delay.
KTranslator can search in wikipedia through 'Search in Internet' button. Integrating the wikipedia like babylon 6 does is a feature to be added in the future.

Report

bobbix59

11 years ago

Hello,

I have used your ebuild. The installation works fine but, when I launch Ktranslator, I have the followings warnings :

kio (KMimeType): WARNING: KServiceType::offers : servicetype KTranslator/DictionaryPlugin not found
kio (KMimeType): WARNING: KServiceType::offers : servicetype KTranslator/UIPlugin not found

So, I can't load any dictionnary. The wizard is okay but, when it finishes, no dictionnary is added :-(.

Can you tell me what's wrong ?

Thank you, and congratulation for this usefull app

Report

C

rgfernandes

11 years ago

This is because KDE doesn't found the plugins.
Try to run kbuildsycoca (in konsole).
If it doesn't work, restart KDE.

Report

bobbix59

11 years ago

Okay, that's it. It works now :-). Thank you

Report

led

11 years ago

stardict dictionaries don't work in 0.4 :(
I intereted ktranslator mainly of stardict dictionaries support...

When it will work, I can make Ukraine and Russian translations and ggettext-patches...

Report

C

rgfernandes

11 years ago

If you tell me what's wrong I can help you. Only saying that the plugin doesn't work won't help.

Report

led

11 years ago

In 0.4rc2 dictionaries are added, but translation is not made, in 0.4 dictionary is added, but in the list does not appear at all :(

Report

C

rgfernandes

11 years ago

Can you send me the dictionary you are trying to load ? Send to my email, please. rgfbr@yahoo.com.br

Report

led

11 years ago

It is sent...

Report

C

rgfernandes

11 years ago

The problem is that the .idx file is compressed. I haven't make the code to handle this type of file yet.
If you decompress the .idx file (slovnyk_en-ru.idx.gz), it works well. I've just tried it here.

Report

led

11 years ago

Thanks! Yes, so works. Whether you plan support gzip'ed idx for stardict? I would like to pack ktranslator for ALTLinux Sisyphus repository, but stardict's dictionaries are in it in the form of idx.gz

Report

mmpm

11 years ago

I don't confirm to this. The plugin works fine.

I only missing a more convenient property-dialog. It is very uncomfortable inserting serveral dictionarys.

Anyway it's an excellent tool! I'm curious about the next version.

Report

mattepiu

11 years ago

Great! 0.4 working fine here, the only issue I found are with the dictionary
itself, shame that I can't add words when
dictionary doesn't find....

Report

C

rgfernandes

11 years ago

I'm planning how to add this feature.

You can add new words by now creating a Plain Text dictionary.

The format of this type of dictionary is a word per line:
headword[TAB]definition

Report

joe81

11 years ago

With every version of ktranslator I have tried, I have sometimes problems opening the popup window using the "special" key: sometimes it opens after 2 clicks, sometimes after 3 clicks, but in the last case all the line will be selected... I'm the one having this annoying problem?
it would be a very great and useful app!

Report

12 years ago

Dictconv
---------

0.2
---
Fix several bug mainly in Babylon glossary reader
Add CMake support (you can build the package with GNU tools or CMake now)
Add support to convert to plain text dictionaries
Add support to convert to DICT dictionaries

0.1
----
Inicial version


KTranslator
-----------

0.4
----
Sdictionary plugin
Fix a bug in Babylon plugin
Fix a bug in StarDict plugin

product-maker 55 337

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.4
updated Apr 02 2007
added Aug 22 2005
downloads today
0
page views today 0