moto4lin

System Software

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Description:

This is application for access Motorola P2k Mobile phones. Now supported upload/download files, seem editor.

asiangecko

5 months ago

where to grt the software?

Report

apacz42

11 years ago

I found on the internet two different windows layout of this application. One with the KJava button, and the other one, without. How to compile this app to get the KJava button?

Report

timcharper

14 years ago

I had trouble getting this to work at first. Here is what I did:

First (after compiling, following the instructions in INSTALL), I ran moto4lin as root. Then, I went into the preferences, and did an "update List" in the USB view under connection preferences. I found my phone in the list, and clicked both buttons "Set as AT device", and "Set as P2k device".

now, when I plugged in the phone, it would see that the phone was plugged in. It would say "Try to connect", then fail. I was frustrated.

Then I opened up the preferenced dialog again, and blanked out the values for "AT" device - because I thought that was getting in the way. Now the program only said "Phone connected as AT" and not "Phone connected as P2k" when I plugged it in. I knew I needed it to connect as p2k, because that is the file transfer protocol that motorola uses (I think AT is for modem connection... using it to dial up internet service).

So, here was what finally got it to work. I opened up the preference dialog, clicked "update list" in usb view, found my phone, clicked the "Set as at device", and then changed the value for AT Product ID: to a bogus value. I hit ok, replugged in my phone and, HURRAY! It only recognized "Phone connected as P2K'. I clicked connect, and it successfully connected.


Kind of a long description, but, I hope that helps anyone else who runs down that same path.

Tim

Report

trevi55

13 years ago

Thanks so much... At the beginning it worked well, but after that I clicked on "Set as AT device" it did't work again.

Now, I've read your suggestions, and my V525 still works! :)

Thanks a lot.

Report

aivs

14 years ago

I dont have /dev/ttyACM0.
What i need do?

[root@localhost aivs]# lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 003: ID 0df7:0620 Mobile Action Technology, Inc. MA-620 Infrared Adapter
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 004: ID 22b8:4810 Motorola PCS E398 Storage
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 0586:330a ZyXEL Communications Corp.
Bus 001 Device 001: ID 0000:0000
[root@localhost aivs]#

Report

karlandtanya

14 years ago

I can access my motorola v180, but only as root...

The device is /dev/usb/acm/0, 1, and 2 as follows:

crw-rw---x 1 root cellphone 166, 0
crw-rw---x 1 root cellphone 166, 1
crw-rw---x 1 root cellphone 166, 2

User is a member of group cellphone, and moto4lin looks at /dev/usb/acm/0.

anyhow, it works great as root, but as user, I can't connect. Also, as root, I get a lot more info when I update the USB View list. (if that info helps)

anyhow, so far, it seems like a way cool utility, but I have some problem in my permissions.

Can anybody suggest what I might have screwed up here?

Thanks a lot, and excellent tool!

I've added the line to /etc/hotplug/usb.usermap:

v180 0x0003 0x22b8 0x4902 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000

and added the file
/etc/hotplug/usb/v180
which contains
#!/bin/bash

if [ "${ACTION}" = "add" ] && [ -f "${DEVICE}" ]
then
chown root "${DEVICE}"
chgrp cellphone "${DEVICE}"
chmod 660 "${DEVICE}"
fi



Here's the log, btw

[info] Phone pluged as AT
Try to connect
[error] Unable to connect
[info] Phone is unpluged

switching to P2k doesn't help

info] Phone pluged as P2K
Try to connect
[error] Unable to connect


(all that as user, not root, of course)

thanks!

Report

famewolf

14 years ago

I have a Motorola C650..am running Suse 9.3...whenever I try to connect to my phone I get:

sh: /dev/ttyACM0: Invalid argument

Not sure what the deal is..I'm running as root..kmobiletools and wammu both work fine.

Report

ipolit

14 years ago

I found what was the problem with my slack kernel. There's one more module that has to be loaded. pl2303

Report

ipolit

14 years ago

same problem, but when I lsmod
cdc_acm 0
cpia 47104 1 cpia_usb
kernel 2.6.11.2 Slack 9.1 Qt 3.3.4
I have /dev/ttyACP0
/dev/ttyACM0
which one? doesn't work with both

and another strange thing

AT product ID 4902
P2K product ID 4902

when I plug and dmesg

usb 1-2: new full speed USB device using uhci_hcd and address 4
usb 1-2: device descriptor read/64, error -71
usb 1-2: device descriptor read/64, error -71
usb 1-2: new full speed USB device using uhci_hcd and address 5
midi: probe of 1-2:1.0 failed with error -5
cdc_acm 1-2:1.0: ttyACM0: USB ACM device

motorola c650

Report

ipolit

14 years ago

installed morphix
everything is fine, unless I have to plug and unplug the cable until the phone accept addressing
thanks for your work

Report

anthony55789

14 years ago

I have a moto a835 (connection point is /dev/ttyACM0 module load is acm) phone is recognized but not open file manager.

Report

thekid

14 years ago

I can't connect to my Motorola V180 phone. I keep geting an "[error] Unable to connect" warning. The program says the phone is connected as AT. Program won't switch to P2k. I'm using the cdc-acm module and /dev/mobile (works under kmobiletools). Is there a P2k module for linux? This application really needs a forum.

kelnio@yahoo.com

Report

C

dion

14 years ago

Okay. At first you must run moto4lin as root or current user must have write permissions to /proc/bus/usb/*.

Press preferences button and check, that ACM device is correct. Also check:
---
AT Vendor : 22b8
AT Product: 4902

P2k Vendor: 22b8
P2k Product 4901
---

Then try to connect. Also you can try to do command:
echo "AT+MODE=8" > /dev/ttyACM0 from console. After this command, you must see phone in lsusb.

Report

aleko

14 years ago

Hi,

I have a Motorola C650 and I've got the same connection problem. I did everything as you explained but I still can't connect. I can see the phone in lsusb and usbview but moto4lin still gives the 'unable to connect' error. Please help.

Report

gml

14 years ago

why don't you develop a kio-slave for konqueror ? it's most pratic for a kde user.

Report

C

dion

14 years ago

This is good idea. But before I want to release new version with separated GUI (Qt based) and P2K API.

Report

gml

14 years ago

Very good idea, a librairy for this permits others projects to support this (for example a Gnome application)
Maybe you write your library without QT dependencies, to facilitates the reuse with other projects.

Report

RockMan81

14 years ago

Voted as good!
As i said to the developers i'm really enjoing with this tool
I'm waiting for a shared library, perhaps we'll make a kio-slave in my kmobiletools

Report

zodar2

14 years ago

I'm on Suse 9.2, 2.6.8 and 2.6.10.
Following notes in "INSTALL", return me the following error:


sergio@linux:~/src/moto4lin-0.3> qmake
sergio@linux:~/src/moto4lin-0.3> make
cd moto_ui && make -f Makefile
make[1]: Entering directory `/home/sergio/src/moto4lin-0.3/moto_ui'
/bin/uic form1_base.ui -o ui/form1_base.h
make[1]: /bin/uic: Command not found
make[1]: *** [ui/form1_base.h] Error 127
make[1]: Leaving directory `/home/sergio/src/moto4lin-0.3/moto_ui'
make: *** [sub-moto_ui] Error 2

I'm a bit newbie and I don't understand what's the matter...
Thanks in advance
Regards

Zodar
By th way, is Moto V980 supported?

Report

lfreak

14 years ago

install the qt-devel-tools and try again (compile = make) wola and is function :)

Report

zodar2

14 years ago

Sorry, I forgot to tell you that I've already installed qt3-devel-tools... version 3.3.3-24 (05/10/2004) and libusb-devel too...

Zodar
P.S.
Perhaps... Could it be "g++" that miss? The most similiar in my machine is gcc, gcc-c++ and libgcc...

Report

12345678910
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.3
updated Mar 02 2005
added Feb 24 2005
downloads today
0
page views today 6
System Tags app software