Description:

KEmu is a graphical front-end for QEMU and KVM.

It requires at last KDE 4.2 and the appropriate bindings for Ruby (Korundum4).
Last changelog:

7 years ago

0.0.3 -> 0.0.4
* improved README
* added character encoding hint for Ruby versions >= 1.9
* added fix to prevent KEmu from crashing when an expected executable is not present

nqn1976

7 years ago

More problems: I get a crash when trying to create a new VM:

> LC_ALL=C kemu-manager
/usr/share/apps/kemu/adapters/adapter.rb:41:in ``': No such file or directory - qemu-kvm -version (Errno::ENOENT)
from /usr/share/apps/kemu/adapters/adapter.rb:41:in `block in executable'
from /usr/share/apps/kemu/adapters/adapter.rb:40:in `each'
from /usr/share/apps/kemu/adapters/adapter.rb:40:in `executable'
from /usr/share/apps/kemu/adapters/adapter.rb:60:in `printedName'
from /usr/share/apps/kemu/adapters/adapterlist.rb:80:in `block in adapterDisplayList'
from /usr/share/apps/kemu/adapters/adapterlist.rb:79:in `each'
from /usr/share/apps/kemu/adapters/adapterlist.rb:79:in `adapterDisplayList'
from /usr/share/apps/kemu/configform.rb:122:in `fillEmulatorList'
from /usr/share/apps/kemu/configform.rb:96:in `fillStaticLists'
from /usr/share/apps/kemu/configform.rb:46:in `initialize'
from /usr/share/apps/kemu/vm.rb:73:in `new'
from /usr/share/apps/kemu/vm.rb:73:in `initialize'
from /usr/share/apps/kemu/mainform.rb:119:in `new'
from /usr/share/apps/kemu/mainform.rb:119:in `add'
from /usr/share/apps/kemu/mainform.rb:94:in `block in setupActions'
from /usr/lib/ruby/site_ruby/1.9.1/Qt/qtruby4.rb:2361:in `call'
from /usr/lib/ruby/site_ruby/1.9.1/Qt/qtruby4.rb:2361:in `invoke'
from /usr/lib/ruby/site_ruby/1.9.1/KDE/korundum4.rb:60:in `qt_metacall'
from /usr/lib/ruby/site_ruby/1.9.1/KDE/korundum4.rb:60:in `method_missing'
from /usr/lib/ruby/site_ruby/1.9.1/KDE/korundum4.rb:60:in `exec'
from ./kemu:48:in `<main>'
KCrash: Application 'kemu' crashing...

Report

C

pen2

7 years ago

OK, I've just packaged and uploaded the current version from repository.
This should fix this problem (at last I hope so, because my tests suggest that indeed this issue is due to different behavior of Ruby 1.8 <-> 1.9)

Report

nqn1976

7 years ago

Works perfectly now, thanks

Report

nqn1976

7 years ago

The cmakelists file in /src/ui is wrong:

CMake Error at src/ui/cmake_install.cmake:36 (FILE):
file INSTALL cannot find
"/home/antonio/src/kemu-0.0.3/src/ui/ui_mainform.rb".
Call Stack (most recent call first):
src/cmake_install.cmake:57 (INCLUDE)
cmake_install.cmake:42 (INCLUDE)

Also, after fixing the file and compiling, trying to run it gives a syntax error:

> ruby kemu
kemu:36: invalid multibyte char (US-ASCII)
kemu:36: invalid multibyte char (US-ASCII)
kemu:36: syntax error, unexpected $end, expecting ')'
about.addAuthor(KDE.ki18n("Martin Höher"),
^

Report

C

pen2

7 years ago

Jep, see above:
The ui_*.rb files must first be generated using the Makefile in the ui directory: Simply run `make ui` there. This is because the "source" package is packaged directly from the repository, and there no generated files are stored.

To be honest, I don't like this either, so hopefully in the next release the generation of the ui/rb files can be done with cmake, too.

@wrong encoding:
Thank you for pointing this out. May I ask you what system (distribution/architecture/Ruby version) you use? For the meantime: Simply replace/remove my name from there - this should fix it for now.

Report

nqn1976

7 years ago

Thanks, that fixed it.
I'm using i686 Arch Linux, ruby 1.9.1.p376, KDE 4.3.4

Report

C

pen2

7 years ago

Glad to hear this ;)

What encoding do you use (AFAIR this is set in /etc/rc.conf via the LOCALE variable in Arch)? I guess you use something else than utf-8?

Nevertheless, I will try fix the issue in the next release (I guess Ruby provides some mechanism to force it to use a given character encoding).

Report

nqn1976

7 years ago

I found the problem: apparently with ruby 1.9 you need to specify the encoding of the script files.
Adding the line

# encoding: UTF-8

at the beginning of /usr/share/apps/kemu/kemu fixes the issue.

Report

C

pen2

7 years ago

Cool, thank you for the info :)

I've already pushed a fix to Gitorious (see http://gitorious.org/kemu/kemu) and will package a new version ASAP.

Report

dovidhalevi

7 years ago

make does nothing at all.

Have korundum4 from Debian Sid.

Report

C

pen2

7 years ago

Hi!

First of all: Sorry, I believe the included README needs some review - especially as KEmu experienced some restructuring recently.

To "build" it, do:
cd /path/to/kemu/src/ui
make ui
cd ../..
mkdir build && cd build
cmake ..
make && make install
kbuildsycoca4


Note that you will also need KDE's development packages installed, as KEmu's CMake files currently use some macros defined there.

If you do not want to install these additional packages, you can also use the self-extracting archive, as it requires no further ado. Simply run it in a terminal via
sh ./kemu-0.0.3-Linux.sh

Hope that helps ;)

Report

7 years ago

0.0.3 -> 0.0.4
* improved README
* added character encoding hint for Ruby versions >= 1.9
* added fix to prevent KEmu from crashing when an expected executable is not present

product-maker roentgen Feb 03 2013

product-maker 6 10

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.0.4
updated Dec 13 2009
added Dec 12 2009
downloads today
0
page views today 0