Banshee Lyrics Plugin
Audio
Score 71%
Description:

This is the new version of the lyrics plugin:

It downloads lyrics from
http://www.leoslyrics.com/
http://lyrc.com.ar
http://lyriky.com
http://lyricwiki.org and http://www.autolyrics.com

REQUIRED PACKAGES
mono, mono-gcms,banshee

INSTALL FROM SOURCES:
./configure
make
make install (as root)

Last changelog:

9 years ago

News about 0.7 version
* Source code completely rewritten
* Better UI
* Leos lyrics api support
* Lyrc supported again

Try it and enjoy.
Email me at christian.martellini@gmail.com for bugs report.

onny

6 years ago

hi, please upgrade this plugin, so that it works with banshee 2.1

Report

rvernucio

7 years ago

I could successfully compile the source by following these steps:

1.
# aptitude install gtk-sharp2 gtkhtml3.14 automake mono-gmcs

2.
$ ./autogen.sh

3.
$ make

4.
# make install

The plugin is correctly compiled and loaded in Banshee. But when I try to check the Lyrics, I get the following error:



"Error downloading lyric...

Click here to manually add a new lyric"

Report

MetaBerylCompiz

8 years ago

Hi, does anybody know if this plugin will work with openSUSE 11.2 KDE?

It says it depends on GNOME. Well, I can't find any KDE plugin, and Amarok doesn't seem to be working right. So, will it work? And if not, can somebody please make one?

Thanks!

Report

rvernucio

7 years ago

Use Amarok instead.

Report

mehor

8 years ago

Hi. Doesn't work with Banshee 1.5.1. Actually, works with LeosLyrics, but text is a mess. Commenting out the line with LeosLyrics, as proposed in a post, made that there's no lyrics found for any song. Ideas?

Report

rvernucio

7 years ago

Yeah, we get the following error:


"Error downloading lyric...

Click here to manually add a new lyric"

Report

Izo

8 years ago

Excellent plugin! I'm wondering if it's possible to add a feature to directly edit the lyrics obtained and save the edit at all?

/izo\

Report

eddster2009

8 years ago

I'm having a problem installing this. When I run ./configure, I get this at the end:

checking for GTKHTML_SHARP_314... configure: error: Package requirements (gtkhtml-sharp-3.14) were not met:

No package 'gtkhtml-sharp-3.14' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTKHTML_SHARP_314_CFLAGS
and GTKHTML_SHARP_314_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Can anyone help me please? I have no idea what to do :(

Report

jzraikes

8 years ago

I also have this problem.

Report

ziulfer

8 years ago

me too

Report

d0wn

8 years ago

On Ubuntu I did

sudo apt-get install libgtkhtml3.14*

and it installed all of the dependencies to fix that problem.

Report

smartbei

8 years ago

You also need the package gtk-sharp2, adding that worked for me.

Report

manu321

8 years ago

Thanks very much, excellent work! This is just the thing that's missing in Banshee!

Report

amrhassan

8 years ago

For some reason it keeps downloading lyrics from http://www.leoslyrics.com and rendering of these lyrics fails to read newlines for some reason, so it's all displayed in one ginormous line.

Why won't it just stick to wiki-lyrics?

Report

schmittzer

8 years ago

I'm having the same problem... Is there a way to change the source for the lyrics or to fix this problem?.

Thanks.

Report

smartbei

8 years ago

What you can do is download the source package and edit the file:
bansheelyricsplugin-0.7/src/Banshee.Lyrics/LyricsManager.cs

Comment out the line that addes LeoLyrics in the LyricsManager constructor:
This:
sourceList.Add (new LeosLyrics ());

Becomes:
//sourceList.Add (new LeosLyrics ());

Report

schmittzer

8 years ago

Thanks, that did the trick :).

Report

duao

8 years ago

how i install the patch from nikita, the plugin doesnt work with thath patch and i dont know how i install it :/
please post it^^

Report

C

martellc1

8 years ago

don't patch it, download the new version(0.7) instead

Report

eqisow

8 years ago

I'm running 64bit fedora, so have to compile. On Fedora 11 I get 'No package 'gconf-sharp-2.0' found'. The package isn't in yum and I'm pretty sure gconf-sharp-2.0 has been replaced with gtk-sharp2. Is there a way to fix the configure file to reflect this? I looked at it, but it was my first time and it didn't seem obvious.

Report

ChrisVS

8 years ago

Just to let you know ...
I could not get the binary package to work (on Fedora 10) but I compiled the source package. Doing this I noticed that the 'Makefile.in' was missing in the src subdirectory. I retrieved it from the source package of the 0.5 version. Compiled ... and it works !
Note for fedora users : make sure you have the development package for banshee installed on your system before you start compiling !

Report

abhi8886

8 years ago

use this
$export GTKHTML_SHARP_314_CFLAGS=/usr/lib/mono/gac/gtkhtml-sharp/3.16.0.0__35e10195dab3c99f/gtkhtml-sharp.dll
It worked for me ...
or see according you location of the dll in your system

Report

fernph

8 years ago

This version works perfectly on my Banshee 1.4.2 over Ubuntu 8.04 Hardy Heron AMD64, except that most of my Banshee interface turned to English as soon as I install it.

Any idea why?

Report

venator260

8 years ago

This extension is in the repos

sudo apt-get install banshee-extension-lyrics

Report

rossmoore

8 years ago

which repo - I'm on intrepid, but it's not in any of the standard ones.

I also get the aclocal error when I try to compile it too. Any help?

Report

9 years ago

News about 0.7 version
* Source code completely rewritten
* Better UI
* Leos lyrics api support
* Lyrc supported again

Try it and enjoy.
Email me at christian.martellini@gmail.com for bugs report.

product-maker droper03121 May 29 2012

product-maker 6 23

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
0.7
updated Jun 04 2009
added Dec 11 2008
downloads today
0
page views today 5