Qaquarelle

Graphic Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

3
5 .8
Description:

Qaquarelle is the opensource Qt4-based graphical editor, whose goal is to provide the native way of painting with emulated traditional instruments, including the full support of tablet input and OpenGL-based processing in GPU.
Last changelog:

10 years ago

v 0.0.4
Save format from v0.0.3 is depricated now.

lit-uriy

10 years ago

можно ли как-то обойтись без использования этого самого GL-видеобуфера?
У меня OpenGL не слишком древний:
Common::OpenGLHelper: GL-version is 1.5.3.

Но ни на стационарной машине ни на ноутбуке программа не работает из-за отсутствия GL_EXT_framebuffer_object.

Report

dovidhalevi

11 years ago

I am using, hopefully temporarily, a old matrox g200 card. Yes, an old clunker. The program starts up disabled sayin the opengl capabilities of this junk are not good enough, useless to continue.

Can we do a little better than that :-) ?

Report

C

DrMoriarty

11 years ago

Qaquarelle works on OpenGL 2.0 and 1.3.
Show your log ("/home/user/.qaquarelle/qaquarelle-client.log) please

Report

C

DrMoriarty

11 years ago

Qaquarelle works on OpenGL 2.0 and 1.3.
Show your log ("/home/user/.qaquarelle/qaquarelle-client.log) please

Report

dovidhalevi

11 years ago

Here is the relevant part of the log:
Common::OpenGLHelper: Initializing...
Common::OpenGLHelper: GL-version is 1.2 Mesa 7.4.4.
Common::OpenGLHelper: GL-vendor is VA Linux Systems Inc..
Common::OpenGLHelper: GL-renderer is Mesa DRI G200 20071017 AGP 1x x86/MMX/SSE.
Common::OpenGLHelper: Attempting to init GLEW.
Common::OpenGLHelper: Successfully inited GLEW.
Common::OpenGLHelper: Checking for important extensions...
Common::OpenGLHelper: -- GL_EXT_framebuffer_object...
Common::OpenGLHelper: Extension GL_EXT_framebuffer_object not found
Common::OpenGLHelper: GL_EXT_framebuffer_object extension is not supported. Failed to proceed.

I guess I need to wait for Debian Sid to catch up, at least to 1.3.

Report

pipaceliny

11 years ago

I tried to paint something with Qaquarelle and I found missing:
1.Color picker
2.Defining colors like this #0000FF
3.Redo/Undo function
4.Saving qaquarelle preferences and panels position in ~/.qaquarelle
5.Last used colors panel?
6.Missing qaquarelle.desktop in /usr/share/applications and qaquarelle icon in /usr/share/pixmaps in debian package
7.Crash when choosing for example Oil before setting painting options with New option.

Waiting for a new release.

Report

tsujan

11 years ago

I like this nifty application very much. It's easily compiled against Qt 4.5.1 and works well under Ubuntu. I encountered just one crash. Please keep on developing.

Report

lit-uriy

11 years ago

скачал с sf.net установщик qaquarelle_setup-0.0.2.exe.
Библиотеки в нём релизные, а приложение собрано в отладочном режие. Требует QtCored4.dll и т.д.

Report

C

DrMoriarty

11 years ago

Спасибо за сообщение. Перезалил исправленный инсталятор.

Report

10 years ago

v 0.0.4
Save format from v0.0.3 is depricated now.

12345678910
1
product-maker ZLv Jan 23 2011 9 excellent
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
pipaceliny
Jul 19 2009
koral
Jul 17 2009
castedflake
Jul 17 2009
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.0.4
updated Feb 09 2010
added Apr 17 2009
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0
System Tags app software