Description:

Limiter, compressor, reverberation, stereo equalizer and auto volume effects for Pulseaudio applications

sombragris

20 days ago

pulseeffects fails to run. This is the console output:

19:26:39.561 - PulseEffects - INFO - pulseaudio context started
19:26:39.562 - PulseEffects - INFO - connected to server: unix:/tmp/xdg-runtime-eduardo/pulse/native
19:26:39.562 - PulseEffects - INFO - server protocol version: 32
19:26:39.562 - PulseEffects - INFO - pulseaudio version: 10.0-rebootstrapped
19:26:39.562 - PulseEffects - INFO - default pulseaudio source: alsa_input.pci-0000_00_1b.0.analog-stereo
19:26:39.562 - PulseEffects - INFO - default pulseaudio sink: alsa_output.pci-0000_00_1b.0.analog-stereo
19:26:39.562 - PulseEffects - INFO - default pulseaudio sink audio format: s16le
19:26:39.562 - PulseEffects - INFO - default pulseaudio sink sampling rate: 44100 Hz. We will use the same rate.
19:26:39.563 - PulseEffects - INFO - default pulseaudio source audio format: s16le
19:26:39.563 - PulseEffects - INFO - default pulseaudio source sampling rate: 44100 Hz. We will use the same rate.
19:26:39.563 - PulseEffects - INFO - loading Pulseeffects applications sink...
19:26:39.563 - PulseEffects - INFO - Pulseeffects apps sink was successfully loaded
19:26:39.563 - PulseEffects - INFO - Pulseeffects apps sink index:1
19:26:39.563 - PulseEffects - INFO - Pulseeffects apps sink monitor name: PulseEffects_apps.monitor
19:26:39.563 - PulseEffects - INFO - loading Pulseeffects microphone output sink...
19:26:39.564 - PulseEffects - INFO - Pulseeffects mic sink was successfully loaded
19:26:39.564 - PulseEffects - INFO - Pulseeffects mic sink index:2
19:26:39.564 - PulseEffects - INFO - Pulseeffects mic sink monitor name: PulseEffects_mic.monitor
Traceback (most recent call last):
File "/usr/bin/pulseeffects", line 4, in
__import__('pkg_resources').run_script('PulseEffects==2.0.2', 'pulseeffects')
File "/usr/lib64/python3.6/site-packages/pkg_resources/__init__.py", line 743, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/lib64/python3.6/site-packages/pkg_resources/__init__.py", line 1498, in run_script
exec(code, namespace, namespace)
File "/usr/lib64/python3.6/site-packages/PulseEffects-2.0.2-py3.6.egg/EGG-INFO/scripts/pulseeffects", line 6, in
a = Application()
File "/usr/lib64/python3.6/site-packages/PulseEffects-2.0.2-py3.6.egg/PulseEffects/application.py", line 62, in __init__
self.sie = SinkInputEffects(self.pm.default_sink_rate)
File "/usr/lib64/python3.6/site-packages/PulseEffects-2.0.2-py3.6.egg/PulseEffects/sink_input_effects.py", line 65, in __init__
self.pipeline = self.build_pipeline()
File "/usr/lib64/python3.6/site-packages/PulseEffects-2.0.2-py3.6.egg/PulseEffects/sink_input_effects.py", line 176, in build_pipeline
self.output_limiter.set_property('input-gain', 0)
AttributeError: 'NoneType' object has no attribute 'set_property'

Report

wwmm

20 days ago

Hi, the lines:

self.output_limiter.set_property('input-gain', 0)
AttributeError: 'NoneType' object has no attribute 'set_property'

are telling gstreamer is not finding the swh-plugins.

Report

sombragris

20 days ago

thank you! I was able to run the program. However, there is a problem. Whenever a sound is played, the program adds some white noise. Do you know if this is an expected behavior? Thanks!!

Report

wwmm

20 days ago

Hi, this is strange. There shouldn't be a white noise

Report

cenobite1

3 months ago

error: Could not find suitable distribution for Requirement.parse('swh-plugins')

Report

wwmm

3 months ago

Hi,

Probably the swh-plugins from ladspa are not installed or its package has a different name on your distribution. Anyway the setuptools script currently in PulseEffects source does not install all the files. It takes care only of the python modules. I will try to improve it

Report

wwmm

3 months ago

I did some reasearch and it seams that setuptools is not meant to install files that are not directly used by the program's python module. This should be done by the distribution packager when creating the installation package. which distro are you using? The ideal solution would be to have a package for it

Report

cenobite1

3 months ago

I use kubuntu 17.04 and the swh-plugins are installed, but it still cant find them

Report

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
2.1.0
updated Jul 17 2017
added Apr 16 2017
downloads today
0
page views today 18