Plasma Feed

Plasma 4 Widgets

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

3
Score 62.5%
Description:

A plasmoid to read your RSS and Atom feeds.

Features:
- Display your feeds on the desktop
- Or access them through the panel icon
Last changelog:

8 years ago

New options:
- limit entries per feed
- choose newest/oldest first ordering

Confirmed to work on KDE 4.6

janet

6 years ago

I had expected that the feeds and entries stay in the widget even when I clicked on them to read them in the browser. But when all entries of a feed are read the feed vanishes. IMHO that shouldn't happen. When I choose to display 10 entries I always want to see 10 entries, the oldest should vanish when new entries are added but as long as that does not happen the read entries should stay, so I can re-read them when I want to!

Report

C

matthiasFauconneau

6 years ago

Hi,
I'm not using this plasmoid anymore since I have my own desktop shell with an integrated feed reader.
I guess the official feed reader should be better by now anyway.
Actually, I'm amazed it still compiles.
Otherwise you could replace
if( !globalConfig().group(feedURL).hasKey(date) ) {
with
if( true ) {
to prevent removal of read items.

Report

janet

6 years ago

I clicked on that mail symbol in the right upper corner of a feed (alas there is no tooltip) and now the feed has vanished. But it is still listed in the configuration. How do I get it back?

Report

janet

6 years ago

Yes - this is exactly what I was looking for, concerning both look and behaviour! I use it the same way as Thule does and therefore have the same requirements.

But why do I have to hold the CTRL-key to make the widget bigger? Shouldn't this "just work" with the size button as other widgets do?

Report

cbg

7 years ago

As mentioned in the last thread, your applet seems to enforce a particular landscape aspect ratio.

This doesn't suit me, as I want it to have portrait orientation and to be much narrower than it is now.

For this to work, you'll need to change the code to wrap any overlapping text around to the next line.

This has already been done in the default 'News' applet, so you can probably just copy the code from there.

Are you happy to implement those two features: unrestricted widget size/aspect and text wrap-around?

Report

C

matthiasFauconneau

7 years ago

You can simply edit the source:
- view->setMinimumWidth(320);
+ view->setMinimumWidth(16);

I'm using a Plasma::TreeView to display the feeds.
Plasma API is not as rich as Qt's so I don't think I can do anything to help with the wrapping issue,

Report

baconskipper

8 years ago

uh - i'm embarrassed - but how can i install this plasmoid?

Report

C

matthiasFauconneau

8 years ago

If you're using a binary distro, you need to install development packages for KDE.
Then you can checkout latest source using git :

git clone git://gitorious.org/plasma-feed/plasma-feed.git

To build and install, run:
cd plasma-feed
mkdir build
cd build
cmake ..
sudo make install
kbuildsycoca4

Once it appears in the list of your available plasmoids, you can add it on your desktop or in your system tray.

Report

baconskipper

8 years ago

Thanks! Looks very good!

Only one more question: i tried to increase the gadget, but it seems to force a constant aspect.

i want to display many different sources, so it should have a small width, but a great high. is there a trick to change the aspect?

Report

baconskipper

8 years ago

Oh - sorry! i get it! i simply had to press the ctrl-button!

Report

Thule

9 years ago

Nice Plasmoid =)

Any chance that you create some options to change the color of the font and open the feed with the default-browser (e.g. Firefox)?

Report

C

matthiasFauconneau

9 years ago

I'm glad you like it.

I could provide the option to change font color, but I'd like to know why you need a specific color ?

I made this plasmoid to be able to read feeds in a full-featured browser (unlike Akregator viewer), so I understand why you would need Firefox.

However, you may have noticed that this plasmoid is designed to remote control a browser in a single tab (using Akregator, I was opening all articles in new tabs which lead to heavy memory usage).

Unfortunately, Firefox doesn't provide a D-BUS interface to remote control it.
You would have to first write a Firefox extension to provide the interface.

But if you want, I can simply open articles as new tabs in the default browser.

Report

Thule

9 years ago

Hehe, maybe I use the plasmoid in a different way than supposed?

I like your widget because it shows all the headlines of an rss-source at once, so I have not to scroll. When I like a headline, I want to open it with my favorite browser by a single >>click<<.

I need a different color of the font because I use the oxyglass-theme which is pretty transparent so I cannot read a black font on dark wallpaper. A different font-size and design would also be nice but is not necessary.


PS: I have to fetch the feeds manually after boot. Is it a bug or so intended?

Report

C

matthiasFauconneau

9 years ago

I updated the source with plasma theming (i.e font color and size) and default browser support.

Report

Thule

9 years ago

Thank you for updating!

I uploaded a screenshot so you can see how I use it and why I need a different font color:
http://img682.imageshack.us/img682/3718/screenshot1nd.jpg
http://img691.imageshack.us/img691/4293/screenshot2pq.jpg

Firefox works well but how can I change the color? I cannot find any options.

I connect via W-Lan to the internet, do you have any idea how to fetch after boot automatically?

Report

C

matthiasFauconneau

9 years ago

I had changed the plasmoid to use the default font, but color and font are not the same settings.
I tested it with a dark theme and it works now.

It's nice to see it works correctly on the desktop. Could you do a screenshot of the plasmoid with the new color settings so I can add it here.

I also added support for Solid, so it should fetch feeds when Solid detect a connection, but I can't test it.

Report

Thule

9 years ago

Now it works fine =)

Here is an updated screenshot:
http://img707.imageshack.us/img707/3007/screenshot3r.jpg

Report

C

matthiasFauconneau

9 years ago

It's interesting to see different usages of this plasmoid.

I wanted a panel popup showing only new messages but it doesn't seem to be your usecase.
So if I understand correctly, you're using it directly on the desktop ?
I'd like to know what features made you choose this plasmoid ?

I changed the URL handling to open in the default browser.
I'll either provide a font color and size option or look into theming support.
I'll release the new version when it's done.

What do you mean by different design ? The current design is simply a Plasma::TreeView in an ExtenderItem so it should be themed correctly.

PS: It should fetch on startup.
If you're on WLAN, maybe the network didn't had enough time to setup.
If you're showing feeds directly on the desktop, they may not get initialized properly. Unlike popups which are created when the fetch is completed.

Report

lestek

9 years ago

After "make install" i get following errors:

lestek@laptop:~/Dokumenty/instalki/118140-plasma-feed/build$ sudo make install
Generating moc_plasma-feed.cpp
[100%] Built target plasma_applet_feed_automoc
[100%] Building CXX object CMakeFiles/plasma_applet_feed.dir/plasma_applet_feed_automoc.o
[100%] Building CXX object CMakeFiles/plasma_applet_feed.dir/plasma-feed.o
/home/lestek/Dokumenty/instalki/118140-plasma-feed/plasma-feed.cpp: In member function ‘void PlasmaFeed::updateIcon()’:
/home/lestek/Dokumenty/instalki/118140-plasma-feed/plasma-feed.cpp:149: error: ‘fromTheme’ is not a member of ‘QIcon’
/home/lestek/Dokumenty/instalki/118140-plasma-feed/plasma-feed.cpp:151: error: ‘fromTheme’ is not a member of ‘QIcon’
make[2]: *** [CMakeFiles/plasma_applet_feed.dir/plasma-feed.o] Error 1
make[1]: *** [CMakeFiles/plasma_applet_feed.dir/all] Error 2
make: *** [all] Error 2

(Kubuntu Karmic 9.10 x64, KDE 4.3.4)

Report

C

matthiasFauconneau

9 years ago

It's because QIcon::fromTheme is Qt 4.6 only.
I fixed this so it should work for Qt 4.5 / KDE 4.3.
I also improved stability.

Report

srog

9 years ago

Kubuntu 9.10 / KDE 4.3

Building fine with the new source.
Thank you !

Report

srog

9 years ago

It seems to be a KDE 4.4 (?) plasmoid.

Building fine with the Kubuntu Lucid (alpha1) / KDE 4.4 (beta2).

Though the plasma is crashing when using it - maybe with the KDE 4.4 RC1.

Report

8 years ago

New options:
- limit entries per feed
- choose newest/oldest first ordering

Confirmed to work on KDE 4.6

12345678910
13
product-maker janet Oct 07 2013 9 excellent
product-maker kazuspara Mar 08 2012 3 bad
product-maker vitoubien Mar 18 2011 9 excellent
product-maker unikum111 Mar 18 2011 9 excellent
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs ocs-url or ocs-store to install things
Pling
Details
license
version
1.0
updated Mar 18 2011
added Jan 06 2010
downloads 24h
0
page views 24h 2