Description:

SysTach for KDE/Plasma

KDE4.x hybrid Plasma (native/QML) rewrite of the SysTach SuperKaramba widget:

http://kde-look.org/content/show.php/?content=72809

Videos:

Overview: https://youtu.be/eLq7ZUDpTFQ
Demo #1: https://youtu.be/oNwBRE1MG1Q
Demo #2: https://youtu.be/Ebp64_89S5Q

Features:

* Connects to ANY KDE Engine and Datasource
* Radial Gauges
* Digital Gauges
* Automatic ranging
* SVG-Skinnable Widgets

Coming soon:
*Ability to display output of command (useful for GPU temps, SMART data, etc.)
*More gauges! Text, digital, and graphs

The Source link below is a ZIP file of the entire Master branch.

The Master branch is also linked at the top of the page, under Version Control.
Last changelog:

1 year ago

0.2 - Release

  • Fixed auto-adjust feature

  • Fixed bug where values were not saved

  • 0.1 - First Release

    baltolkien

    1 year ago

    It works on Plasma 5?
    Great work

    Report

    mjkersey

    1 year ago

    It does! I'm not sure if it will work without kde5libs-dev and deps installed, but that's required to build anyway.

    Report

    buschmann23

    2 years ago

    Packages for openSUSE can be found here:

    http://software.opensuse.org/package/plasmoid-systach

    Report

    mjkersey

    2 years ago

    Thank you for packaging! As I do not run OpenSUSE, I don't have access to packaging tools. I've considered using an OpenBuilds service, but haven't had the time to set it all up.

    Report

    13finn

    3 years ago

    Thank you very much.

    Report

    mjkersey

    3 years ago

    Not a problem at all! The initial "release" was for a few friends that wanted only the Deb for Kubuntu x64 without the hassle of compiling and installing dependencies. It was uploaded before going to sleep, and I didn't feel like mucking around with creating github repo just yet.

    Let me know if you have any build problems, as I have only tested the build on 3 machines of similar distributions and arch.

    From what I can tell, kdelibs5-dev is the only "weird" package required to build, but if you've built other plasmoids from source, you probably have this installed.

    Report

    13finn

    3 years ago

    Binsry package formats are of no use to a lot of us. Source code is necessary and it would be appreciated if you would release a platform agnostic package like a tarball.

    Report

    mjkersey

    3 years ago

    Yes, it's there now, I created a Git Repository for this. Sorry, it was uploaded last night as a Deb package for a few folks that needed only the binary.

    The Source link is a Zip download from GitHub. Scripts to build, install, uninstall the project are included.

    Report

    ksolsim

    3 years ago

    where is source code?

    Report

    mjkersey

    3 years ago

    See my comment below, a Git repo has been created, and links to it and the Source are now included in the project.

    Report

    ksolsim

    3 years ago

    thanks..

    Report

    1 year ago

    0.2 - Release

  • Fixed auto-adjust feature

  • Fixed bug where values were not saved

  • 0.1 - First Release

    File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install
    Score 68%
    68.00 Likes
    32 Dislikes
    Details
    version
    0.2
    updated Mar 17 2016
    added Jan 27 2014
    downloads
    page views 1404