GX Mail Notify

Plasma 4 Widgets

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on git.opendesktop.org

20
Score 84%
Description:

Plasmoid for checking unreaded e-mails.

Requirements
============

- KDE 4.2

Features
========

- More e-mail accounts.
- Support protocols POP3 and IMAP4.
- Support TSL/SSL-encryption (verification of certificates).
- Information interface with account details.
- Variable size of icon or fixed size like tray icon.
- Launch e-mail clients.

TODO
====

- Sound notify.
- Popup notify.
- Localization.
- Synchronize with KMail.

Last changelog:

8 years ago

0.4.4
- Fixed compilation problem with gcc 4.5.

0.4.3
- One mail account can save more certificates (GMail problem).
- Note: You must accept all of certificates again (for encrypted connections).

0.4.2
- Fixed problem with convert certificates to PEM format (changed to DER) = fix error "asn1 encoding routines:ASN1_get_object:too long".
- Note: You must accept all of certificates again (for encrypted connections).

0.4.1
- Fixed problem with count of messages on IMAP4 accounts.

0.4
- Fixed problem with SSL3 connections.
- Fixed problem with untrusted certificates.
- Added confirm dialog for verification of certificates.
- Improved: countdown starts after end of previous check.
- Improved: disabled "check now" button until check is in progress.

0.3
- New information interface designed like kickoff (in panel click on icon).
- Click on items launch e-mail clients.
- Added time to next check and check now feature.

0.2
- Fixed error icon that no disappear after succesful check and no messages founded.
- Fixed size of icon in toolbar without "growing widget".
- Fixed font-place and font-size (minimum size is 12).
- Fixed load Port number setting (checked SSL setting has rewrite port).
- Added new config tab Appearance (Icon: fixed size like tray icon, Font: setting font family - apply only on message-counter).

0.1
- Initial release.

SirDodger

6 years ago

Nice Application, but please implement both SSL AND TLS!

An import from the akonadi-ressource are fine :)

Report

kneissel

6 years ago

Hello, i'm not really good with coding but i find a workaroud here http://pastebin.com/Xd0nKuex

In the file mail_checker.cpp
I replace the line :

actual_action(CLOSE_CONNECTION), certificate_details_dialog(0), time_to_check(0), check_messages(-1), check_error(false)

By this one :

actual_action(CLOSE_CONNECTION), certificate_details_dialog(0), time_to_check(0), check_messages(-1)

And it works fine.
As i say i'm not good with coding so it maybe break some kind of stuff but for now i don't seen anything strange here.

Report

lonestaritaly

6 years ago

hey thanks!
it did compile now, I'm going to see if it's all ok

you're still better than me at such things, for sure

Report

lonestaritaly

6 years ago

Does not compile on KDE/QT 4.8.0:

[ 38%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/list_account_item.o
[ 44%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/account.o
[ 50%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/mail_checker.o
/usr/src/gx_mail_notify-0.4.4_modified/mail_checker.cpp: In constructor ‘MailChecker::MailChecker(Account*)’:
/usr/src/gx_mail_notify-0.4.4_modified/mail_checker.cpp:29:121: error: call of overloaded ‘QString(bool)’ is ambiguous
/usr/src/gx_mail_notify-0.4.4_modified/mail_checker.cpp:29:121: note: candidates are:
/usr/lib64/qt/include/QtCore/qstring.h:421:43: note: QString::QString(const QByteArray&)
/usr/lib64/qt/include/QtCore/qstring.h:419:43: note: QString::QString(const char*)
/usr/lib64/qt/include/QtCore/qstring.h:725:8: note: QString::QString(const QString&)
/usr/lib64/qt/include/QtCore/qstring.h:89:5: note: QString::QString(QChar)
/usr/lib64/qt/include/QtCore/qstring.h:88:14: note: QString::QString(const QChar*)
make[2]: *** [CMakeFiles/plasma_applet_gx_mail_notify.dir/mail_checker.o] Errore 1
make[1]: *** [CMakeFiles/plasma_applet_gx_mail_notify.dir/all] Errore 2
make: *** [all] Errore 2

any fix planned or it's no longer developed?

Report

kneissel

6 years ago

See my message below (i'm new with posting on kde-look and i made a mistake when trying to answer to your post)

Report

jenzuslongus

6 years ago

If I try to authenticate against my mail-server with a password that contains special characters like '(' or ')' the authentication will fail.
This could be a bug in my mail-configuration but the password works with all other mail-applications flawlessly.

Report

jenzuslongus

6 years ago

I found out that the password must be quoted with double quotes in mailchecker.cpp in the function MailChecker::writeData(Action action):

case VERIFY_USER:
if (account->protocol == "POP3") {
data.append("USER ");
data.append(account->username.toAscii());
}
else if (account->protocol == "IMAP4") {
data.append("001 LOGIN ");
data.append(account->username.toAscii());
data.append(" \"");
data.append(account->password.toAscii());
data.append("\"");
}
break;

The changed lines are tho ones containing the data.append("\"") statements.

Report

molecule-eye

8 years ago

Would be nice if the background of the popup was the same as the background for the battery widget, clock widget, network management widget, etc. On my oxygen theme it's just a white background.

Report

geertvandeweyer

7 years ago

I second this ! Options to format the background / font color to match other widgets would make this widget perfect.

Besides that: excellent work !

Report

molecule-eye

8 years ago

Would be nice if more information was shown when new mail arrived such as the title and sender of the received msgs (and, if I'm allowed to really hope, also the first x characters of the message!)

Report

atilius

8 years ago

Hello, are you going to improve your application to be able by clicking on the header of mail open the mail and read it? Thx Martin

Report

linuxfever

8 years ago

Thanks for this nice plasmoid. I was wondering whether it would be possible to change the tray icon.

In particular, is there a way to choose the tray icon? Or, can it be done only be replacing the *.svg files and recompiling?

The problem is that I would like to have a consistent look with the icon theme (different to Oxygen). Is it possible that the tray icon changes according to the icon theme?

Thanks.

Report

C

Goffix

8 years ago

Hi,

you can try replace SVG in source code for now.

I add this feature in future, but now there are important things.

Report

HavinItAgain

8 years ago

Hi,

Great work on this plasmoid, there is nothing else like it. But:

I am getting the certificate accept dialog on every login now. It didn't do this on first install (built for kde-4.5.1) but I did "something" and soon it started asking every time.

The server is dovecot-2.2 on a machine on my LAN, with the default self-signed certificate. If it matters, I am accessing the server via a WAN URL that resolves to the local machine via my local DNS server (don't think this should matter as it didn't before).

Have tried removing the plasmoid and re-creating it, account and all, but this doesn't seem to help. Where is the cert stored normally?

Report

C

Goffix

8 years ago

Hi,

i will add checkbox for "skip cert check", because there are too much problems with several servers.

Update soon.

Report

wolfshift

8 years ago

When I run the command "cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`" as instructed in the README, I get the following error:
"CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:98 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/ian/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
Call Stack (most recent call first):
CMakeLists.txt:7 (find_package)"

On OpenSUSE 11.3, with KDE 4.4.4.

Any suggestions on how to update whatever it is I need to update?

Thanks

Report

vgevorgyan

8 years ago

Hi

Had the same problem.
Done `sudo aptitude install kdelibs5-dev` and the cmake worked.

But after make have this error:

../gx_mail_notify-0.4.4/mail_checker.cpp: In constructor ‘MailChecker::MailChecker(Account*)’:
../gx_mail_notify-0.4.4/mail_checker.cpp:22: error: call of overloaded ‘QString(bool)’ is ambiguous
/usr/include/qt4/QtCore/qstring.h:428: note: candidates are: QString::QString(const QByteArray&)
/usr/include/qt4/QtCore/qstring.h:426: note: QString::QString(const char*)
/usr/include/qt4/QtCore/qstring.h:727: note: QString::QString(const QString&)
/usr/include/qt4/QtCore/qstring.h:106: note: QString::QString(QChar)
/usr/include/qt4/QtCore/qstring.h:105: note: QString::QString(const QChar*)
make[2]: *** [CMakeFiles/plasma_applet_gx_mail_notify.dir/mail_checker.o] Error 1
make[1]: *** [CMakeFiles/plasma_applet_gx_mail_notify.dir/all] Error 2
make: *** [all] Error 2


Any suggestion?

Report

progdan

8 years ago

This patch should simply fix it:

http://pastebin.com/2CLYkLqE

Report

Murz

8 years ago

You have posted wrong patch! It do the diff contrary, you must remove the string with "+" and add with "-" for apply.

Applying this patch by hands (contrary) fixes compilation error for me on Kubuntu Maverick! Thank's!

Please fix the patch or apply it to plasmoid core!

Report

progdan

8 years ago

Upps, you are right...sorry for that. Here's the fixed patch:

http://pastebin.com/mNAQaNku

Report

SirDodger

8 years ago

I'v got these compiling errors:
[ 0%] Built target plasma_applet_gx_mail_notify_automoc
[ 5%] [ 11%] Generating ui_appearance_dialog.h
Generating ui_certificate_details_dialog.h
'checkBox' isn't a valid widget
'verticalLayoutWidget' isn't a valid widget
'groupBox_2' isn't a valid widget
[ 17%] [ 23%] Generating ui_config_dialog.h
Generating ui_account_dialog.h
'groupBox_3' isn't a valid widget
Scanning dependencies of target plasma_applet_gx_mail_notify
[ 29%] [ 35%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/plasma_applet_gx_mail_notify_automoc.o
Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/plasma-gx_mail_notify.o
[ 41%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/list_account_item.o
[ 47%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/account.o
[ 52%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/mail_checker.o
[ 58%] Building CXX object CMakeFiles/plasma_applet_gx_mail_notify.dir/appearance_dialog.o
/var/tmp/portage/kde-misc/gx-mail-notify-0.4.4/work/gx_mail_notify-0.4.4/mail_checker.cpp: In constructor »MailChecker::MailChecker(Account*)«:
/var/tmp/portage/kde-misc/gx-mail-notify-0.4.4/work/gx_mail_notify-0.4.4/mail_checker.cpp:22: Fehler: Aufruf des überladenen »QString(bool)« ist mehrdeutig
/usr/include/qt4/QtCore/qstring.h:428: Anmerkung: Kandidaten sind: QString::QString(const QByteArray&)
/usr/include/qt4/QtCore/qstring.h:426: Anmerkung: QString::QString(const char*)
/usr/include/qt4/QtCore/qstring.h:727: Anmerkung: QString::QString(const QString&)
/usr/include/qt4/QtCore/qstring.h:106: Anmerkung: QString::QString(QChar)
/usr/include/qt4/QtCore/qstring.h:105: Anmerkung: QString::QString(const QChar*)
make[2]: *** [CMakeFiles/plasma_applet_gx_mail_notify.dir/mail_checker.o] Fehler 1
make[2]: *** Warte auf noch nicht beendete Prozesse...
make[1]: *** [CMakeFiles/plasma_applet_gx_mail_notify.dir/all] Fehler 2
make: *** [all] Fehler 2
* ERROR: kde-misc/gx-mail-notify-0.4.4 failed:
* Make failed!


I used currently Qt4.7 and an pre-KDE4.6 version (direcly from git)

greetings from Hamburg,
B.

Report

pierat

8 years ago

I get the same error here on KUbuntu Lucid.

Report

DigitalStorm

8 years ago

hi,

first of all thanx for a good work.

I would like to have some new features:

1. the possibility to specify an IMAP folder to check, not just INBOX only.

2. the possibilty to check all folders in my IMAP account.

These two feature could be sumarized into one, more complicated: the possibility to select (any or all) folders to check in IMAP account.

Report

verona0000

8 years ago

Hy. I uninstalled the plasmoid, and installed the old 0.4.2 from source. It works flawlessly with the gmail too. But 4.3 and 4.4 are not. (If anybody has got problem like me, the 4.2 will solve the problem.)

Report

verona0000

8 years ago

I forgot this. I want to install an older version of this plasmoid. How can I delete all of the parts, files of the gx mail, include the configs?

Report

8 years ago

0.4.4
- Fixed compilation problem with gcc 4.5.

0.4.3
- One mail account can save more certificates (GMail problem).
- Note: You must accept all of certificates again (for encrypted connections).

0.4.2
- Fixed problem with convert certificates to PEM format (changed to DER) = fix error "asn1 encoding routines:ASN1_get_object:too long".
- Note: You must accept all of certificates again (for encrypted connections).

0.4.1
- Fixed problem with count of messages on IMAP4 accounts.

0.4
- Fixed problem with SSL3 connections.
- Fixed problem with untrusted certificates.
- Added confirm dialog for verification of certificates.
- Improved: countdown starts after end of previous check.
- Improved: disabled "check now" button until check is in progress.

0.3
- New information interface designed like kickoff (in panel click on icon).
- Click on items launch e-mail clients.
- Added time to next check and check now feature.

0.2
- Fixed error icon that no disappear after succesful check and no messages founded.
- Fixed size of icon in toolbar without "growing widget".
- Fixed font-place and font-size (minimum size is 12).
- Fixed load Port number setting (checked SSL setting has rewrite port).
- Added new config tab Appearance (Icon: fixed size like tray icon, Font: setting font family - apply only on message-counter).

0.1
- Initial release.

File (click to download) Version Description Packagetype Architecture Downloads Date Filesize DL OCS-Install
Pling
Details
license
version
0.4.4
updated May 06 2010
added Feb 18 2009
downloads today
0
page views today 2