Image 01
profile-image

F1ash

Flash Shadow
kde-plasma-mail-checker

Plasma 4 Widgets 123 comments

by F1ash
Score 75.1%
Apr 06 2014
You are very persistent ;) . Try the new version. - Dec 30 2011
Thanks for new useful command. It will be added soon.

I`m use native class (PyKDE4.KNotification) in plasmoid and notification appears in the usual place. May be KDE 4.x works not quite correct. - Dec 29 2011
Plasmoid can be installed in the panel. I do it by simply double-click instead of dragging. It looks like the first picture in the bottom right. - Dec 18 2011
MailChecker not designed to track the number of unread messages, but only for new ones. Over time I will add a display number of unread messages for IMAP4 (and POP3, if possible). - Dec 17 2011
This is what happens when you run more than one instance of a plasmoid, and then one of them was removed . Please, install one copy of the plasmoid. - Jul 25 2011
Which application requires opening KWallet - plasmaMail–°hecker or akonadi?
I think you need to increase the timeout settings KWallet to close automatically in case of Wallet its non-use. - Jul 18 2011
The KWallet needed in any case, even with a blank password. EXAMPLES section contains the possible commands to invoke the mail program from KDE-notification. Akonadi accounts do not store passwords in KWallet, but KWallet required for the operation of the plasmoid. - Jul 09 2011
Akonadi has its own tasks and can work independently and without Nepomuk. - Jul 09 2011
Now you can not use the plasmaMailChecker without KDEWallet, because it keeps the mailbox password in encrypted form. Ways to store passwords in clear text or secure password storage capabilities without KDEWallet are not implemented, because there was not need for it. - Jul 09 2011
You need to install kdebase-workspace-python-applet (Fedora package name) may be? - Jul 07 2011
To get started, try to enable the "Show error messages" in Settings. It must report about the incorrect Akonadi accounts.
You can try to edit your account and find a resource for akonadi account again. Because when you add new objects to Akonadi, the numbers of their resources are subject to change. Therefore MailChecker not notified of the desired object Akonadi, although the mailbox akonadi working properly. - Jun 26 2011
To get started, try to enable the "Show error messages" in Settings. It must report about the incorrect Akonadi accounts.
You can try to edit your account and find a resource for akonadi account again. Because when you add new objects to Akonadi, the numbers of their resources are subject to change. Therefore MailChecker not notified of the desired object Akonadi, although the mailbox akonadi working properly. - Jun 26 2011
Thank you for the use and proposition. - May 29 2011
It`s false. My account in fastmail works.
See for : http://www.fastmail.fm/help/remote_email_access_server_names_and_ports.html

For detailed information try enable the "Show error messages". - May 11 2011
* or enable 'use SSL'. - Apr 09 2011
It may be necessary on site mailbox to disable the settings "use TLS" or "STARTTLS", or "use SSL". - Apr 09 2011
It may be necessary on site mailbox to disable the settings "use TLS" or "STARTTLS", or "use SSL". - Apr 09 2011
LightMight

Network 8 comments

by F1ash
Score 70.0%
Jun 22 2011
Use "Save last shared structure" in ServerSettings for restore last shared structure at restart of application.
For permanent storage of structures and load them, use the "Save" & "Load" buttons. - Nov 08 2011
I find it difficult to answer at once. See errors in the ~/.xsession-errors - Nov 08 2011
Right now LightMight is developed as cross-platform application and you can download new versions directly from github http://github.com/F1ash/LightMight.
Unfortunately i don't have enough time to package LightMight for other Linux distributions.
If you build deb-package by yourself, please send me the link. - Nov 08 2011
This program is made as a standalone server that is not bound to the IM-messendgers. It can serve several clients at once (how powerful your computer or wide channel). Tree Shares transferred to the client side as a single object, so remote users can choose what they need, and get a selection from the server without prompting. However, the client can not have other resources available on the server side. - Jun 18 2011
plasmaCpuFreqUtility

Plasma 4 Widgets 66 comments

by F1ash
Score 78.4%
Mar 12 2012
Unfortunately, I can not test on Arch. Then for Arch needs to rewrite some parts of the plasmoid. - Oct 10 2011
Ok. Icons do not have a border.
When I find the icons with larger size, then upload the final version. - Sep 15 2011
Try version (g). - Sep 14 2011
I do not understand correctly the data from the files. Plasmoid have to adjust again. - Sep 14 2011
I`ll try find lager icons.
Cores (1-4) are not represented in your system.
See for:
/sys/devices/system/cpu/present
0-5 -- in your file?
and
/sys/devices/system/cpu/possible
0-5 -- ?
If this really, then your cores disabled in BIOS, because system can`t define them. Therefore there is not exist a files for programly management. - Sep 14 2011
Hmmm... It`s strange bug. I make some fixes. Try versin (f). - Sep 12 2011
Sorry, I hurried. Try version (e). - Sep 09 2011
Try new version (d).
- Sep 09 2011
Try run 1.4.1.b-version in plasmoidviewer.
If plasmoid don`t work, then you need to add debug output to result. - Sep 08 2011
http://paste.ubuntu.com/680526
http://paste.ubuntu.com/680527
(sorry, fpaste.org periodically refuses)

Load new source (1.4.1) and change CMakeLists and metadata.desktop

Icons in plasmoid must absent, but let result. - Sep 02 2011
If you sure that specified paths in last CMakeLists is correct , then I try to make ARCH-correct version of plasmoid. - Sep 02 2011
Try to sure that a code changed in path:
/usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/code/main.py

now in line 98-99 :
procData['online'] = {}
for i in present : procData['online'][int(i)] = readCpuData(str(i), 'online')

If code is changed, but a bug is stay, then I will make the debug-version for you.
- Sep 02 2011
Try this :
http://fpaste.org/at8r/

If you manually moved files to specified directories, then plasmoid works? You are have the successfull result already? - Aug 31 2011
I`m fixed issue. Try update the source. - Aug 31 2011
How much you have active core of processor? - Aug 31 2011
On my system : KDE 4.6.5 && PyQt4 4.8.3 - Aug 31 2011
Try this :
http://fpaste.org/tbZw/

but I'm not sure that plasmoid will work,
because cmake compile executable file, but not library... May be KDE find cpu_freq_helper there. - Aug 30 2011
And : lib64 used for x86_64 system only, Else lib directory is used. - Aug 30 2011
May be need to copy this files for d-bus & polkit-1 correctly for your system. - Aug 30 2011
Other files installed correctly?
Because, d-bus & polkit-1 don`t work without policy, actions, service and conf files. - Aug 30 2011
Try this CMakeLists :
http://paste.ubuntu.com/677958/
run without prefixes:
cmake .
make
su -c 'make install'
Save pathtree for analize. - Aug 30 2011
Try to verify the installation of the plasmoid.
Let result, please.
It is a pathtree of plasmoid:
http://fpaste.org/UEz7/

IBus can not interfere with the plasmoid, but try restart it (IBus) and then run plasmoid (or in plasmoidviewer). - Aug 30 2011
Try copy\move cpu_freq_helper to /usr/local/lib{64}/kde4/libexec - Aug 30 2011
Necessary to clarify:
path to install the system Plasmoids
(like these:
/usr/share/kde/apps/plasma/plasmoids/<plasmoid-name>
/usr/share/kde4/apps/plasma/plasmoids/<plasmoid-name>
)
path to install cpu_freq_helper
(either:
/usr/local/lib{64}/kde4/libexec -- default path
/usr/libexec/kde4 -- for Fedora)

For example, default install pathtree:
http://fpaste.org/ez0X/

see for:
http://techbase.kde.org/Development/Tutorials/KAuth/Helper_HowTo#Needed_macros_and_CMake

But org.freedesktop.auth.cpufrequtility.conf not running d-bus client in Fedora for default path. And using /usr/local directory not preferably in Fedora. So, you can change CMakeLists.txt according to the documentation (Needed_macros_and_CMake). This should not be very difficult.

plasmoid pathtree:
http://fpaste.org/UEz7/

If you find out exactly the way for the plasmoids, then I will help you fix the CMakeLists.txt . - Aug 30 2011
This means that in your System plasmoids installed differently as in Fedora. - Aug 29 2011
$ su -c 'make install'
***
Install the project...
-- Install configuration: "RelWithDebInfo"
-- Installing: /usr/libexec/kde4/cpu_freq_helper
-- Removed runtime path from "/usr/libexec/kde4/cpu_freq_helper"
-- Installing: /usr/share/polkit-1/actions/org.freedesktop.auth.cpufrequtility.policy
-- Installing: /etc/dbus-1/system.d/org.freedesktop.auth.cpufrequtility.conf
-- Installing: /usr/share/dbus-1/system-services/org.freedesktop.auth.cpufrequtility.service
-- Installing: /usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/metadata.desktop
-- Installing: /usr/share/kde4/services/kde-plasma-cpufrequtility.desktop
-- Installing: /usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/code/main.py
-- Up-to-date: /usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/icons/conservative.png
-- Up-to-date: /usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/icons/ondemand.png
-- Up-to-date: /usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/icons/performance.png
-- Up-to-date: /usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/icons/powersave.png
This a install paths (for Fedora). Check it. Then, configure SELinux. May be need reboot for register cpu_freq_helper d-bus client. - Aug 29 2011
ALSA Volume Control plasmoid

Plasma 4 Widgets 62 comments

by F1ash
Score 83.0%
Apr 01 2014
This means that you need to find a Debian package, which supports module for python alsaaudio. - Aug 11 2011
Plasmoid designed to change its size with the change in the height/width of the panel. For vertical panel need to change the orientation of the plasmoid in the Settings.
Maybe I do not quite understand you correctly. - May 31 2011
Simple Spacer plasmiod

Plasma 4 Widgets 2 comments

by F1ash
Score 74.3%
Apr 07 2011
I have KDE 4.6.5, so I can not test it myself. Perhaps there is an error message in ~/.xsession-errors. - Jul 29 2011
BeClock

Various KDE 1.-4. Improvements
by thomas12777

Score 85.2%
9   Jan 18 2012