Image 01
profile-image

josvanr

jo svanr
XFCE Screenshots
deKorator Themes
GTK3 Themes
Utilities
XFCE/XFWM4 Themes
Xfce / CDE theme desktop screenshot

XFCE Screenshots 3 comments

Score 58.0%
Apr 15 2018
Thnx! Please see https://www.opendesktop.org/p/1231025/
- Jul 13 2019
CDE / Motif theme

GTK3 Themes 68 comments

Score 81.7%
May 07 2018
Great, thnx ! Hm yes I hope I'll ever be able to work on this again.. - Mar 17 2019
Ok. Aha that sounds like you have python3 whereas I still had python 2.7. I think 3 uses print() where in 2 one could use print etc without (). I must port the scripts one day. Dont know how much work that is... - Feb 17 2019
PS are you running cdepanel.py from the scripts directory or the 'binary' (cdepanel)? The latter has been 'compiled' for xubuntu 17. If you want to use the theme on 18.04, you have to run the python script cdepanel.py (and also install dependencies if necessary). Maybe you could try that first in your current installation, if you haven't done so already... - Feb 16 2019
I'm running the LTS version (18.04) myself and it works fine here. Not sure how to fix the problem in 18.10, but itdoesnt seem to be an issue with the cdetheme itself. So I guess you can either do some more digging, or just install 18.04. Then it should work right away - Feb 16 2019
wait it seems to be some other problem:

https://bbs.archlinux.org/viewtopic.php?id=235643
- Feb 16 2019
hello! Hm I'm not sure what the error messages mean, but maybe you can try using a different font. The font is not yet in the config file, but you can define it in cdepanel.py. Just look for 'Globals.font'. Hope it helps.. - Feb 16 2019
gee thnx someone actually posted a patch! If I ever get round to working on this again, I'll certainly include it. It will probably take some time, though, probably at the next stable xubuntu release (when I upgrade). Or you could start your own release of course :) - Feb 02 2019
hmm no. I think PyQt uses sip. I included it manually in cdepanel.py but its not necessary I believe. Maybe its a version conflict. Are all modules you installed for python 2.7? (sip, PyQt4 etc) - Dec 29 2018
Thnx! Hm it will be some time for I can look into this again. What happens if you run gtk-launch separately (from a terminal)? Maybe you can try sudo apt upgrade and sudo apt update or something, try and fix broken dependencies.. - Sep 30 2018
thnx btw for your contribution, if that was you ! - Sep 03 2018
hi Roffez, right, you can't. In CDE, the text colors are calculated from the background they are on. Black for light backgrounds, white for dark ones. So I replicated that calculation (got the code from MWM). If you want to set it manually, you would need to do some hacking............. - Sep 03 2018
Hmmm I seem to be unable to set the gtk theme in the live usb version (gnome-tweaks can't be installed). Dont know if I'll get around to do a full install. Maybe you can try and look for error messages if you start an application from the command line. The gtk3 errors should be visible then... - Aug 28 2018
Hello!

I'll release an update sometime soon but if you want to try in the meantime:

please delete the directory ~/.themes/cdetheme/gtk-2.0/bak , that seems to cause the trouble.

Unfortunately, the panel app doesnt seem to work too well with kubuntu, but the gtk themes do. - Aug 28 2018
ok thnx. Hmm I may be able to try that from live cd. What application is this? Same for Gimp? - Aug 22 2018
thnx! Hm yes that would be nice. But I doubt I can find the time for that. Since my last upload, I haven't even found the time for simple maintenance.. but who knows, someday... - Aug 22 2018
Thnx! Hm in my distro (xubuntu 18.02) it seems to work. What distro are you using? - Aug 22 2018
what do you mean with 'panels' ? - Jul 13 2018
prastitje daitje mnje el screen shot - Jul 13 2018
have you installed all required python modules?

sudo apt install python-dev build-essential python-sip-dev python-sip-dev libpythonqt-dev libqt4-dev libqt4-dev libqt4-dev python-qt4-dev python-qt4 python-yaml python-xdg python-pil python-pip
- Jun 17 2018
Hellø, Thnx ! Aha ok hmm ... It may be due to the python version. I used 2.7, which doesnt need parenthesis. But in python 3 you do need that. Maybe you can try to change the first line: #/usr/bin/python to #/usr/bin/python2.7 to see if that works. Dont know if that is the correct way to do this, but if you have 2.7 installed it should work.
- Jun 17 2018
Hello

aha ok hmm it would be something like

tar -xf cdetheme1.3.tar.gz
cd cdetheme1.3
mkdir ~/.themes
cp -r cdetheme ~/.themes

But the easiest woudl be to just install Xubuntu 17.10 and run ./cdepanel in the 'cdetheme1.3' directory.
- May 13 2018
hello, I just tried it on ubuntu mate 17.10 (sorry I now see you have 16, but should work too). Please copy the directory 'cdetheme' into your ~/.themes directory (.themes directory inside your home directory). Then go into Appearance Preferences and pick one window decoration style and pick 'customize' There you can see 'cdetheme'.. But the window decorations only work for XFCE. So if you want the full package, you need to install XFCE..... - May 12 2018
Hi Gyll, THNX Yes please, if you have any tips.. Some things I justwansnt able to figure out how to do. Your setups look pretty consistent so you probably know more than I haha. So yes I'd be happy to receive your help. I'll find some time to look into it. Dont know if it is possible to send a PM via this platform?
- Apr 26 2018
https://www.youtube.com/watch?v=0aRtupiY9Dw

;) - Apr 25 2018
Thnx !
- Apr 25 2018
QTStep

Kvantum 12 comments

by abgr
Score 72.2%
Nov 04 2018
+ - Oct 09 2018
Belle Pintos Grande

GTK3 Themes 48 comments

Score 75.0%
Jul 31 2019
thnx yes, I think I found it ! - Jun 12 2018
Thnx that looks great ! Hm I was wondering what app you used for the screenshot showing all widgets at once? Thnx..
- Mar 30 2018
XFCE like TWM

XFCE/XFWM4 Themes 3 comments

Score 63.3%
Jun 07 2018
I like it !
- Jun 07 2018
Glazy XFCE

XFCE/XFWM4 Themes

Score 58.0%
Dec 07 2018
aha interesting... hmm are you using FVWM with Xfce?... - Apr 28 2018
cdepanel

Utilities 3 comments

Score 58.0%
Apr 25 2018
haha thnx yes it is included ! :) - Apr 26 2018
nineties

XFCE Screenshots 2 comments

Score 50.0%
Jul 10 2017
ah yes ! An elelegant wm from a more civilzed age - Apr 15 2018
McOS-XFCE-Edition

XFCE/XFWM4 Themes 38 comments

Score 82.1%
Sep 07 2018
A 13193 line theme. respect ! Looks great too :) - Apr 15 2018
GTK 3 Theme Template

GTK3 Themes 10 comments

by unkie
Score 77.5%
May 28 2011
Hm this would be a great thing to have, a simple but complete theme template. - Apr 11 2018
OneStepBack

GTK3 Themes 115 comments

by jpsb
Score 79.0%
Jul 08 2018
aha... ok thnx for the tip! I thought I tried that out (commenting it out) but maybe I was editing the wrong file again ;) - Apr 10 2018
Hello ! I've been studying the css of your themes and am a bit mystified about how the scrollbar buttons know that they both have to sit on one side of the scrollbar.(and not one on each side). Cant find how this is coded. Can you give me a hint? thnx - Apr 09 2018
YES ! It works :) In the theme's directory I now made 2 directories: one called gtk-3.16 containing the files of the older theme and a dir gtk-3.20 containing the newer files. With this setup, it works on both xubuntu 16.04 and 17.10. Maybe you can include the older one in your distr. too..

anyway, thnx for helping me out !

Jos - Apr 08 2018
aha! thnx I didn't know that ! Ok so I looked up libgtk3 in synaptic. On 16.04 it seems to be 3.18.9-1 and on 17.10 its 3.22.25-0 Hmm but wait then I dont get the numbering. In the .themes directory there are subdirs like 'gtk-3.0' Shouldnt that then be 'gtk-3.22' or something?...

Jos - Apr 07 2018
thnx yes LTS... Please see:

ldd /usr/bin/pavucontrol |grep gtk
libgtkmm-3.0.so.1 => /usr/lib/x86_64-linux-gnu/libgtkmm-3.0.so.1 (0x00007fb42998f000)
libcanberra-gtk3.so.0 => /usr/lib/x86_64-linux-gnu/libcanberra-gtk3.so.0 (0x00007fb428e79000)
libgtk-3.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-3.so.0 (0x00007fb428339000)
- Apr 07 2018
Great ! It works well and colors can be modified easily. Unfortunately gtk3 doesnt seem to work on xubuntu 16.04. Which is strange because it does work on 17.10, which seems to have the exact same libraries. At least for pavucontrol if I do

ldd /usr/bin/pavucontrol |grep gtk

I get the exact same libraries, both on 16.04 and 17.10. But on 16.04 it doesnt work, and on 17.10 it does... so yes... Maybe just better wait until the older gtk3 versions just die out..
- Apr 07 2018
MWM / CDE / MOTIF Window Decorations

deKorator Themes 3 comments

Score 67.1%
Nov 26 2012
thnx. Due to limitations of deKorator you need to place the minimize button in the utmost left position (most left button on the left side of the window) and the maximize button on the right side. All other buttons need to be on the right side of the window (left of the maximize button). Then it looks ok. I couldn't find another way to make it work... - Dec 19 2012
deKorator

Various KDE 1.-4. Styles 133 comments

Score 77.8%
Aug 04 2017
hi

thanx for writing deKorator! I'm trying to make an mwm/cde style window decoration. I want to have the buttons and title bar colorized in the current color scheme's colors. It seems to work fine for the title bar, window borders and button background, but the buttons themselves dont seem to colorize. 1) when I disable 'colorize buttons' the buttons appear in the color of the png file, as they should 2) when I enable 'colorize buttons' the buttons appear grey, independent of the color scheme i pick. So they don't seem to colorize, but appear in a single grey color... helpppp.... - Jan 01 2009
XFCE like TWM

XFCE/XFWM4 Themes
by Moimeme

Score 63.3%
Jun 07 2018
BeOS Again v1

XFCE/XFWM4 Themes
by antice

Score 63.3%
May 14 2018
Fvwm-4Dwm

FVWM Themes
by jct007

Score 63.3%
Apr 28 2018
Glazy XFCE

XFCE/XFWM4 Themes
by novomente

Score 58.0%
Apr 28 2018
QTStep

Kvantum
by abgr

Score 72.2%
9   Oct 09 2018
+