gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

Please see my response to the "same hrere” thread below and let me know if you still have any problems getting the plasmoid to work.
- Apr 01 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

It seems to work fine for me in a virtual machine. I installed a clean copy of Kubuntu using the 9.04 beta iso image, installed all updates, and then installed the “python-plasma” package. After doing this the plasmoid installs and runs with no problems.

Please let me know if you are still having this problem or if I have misunderstood what your issue is.
- Apr 01 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

I cannot right now because I am out of town on business, but I will try to install Kubuntu in a virtual machine later this week and see if I can get it working. I will report back as soon as I find anything useful. However, if anyone else has gotten the plasmoid working under Kubuntu it would be great to hear how you did so. - Mar 29 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

Thanks for the comment. If you want to use that icon in the background you can do so because the icon is configurable. However, since the icon you suggest looks quite nice, I would be interested in knowing what license it is under. If it is under a compatible license I can look into making it the default icon. - Mar 21 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

I believe that the python script engine for plasma was only added as of KDE version 4.2, so you may need to upgrade to the latest version of KDE for this plasmoid to work. - Mar 21 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

I have posted a new version, version 0.4, that will hopefully fix this problem. I was being stupid when determining where the notifyrc file should be located. Please let me know if this new version solves your problem or if anything else is not working as expected.
- Mar 20 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

Hopefully we can solve this problem. The notification configuration is stored in the following file:

~/.kde4/share/apps/gmail-plasmoid/gmail-plasmoid.notifyrc

The first thing would be to make sure that this file exists and has something in it. If this file is missing then it will have to be created and I can tell you what the contents should be (the plasmoid should create the file if it does not exist, but it is possible that it failed). If the file does exist then I am not sure why the KDE notification system is not picking it up. It is possible that restarting KDE might help or maybe your distribution stores the KDE configuration files in a different location.

I hope the above helps, and please let me know if I can be of more assistance or if you solve the problem.
- Mar 20 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

I'm glad you got it working and thanks for posting this information because it might be helpful for others having similar problems. Also, I hope to have a new version out soon that has more robust error handling and some new features.
- Mar 19 2009
gmail-plasmoid

Plasma 4 Extensions by mjmccans 397 comments

Thanks for the feedback and hopefully we can get this working for you. It would be helpful if you could provide the following: (1) the error message returned and (2) the version of KDE you are using.

A common error is “Could not create a python ScriptEngine for the gmail-plasmoid widget,” which means that the plasma python script engine is not installed on your system. Another way to test this is if any of the other python based plasmoids work for you.


- Mar 19 2009