Image 01
profile-image

NForce

NForce . Kaunas, Lithuania
Radio Lithuania

Amarok 2.x Scripts by kliurka 2 comments

O, pagaliau ir mes sulauk─Śm :) - Nov 30 2009
kbluetooth

System Software by afiestas 58 comments

The ebuild in portage was fixed, now it builds fine. Still, don't know why was that happening with original tarball and manual compiling too - Nov 12 2009
kbluetooth

System Software by afiestas 58 comments

I am trying to compile RC2 on my 64bit gentoo box, but i always get this error:
Linking CXX executable kbluetooth
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lKDE4Workspace__solidcontrol
collect2: ld returned 1 exit status
make[2]: *** [src/kbluetooth] Error 1
make[1]: *** [src/CMakeFiles/kbluetooth.dir/all] Error 2
make: *** [all] Error 2 - Nov 12 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Version 0.6 works fine for me at last :) Great job! - Aug 17 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Don't know, but it worked for sure...I'll test the updated version on monday :) Great plasmoid by the way, I was looking for something like that since kde 4.0 :) - Aug 14 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Here it is: http://pastebin.com/m68dfb61c
P.S. sorry for the flood before, the site is working awfully - Aug 14 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Feels like it is fixed :) But now there's another problem. If i uncomment this line
sensor name="Core0Unit" type="engine" cmd="systemmonitor:lmsensors/k8temp-pci-00c3/temp2:units"
then it shows me broken dependency error on that line:
value key="Core0 Temp" use="Core0Temp" format="$1C"
P.S. Previously it was
value key="Core0 Temp" use="Core0Temp" use="Core0Unit" format="$1$2" and it worked! - Aug 14 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Feels like it is fixed :) But now there's another problem. If i uncomment this line
sensor name="Core0Unit" type="engine" cmd="systemmonitor:lmsensors/k8temp-pci-00c3/temp2:units"
then it shows me broken dependency error on that line:
value key="Core0 Temp" use="Core0Temp" format="$1C"
P.S. Previously it was
value key="Core0 Temp" use="Core0Temp" use="Core0Unit" format="$1$2" and it worked! - Aug 14 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Feels like it is fixed :) But now there's another problem. If i uncomment this line
sensor name="Core0Unit" type="engine" cmd="systemmonitor:lmsensors/k8temp-pci-00c3/temp2:units"
then it shows me broken dependency error on that line:
value key="Core0 Temp" use="Core0Temp" format="$1C"
P.S. Previously it was
value key="Core0 Temp" use="Core0Temp" use="Core0Unit" format="$1$2" and it worked! - Aug 14 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Feels like it is fixed :) But now there's another problem. If i uncomment this line
sensor name="Core0Unit" type="engine" cmd="systemmonitor:lmsensors/k8temp-pci-00c3/temp2:units"
then it shows me broken dependency error on that line:
value key="Core0 Temp" use="Core0Temp" format="$1C"
P.S. Previously it was
value key="Core0 Temp" use="Core0Temp" use="Core0Unit" format="$1$2" and it worked! - Aug 14 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Feels like it is fixed :) But now there's another problem. If i uncomment this line
sensor name="Core0Unit" type="engine" cmd="systemmonitor:lmsensors/k8temp-pci-00c3/temp2:units"
then it shows me broken dependency error on that line:
value key="Core0 Temp" use="Core0Temp" format="$1C"
P.S. Previously it was
value key="Core0 Temp" use="Core0Temp" use="Core0Unit" format="$1$2" and it worked! - Aug 14 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Just found out that it is unneccessary to comment out those lines. Plasma started - plasmoid shows me error on kernel line. I hit "reparse" - plasmoid shows me error on some wlan line. I hit reparse - it works!
P.S. When i hit reparse for first time - plasma crashed - Aug 10 2009
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Extensions by finkandreas 301 comments

Hey, i've edited the default script so it fits my needs, but i have the same error every time plasma is started: You have broken dependency in line value key="Kernel" use="KernelVersion". If i comment that line out, and one other line, it starts working, then i can uncomment those commented lines and it just keeps working. But every time plasma is started - the error happens. KDE 4.3, gentoo. I am using this script: http://pastebin.com/m50d51181

P.S. it happens with original script, which is included in the tarball, too - Aug 10 2009
Weather Wallpaper Plugin

Plasma 4 Extensions by jmthomas 37 comments

Hello again. I was not happy to have Air wallpaper for half an hour after start (because of not immediate internet connection), so i've made a very simple little patch, which allows me to use last used wallpaper if no connection. Here it is:
--- weather.cpp 2009-04-07 17:51:13.000000000 +0300
+++ weather.cpp 2009-04-08 23:47:04.000000000 +0300
@@ -52,6 +52,7 @@

void WeatherWallpaper::init(const KConfigGroup & config)
{
+ m_config = config;
m_weatherUpdateTime = config.readEntry("updateWeather", 30);

// Connect to weather engine.
@@ -61,6 +62,7 @@
// Set custom options
m_ionPlugins = m_weatherEngine->query("ions");

+ m_wallpaper = config.readEntry("wallpaper");
m_activePlace = config.readEntry("place");
m_activeIon = config.readEntry("ion");
m_extraData[m_activePlace] = config.readEntry("data");
@@ -503,6 +505,7 @@
m_wallpaper = QString(m_dir + "Icy_Tree");
}

+ m_config.writeEntry("wallpaper",m_wallpaper);
loadImage();
emit update(boundingRect());
}

(this is for weather.cpp)

--- weather.h 2009-04-07 17:36:23.000000000 +0300
+++ weather.h 2009-04-08 23:47:26.000000000 +0300
@@ -76,6 +76,7 @@
private:
QWidget* m_configWidget;
KDialog *m_addDialog;
+ KConfigGroup m_config;
Ui::weatherLocations locationsUi;
Ui::weatherAddPlace addUi;
QStandardItemModel *m_amodel;

(and this one is for weather.h) It would be nice if you use them :) - Apr 08 2009
Weather Wallpaper Plugin

Plasma 4 Extensions by jmthomas 37 comments

Here is PKGBUILD for ArchLinux:

pkgname=plasma-weather-wallpaper-plugin
_pkgname=plasma-wallpaper-weather
pkgver=0.2.1
pkgrel=1
pkgdesc="Plugin for Plasma dekstop which sets wallpaper as the weather changes"
arch=('i686' 'x86_64')
url=""
license=('GPL')
depends=('kdebase-workspace')
makedepends=('cmake' 'automoc4')
source=("https://edge.launchpad.net/%7Eechidnaman/+archive/ppa/+files/plasma-wallpaper-weather_$pkgver.orig.tar.gz")
md5sums=('94177bfca63db13bbbb0d837bd36a606')

build() {

cd ${srcdir}/${_pkgname}-${pkgver}/
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` .. || return 1
make || return 1
make DESTDIR=$startdir/pkg install || return 1
} - Apr 08 2009
Weather Wallpaper Plugin

Plasma 4 Extensions by jmthomas 37 comments

Nice idea :) But it's unusable for me for now :( At system start I have no internet connection (using wi-fi which connects in 1 minute after start) so I have no wallpaper too. It would be great if it used last used wallpaper if no connection. And it would be great if it had a possibility to try if there is a connection. Without it - i would have to wait 30 minutes for wallpaper change. - Apr 05 2009
STasks

Plasma 4 Extensions by mbaszczewski 445 comments

No, it's not the case. Whole grouping thing does not work as it should, and its not because of the stasks. I just had Dolphin and Dolphin <2> been grouped, but when i repeated - nothing grouped - Mar 25 2009
STasks

Plasma 4 Extensions by mbaszczewski 445 comments

You could use different windows instead of tabs, then they will be shown in taskbar. Of course you could do that when grouping will normally work (KDE 4.3? Did someone report that bug in KDE's bugzilla?) - Mar 22 2009
STasks

Plasma 4 Extensions by mbaszczewski 445 comments

"...desktop settings off..."
I mean "desktop effects off" - Mar 21 2009
STasks

Plasma 4 Extensions by mbaszczewski 445 comments

I've made a patch for that:

--- stasks_tooltip.cpp 2009-03-21 01:53:56.000000000 +0200
+++ stasks_tooltip_patch.cpp 2009-03-21 19:40:48.000000000 +0200
@@ -56,6 +56,23 @@
}
};

+class QClickableLabel : public QLabel
+{
+public:
+ void setWindow(WId window)
+ {
+ m_window = window;
+ }
+private:
+ WId m_window;
+protected:
+ void mousePressEvent(QMouseEvent *event)
+ {
+ KWindowSystem::forceActiveWindow(m_window);
+ event->accept();
+ }
+};
+
STasksToolTip::STasksToolTip(int size, QWidget *parent) : QWidget(parent)
{
setWindowFlags(Qt::ToolTip);
@@ -221,10 +238,12 @@

m_tasksLayout->addWidget(iconLabel, 0, (i*3),1,1);

- QLabel *label = new QLabel(tasks.at(i)->name());
+ QClickableLabel *label = new QClickableLabel;
label->setMaximumWidth(160);
+ label->setText(task->task()->name());
+ label->setWindow(task->task()->window());
m_tasksLayout->addWidget(label, 0, (i*3)+1,1,1);
-
+
CloseIcon *iconClose = new CloseIcon;
iconClose->setMaximumWidth(20);
iconClose->setTask(task);
- Mar 21 2009
STasks

Plasma 4 Extensions by mbaszczewski 445 comments

One more bug - if I open a group with desktop settings off - i can't access any of the windows minimized in that group. It simply does nothing - Mar 21 2009
STasks

Plasma 4 Extensions by mbaszczewski 445 comments

Nice...But damn, grouping is almost dead :( It worked only with VLC. I've tried skype (2 chats, main window, settings window) and i've got 4 independent tasks. Tried Firefox (Two main windows, settings, downloads, addons) - got 5 tasks...Tried with dolphin also - opened it once, then another copy - two independent tasks. By the way, original kde4.2 task bar suffers from same glitches, is it possible to get this stuff working? - Mar 20 2009
Magic Folder

Plasma 4 Extensions by bizzl 66 comments

Damn, while I was waiting for a fix, I wrote my own version of this plasmoid :D - Mar 14 2009
Magic Folder

Plasma 4 Extensions by bizzl 66 comments

I mean "call "kquitapp plasma"" - Mar 12 2009
Magic Folder

Plasma 4 Extensions by bizzl 66 comments

Version 1.0.1 still fails to init after reboot, and crashes plasma when i cla "kquitapp plasma", so in any way settings are not saved( - Mar 12 2009
STasks

Plasma 4 Extensions by mbaszczewski 445 comments

Great plasmoid! But in 0.4 performance is much lower than in previous versions on my pc :/ Animation looks laggy with compositing on, with my ati x1250 video card - Mar 10 2009
KDE Mobile Edition - UIQ3

Phone Themes by brdn25 5 comments

Need to port that for my phone :) Can you upload the sources somewhere? Such as icons, progressbars :) And player - Feb 03 2009
Linux

Wallpaper Other by Yulia 1 comment

Wow, great job. Nice to see wallpapers as good as this - Jan 13 2009
kde-style

Wallpapers KDE Plasma by Yulia 2 comments

Nice. Keep up the good work :) - Jan 12 2009
8 .2
Aug 10 2009
STasks

Plasma 4 Extensions
by mbaszczewski

6 .5
Feb 23 2009